Unusual TTCB Behavior (playback issues) on Mac

Discussion in 'TiVo Home Media Features & TiVoToGo' started by darksurtur, Sep 23, 2008.

  1. darksurtur

    darksurtur Member

    157
    0
    Jan 2, 2008

    Advertisements

    I've just started playing around with the TiVO network features on my series 2 DT and have gotten most of it working smoothly. However, I am having a strange issue with playback of converted avi files on the TiVO using Tivo Desktop Mac to transfer back.

    I am able to successfully convert the files using ffmpegx to mpeg2 (with a mp2 audio stream) at 544x480 and 4:3 aspect ratio. Some of these files are in 4:3 original aspect ratio, and some are in 16:9 aspect ratio, so I use the letterbox fields to add black lines to the top and bottom of these latter files. Encoding is 1024 to 1500Kb/s. The files convert successfully and appear to play normally on VLC, and the 4:3 files play fine on the TiVO (with some small clipping on the right and left edges, nothing to worry about). However, the files that were originally in 16:9 play very oddly, with heavy vertical lines in the image, graininess and a zoom in to the upper right corner of the image, as if its playing a much smaller resolution file.

    To test things, I created a TiVO compatible mpeg file from a 16:9 movie using VisualHub demo and it transferred and played fine. Now I have no problems buying VisualHub and using that for conversions - it's a great program - but I do want to know what I did wrong, because MediaInfoMac shows exactly identical settings for my files and VisualHub's files save for file size. Did I calculate the letterbox pixel sizes wrong, and would it cause this kind of error? (I calculate 87 now, but may have used 78 when encoding; I can't figure out how to check. What is the right size?) I can't see how, since the file ends up being 544x even if it stretches some due to miscalculation? Did I set something wrong in regards to aspect ratio? I can only seem to set resolution, and 544x480 does not equal 4x3.

    For reference, I have a 649 series 2 DT TiVO with a TIVO brand wireless adapter and a Powerbook G4 running OX 10.4.11.

    Any help would be greatly appreciated!
     
  2. bedelman

    bedelman Call me Bob

    3,564
    0
    Feb 26, 2001
    Crystal...
    Personally, I use the (now unsupported) TiVo.NET (TiVo Dot Net) application and others use PyTiVo for the Macintosh. There's no file conversion needed for things like AVI files and a bunch of other formats. The Macintosh just shows up on the TiVo box's Now Playing List and go from there.

    Converting to MPEG-2 is a pain and I stopped doing that well over a year or so ago.

    I do still use TiVo Desktop to handle .tivo files that I haven't converted/processed though.
     
  3. Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008
    I'll second the suggestions to try the pyTivo route as it will handle the conversions for you. And if you have .tivo files that were created from Tivo units on your account (all sharing the same Tivo MAK), pyTivo will happily serve them back to your Tivo without the need for conversion.

    I recently built and posted an updated ffmpeg binary for G5 Macs making it much easier to get pyTivo up and running for Mac OS X. The setup has been reduced to:

    1) Get updated python using Mac OS X installer DMG from http://www.python.org/download/

    2) Grab a pyTivo fork distribution, extract it, and rename the folder to pyTivo. I suggest either wgw OR wmcbrine's forks.

    Visit the appropriate link below and click the snapshot link on the far right for the first line under shortlog to download the corresponding .tar.gz file.

    wgw's fork
    http://repo.or.cz/w/pyTivo/wgw.git

    wmcbrine's fork
    http://repo.or.cz/w/pyTivo/wmcbrine.git

    3) Grab my ffmpeg binary, extract it and drop into the pyTivo folder:
    http://pytivo.krkeegan.com/rdian06-s-ffmpeg-builds-t468.html

    4) Copy the pyTivo.conf to create your own with a few basic settings following the directions at:
    http://pytivo.armooo.net/wiki/ConfigurepyTivo

    You basically just need to set the ffmpeg path and the share folder path to your movies.

    5) Launch pyTivo.

    Launch Terminal.

    cd to the pyTivo folder. (Type "cd ", then drag the pyTivo folder to the Terminal window to insert the path automatically. Then hit Enter.)

    Then type "python pyTivo.py" and check the Now Playing list on your Tivo.

    (Yeah, it's still not a one click fire and forget install, but it's a lot simpler than having to compile your own ffmpeg via Macports.)
     
  4. darksurtur

    darksurtur Member

    157
    0
    Jan 2, 2008
    Thanks for the quick replies!

    I had considered pyTiVO when I started networking, but the installation process for Mac seemed so daunting. The streamlined instructions sound great, and I’ll give them a shot and hope they work on a G4 Powerbook. I’ll report in once I’ve tried, but it’ll be a few days until I get around to it. Still, it would be nice to know what I did wrong in the original conversion process, if only for my own edification.
     
  5. darksurtur

    darksurtur Member

    157
    0
    Jan 2, 2008

    Advertisements

    Ok, I've tried for a while to get this working, but no go. pyTivo installs and sets up correctly - I can see my files - but I can transfer them. I always get a "transferring is prohibited copyright" error, which I take it means ffmpeg isn't resolving the video file.

    So I tested the precompiled version you linked to and it gave me the following error:
    g4:~ comp$ /Applications/pyTivo/ffmpeg -formats
    Illegal instruction
    g4:~ comp$

    Assuming that means it isn't working at all on my machine (is it because I have a Powerbook G4?), I extracted the working ffmpeg from the latest ffmpegx install. It works and says:
    g4:~ comp$ /usr/local/bin/ffmpeg -formats
    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    configuration: --enable-mp3lame --enable-gpl --disable-vhook --disable-ffplay --disable-ffserver --enable-a52 --enable-xvid --enable-faac --enable-faad --enable-amr_nb --enable-pthreads --enable-x264
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    built on Apr 15 2006 08:41:02, gcc: 3.3 20030304 (Apple Computer, Inc. build 1666)
    [list of formats snipped]

    But I still get the transferring prohibited error with every video file I've tried, e.g. this won't play:
    g4:~ comp$ /usr/local/bin/ffmpeg -i /Users/comp/TiVO/Bleach80.avi
    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    configuration: --enable-mp3lame --enable-gpl --disable-vhook --disable-ffplay --disable-ffserver --enable-a52 --enable-xvid --enable-faac --enable-faad --enable-amr_nb --enable-pthreads --enable-x264
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    built on Apr 15 2006 08:41:02, gcc: 3.3 20030304 (Apple Computer, Inc. build 1666)

    Seems that stream 0 comes from film source: 30000.00 (30000/1) -> 23.98 (24000/1001)
    Input #0, avi, from '/Users/comp/TiVO/movie80.avi':
    Duration: 00:22:54.4, start: 0.000000, bitrate: 1049 kb/s
    Stream #0.0, 23.98 fps(r): Video: mpeg4, yuv420p, 640x480
    Stream #0.1: Audio: mp3, 44100 Hz, stereo, 96 kb/s
    Must supply at least one output file
    g4:~ comp$

    My config file is:
    [Server]
    port=9032
    ffmpeg=/usr/local/bin/ffmpeg

    [My Movies]
    type=video
    path=/Users/comp/TiVO/

    I'm at a loss here; it *should* be working, right? What else can I try?
     
  6. Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008
    That build I linked was compiled with G5 optimizations. I'll see if I can change the options and compile it for G4 today. But I don't have a G4 to test it on.

    Hrmm, using ffmpegX's ffmpeg binary looks like it should work. Try putting debug=true into the Server section of the conf file and then watch what pyTivo outputs in it's Terminal window when you initiate the transfer.
     
  7. darksurtur

    darksurtur Member

    157
    0
    Jan 2, 2008
    Ok, when I debugged, I got a decode/encode error, suggesting that no, ffmpegx's file wouldn't work. So I just bit the bullet and compiled my own version of ffmpeg and lame by installing XCode and Macports. It took forever and I had some missteps along the way, but by then it was a matter of pride. Besides, Macports is a nice thing to have access to, just in case. And it worked - I transferred over my files and they play! Thanks for all your help!
     

Share This Page

spam firewall

Advertisements