TTG: Tivo DVR busy with another transfer?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by richwiss, Jan 9, 2005.

  1. Jan 9, 2005 #1 of 27
    richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    Just TTG on one of two machines in the house. (The other machine has not received the upgrade yet). Windows XP running server v.2.0. My network is completely wired, so there's no wireless issues at all. I have never (and still don't) have a problem with HMO playing music or viewing photos.

    The server software pulls the playlist, let's me choose a show, and then hit transfer. After a few seconds, I get the message "The TiVo DVR is busy with another transfer. This recording will begin to transfer when the DVR is available." I've checked and double checked and there is no transfer going on between the DVRs. I've even rebooted the DVR and force-connected to make sure there wasn't a further update (this was suggested elsewhere). I've also tried disabling Norton Anti-virus (also suggested elsewhere).

    Sometimes I'll get the message "This transfer is not making progress", but usuallys it's the "busy with another transfer" error.

    Any other ideas?

    :confused:
     
  2. bigbrihaze

    bigbrihaze New Member

    20
    0
    Jan 18, 2004
    San Diego, CA
    Ok, I just found your post....I am having the SAME issue. My first day thoug, it worked fine. I cannot get it to work again
     
  3. richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    What's really weird now is that it still doesn't work from the TiVo Desktop software, but from my PowerBook laptop, I can use the http interface and download shows with no problem. So, now I know the problem isn't the TiVo alone, and possibly it's a Windows XP problem. I've tried with and without firewalls, with and without QoS on the connection, and with and without Symantec products (which apparently caused problems with older versions of the desktop software).
     
  4. TiVoBill

    TiVoBill New Member

    1,389
    0
    Jun 7, 2002
    If you click the "Transfer Status" button, does it show any transfers in progress? Normally you should be able to remove the stalled transfer there.
     
  5. richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    Yes, I can see the stalled transfers -- and I can delete them. But starting a new one yields the same results -- a stalled transfer.
     
  6. Duvs

    Duvs New Member

    64
    0
    Dec 7, 2004
    Maryland
    I'm getting the same errors on my Tivo as well. Initially I was transferring with no issues - but then I had one transfer time out, since then (several days, several reboots) and now i always am getting the "DVR is busy with another transfer error".

    Seems to be something on the server(Tivo) side - if I go to the https://<tivo_ip>/nowplaying and attempt to download manually with a web browser I get the same error.

    Duvs
     
  7. ellinj

    ellinj Seems Very Friendly TCF Club

    13,117
    189
    Feb 26, 2002
    NoVa
    Did you try rebooting the Tivo? I had this issue do to what I believe was cancelling a d/l via the web interface. rebooting the tivo cleared it up.
     
  8. Duvs

    Duvs New Member

    64
    0
    Dec 7, 2004
    Maryland
    Rebooted a couple times (Through Tivo Settings -> Restart) but the problem continues.
     
  9. richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    I too rebooted a bunch of times with no luck.
     
  10. Duvs

    Duvs New Member

    64
    0
    Dec 7, 2004
    Maryland
    I guess I'll bite the bullet and call customer service tonight to see what the deal is. HMO still works great and I can get the show listing no problem via the Desktop and the web interface. If I restart I get exactly 13 KB of the file and then it times out every time, subsequent attempts get the "DVR is busy with another transfer" error. Then I restart, get 13KB, then get the DVR is busy error. This happens with TD 2.0 and the web interface, same behavior either way.
     
  11. richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    Duvs-

    I get the same behavior from windows XP (no luck HTTP or Desktop), but from the Mac OS X, I can download through HTTP (there is no Desktop). I tried calling customer service and was pissed off when I hung up. They had me doing the most basic things than any one of us would have tried, and didn't think of anything except "Perhaps you should call Microsoft." Be prepared to get annoyed, and be sure to ask for a more senior person than the person you speak to the first time -- they're just going to read you a script.

    Good luck!
     
  12. Duvs

    Duvs New Member

    64
    0
    Dec 7, 2004
    Maryland
    richwiss -

    Finally opened my case and here is the fix that worked for me (didn't try this on my own because it seemed impossible that this could be the reason), the Tier-2 tech simply had me uninstall and reinstall the Tivo Desktop software on my PC.

    For whatever reason this freed things up and allowed shows to transfer again. Seems like a bug to me that the Desktop can't handle the slighest drop in network connectivity without causing a condition whereby you have to uninstall it and re-install. It is also strange that this condition also cascaded to the Tivo web server and gave me a server busy error. Once I reinstalled TD 2.0 I couldn't reproduce the server busy error message for the tech.

    Let me know if that works for you.

    Duvs
     
  13. fatbastard

    fatbastard New Member

    14
    0
    Jan 2, 2005
    NJ
    I have gotten similar errors and speaking to a tech was useless..first they had me unisnstall the desktop then reinstall, after that didn't work I called a gain and they had me do the same thing but also delete the tivo beacon, but I got teh same crap results. I have tried shutting off NIS but that made no difference. He then told me to call MS to have them clear the registry, I opened regedit and thought about making changes then wimped out so I restored the OS to a day back in December before the TD was installed. I checked the registry and there was nothing for tivo beacon, did the install and still nothing! I am at my wits end with this...anyone have any ideas? By the way I have never been able to transfer, before I called TiVo I could only transfer about 30MB before it would die, now I get about 7 before it times out.
     
  14. richwiss

    richwiss New Member

    19
    0
    Feb 27, 2003
    OK, so now I'm REALLY confused. My second TiVo was finally upgraded and now it turns out that I can transfer shows with no problems from one of them, but not from the other. I can see the Now Playing list on the first one and even start the transfer for a second before it stalls (as described above). From the second one, I have no problems transferring shows. So, clearly it's not exclusively the TiVo beacon or TiVo desktop software since it works just fine from one and not the other. BTW, both TiVo's are connected to a wired network with the same USB-Ethernet adapters and both can play MP3s over HMO just fine.
     
  15. Duvs

    Duvs New Member

    64
    0
    Dec 7, 2004
    Maryland
    I had similar behavior - my brothers Tivo (different account, different MAK) got updated (we live in the same house) and i could download fine from his and not from mine. Reinstall of desktop fixed it.

    I tried to get the engineer on the phone to explain just how this happens but all i got was "lets just uninstall and reinstall the desktop". I can't for the life of me figure out how something buried in the Desktop software can cause the Tivo web server to respond "DVR is busy with another transfer" when accessing through Firefox, that a reinstall of TD 2.0 would fix.

    Duvs
     
  16. TivoPip

    TivoPip New Member

    219
    0
    Feb 25, 2003
    Colorado
    I'm guessing that somewhere in the TD2 software there is some file or registry setting that controls the transfer. This is obviously not being cleared until you unistall TD2. I'd suggest that TD2 add an option to reset this information in the menus somewhere.
     
  17. morac

    morac Cat God

    11,991
    916
    Mar 14, 2003
    NJ
  18. VauxhallGuy

    VauxhallGuy New Member

    13
    0
    Dec 20, 2005
    Was a resolution ever found for this problem?
     
  19. Andrewp75

    Andrewp75 New Member

    210
    0
    Aug 4, 2004
    Washington DC
    Having this problem too, anyone every figure this out?

    Thanks!

    A
     
  20. rolandv

    rolandv New Member

    16
    0
    Dec 21, 2002
    The answer is in the link above that you guys obviously didn't check. I struggled with this problem for quite a few months. I don't know why it happens, but I do have a fix that consistently works for me.

    1) Make sure you have finished transferring what you want transfered or write down what's left in your transfer-status list.
    2) Exit TiVo Desktop.
    3) Go into the task-manager, switch to the "Processes" tab, and do a right-click "End Process" on the process "TivoTransfer.exe".
    4) Find the folder "C:\Documents and Settings\<your-windows-username>\Local Settings\Application Data\TiVo Desktop\TiVoTransfer.dat" and rename it to something else like xxTiVoTransfer.dat.
    5) Carefully read the *Note* below.
    6) Restart TivoDesktop.
    7) Transfer-status should now be empty.
    8) If you wrote-down anything queued for transfer in step 1, restart those transfers now.

    Happy TiVoing,
    ... Jolest

    *Note* that if you were transferring anything when you started this process, you will probably have one incomplete .tivo file (one with the mid-transfer-TV-program's name) and/or some zero-length .tivo files sitting in your transfer directory (and therefore in your computer's NowPlaying" list). As far as I can tell, if you delete those files while TivoDesktop is not running, TivoDesktop will remove those entries from your computer's NowPlaying list when it's next restarted... If you plan on doing this, do it BEFORE you restart TivoDesktop or you may accidently delete files you need... Be careful to ONLY delete the zero-length .tivo files (and maybe ONE other mid transfer program). DON'T delete the .tivo files for any other programs you want to keep...



    That was the original post. All I do is stop all my transfers in Tivo to go and close tivo to go. Kill the tivotransfer.exe process in the task manager. Delete Tivotransfer.dat, and delete all files in the cache folder in the path at step 4 above. Then I personally have to RESTART MY TIVO. This is a critical step, without restarting the Tivo the prior steps are worthless. After the Tivo restarts, launch Tivo 2 Go and you should be able to transfer normally.

    Oddly enough I have one show that will not transfer no matter what. Coinicidentally, it was the same episode of the show that caused my problems 2+ months ago. It will die at the same spot every time and then Tivo 2 go is broken. I've given up on that episode, it's not that important. I'm just glad the Tivo 2 go is kind of working now. It's not stable. I have to do the above steps almost everytime I want to transfer something. It's quite a pain and not very convenient at all. I wish I knew what was going wrong. I didn't have these problems prior to the most recent Tivo software update.
     

Share This Page