TS4K - setup error - can't download firmware v4734

Discussion in 'TiVo Stream 4K' started by scopus, Aug 17, 2020.

  1. scopus

    scopus Member

    59
    3
    Mar 25, 2002
    Xenia, Ohio

    Advertisements

    Just purchased a new Stream 4K from Amazon, but I can't seem to get through the setup process.
    I was finally able to pair the remote (took 3 tries - it would pair and then drop, pair then drop). Next, login to register Google w/ my account was successful using my phone.

    But I can't get to the Tivo Stream setup screens, because it's forcing a firmware update to v4734 - which fails saying "Couldn't download system update - there was a problem downloading the software update. Due to the importance of the update, it will need to be applied before you are able to continue.".

    I've tried a WIFI connection - with the TS4K unit sitting 2 feet from my router - it connects to internet but the update won't work or complete. I've also picked up an ethernet adapter from the user community "approved" list - which the TS4K does recognize and says it's connected to the internet - and it still won't complete the firmware update.

    I think I've read about firmware v4800 being released - so is there some type of issue with the sequence of firmware events that it's forcing?

    Without the update, this thing is useless. Any ideas?

    EDIT: contacted Tivo tech support - supposedly they are aware of the problem but no timeframe on fixing. Not sure if this is true or the standard script they read from?

    I might wait a few days - but I'm not waiting weeks to use a device I just purchased.
     
    Last edited: Aug 17, 2020
  2. dbpaddler

    dbpaddler Active Member

    544
    187
    Sep 25, 2004
    Philly
    Did you try a hard reset and starting from scratch? Maybe not doing the setup through an android device and trying to do not all form the TS4k?

    Sent from my SM-N975U1 using Tapatalk
     
  3. scopus

    scopus Member

    59
    3
    Mar 25, 2002
    Xenia, Ohio
    Hard reset meaning what? I've unplugged it, waited minutes... and sometimes hours... but when I reconnect the power, it resumes right at the same spot in the setup process - forcing the firmware download. If you are referring to a RESET/CLEAR through the software in some way, I see no option to do that. Is there some combination of remote key presses to achieve that? I can't get to any usable interface - ie the Android TV home screen w/ the settings option.

    The forced firmware upgrade is a roadblock.
     
  4. dbpaddler

    dbpaddler Active Member

    544
    187
    Sep 25, 2004
    Philly
    Meaning just that. It has a reset button built into the unit in case you can't do a software based hard reset. And it might only be a road block because of the way you currently tried to set it up. Which is why I'm suggesting to hard reset and just set it up purely from the device to see if that works.
    [​IMG]

    Sent from my SM-N975U1 using Tapatalk
     
    scopus likes this.
  5. scopus

    scopus Member

    59
    3
    Mar 25, 2002
    Xenia, Ohio

    Advertisements

    Thanks for the picture - LOL - clearly I need some glasses - I would have never found that little button. But the reset did the trick! I avoided using my phone for setup, and no firmware messages. Was able to fully register the device and have it working.

    THANK YOU!

    If only Tivo tech support were as helpful.
     
    Alex_7, fattymcbuckles and dbpaddler like this.
  6. dbpaddler

    dbpaddler Active Member

    544
    187
    Sep 25, 2004
    Philly
    That's why this community is here... Congrats to being up and running.

    Sent from my SM-N975U1 using Tapatalk
     
    Alex_7 and fattymcbuckles like this.

Share This Page

spam firewall

Advertisements