Trouble with wired networking: bad TiVo?

Discussion in 'TiVo Series3 HDTV DVRs' started by mbcook, Oct 11, 2006.

  1. mbcook

    mbcook Nice Guy

    175
    0
    Jun 1, 2003

    Advertisements

    I just got a Series three earlier this week and I've been having problems with the built in ethernet adapter. I'm a bit worried about this because I have a Comcast guy set to come on Friday and since the cable cards are tied to the TiVo if I had to replace the TiVo I'd have to get a guy to come out again, wouldn't I?
    So here is the situation. When I first set the TiVo up it took a couple of tries to get it to connect to my network for some reason. Nothing special about my network. The Tivo is connected to a hub that is connected to a Linksys router.

    But I'm having problems and can't connect to the TiVo service. I've tried a different hub, multiple different cables, connecting the TiVo directly to the Linksys router, different ports, etc. Nothing seems to help.

    The TiVo complains it can't find a DHCP server (it's there). If it finds that it complains about not finding a gateway (also there, same box). If THAT works, it complains about the TiVo service being unavailable.

    Now also plugged into this hub is the Wireless access point that supplies my laptop so I know there is connectivity. I hooked my laptop up by ethernet and did a TCP dump and that time the TiVo got as far as talking to the TiVo service then it gave up complaining about the service not being there.

    It did manage to get a DHCP address, look up the TiVo server, and start connecting (I stopped watching then).

    This really has me stumped. Unfortunatly I don't have a USB adapter I can test with. The TiVo recognizes it's network adapter (the Phone & Network screen shows the MAC address) and looking at my router/DHCP server I can see that it has succeeded in getting an address before (192.168.1.9 in this case).

    I just tried setting everything manually and got N07 (unable to find gateway/router). Putting it back to using DHCP (which is the correct setting for my network) gives me the N02 (unable to find DHCP).

    I think the only time it ever did it successfully was when it worked during the initial setup.

    I realize I can make it use the phone line for now, but I'd like to get it using ethernet.

    Help!

    Edit: I just remembered. About two hours after the initial setup I was fooling around online with Yahoo! TV and setup 4 or 5 season passes that did get setup correctly on the TiVo. Networking hasn't worked right since then though.

    EDIT: This has been fixed (or at least seems that way). See my post a little below from 10/13.
     
  2. snathanb

    snathanb New Member

    462
    0
    Sep 13, 2006
    Just an FYI... I had a similar problem. My router had been down for a short while, and TIVO had tried to connect and have given the no DHCP server found error.

    Even after the router was ok, it still was giving the error. I tried giving it a static IP, and that didn't help. I had to reboot the TIVO to get the networking stuff to work correctly again.
     
  3. SoBayJake

    SoBayJake Member

    407
    0
    Feb 6, 2002
    Los Angeles, CA
    Mine was quite flakey connecting to the TiVo Service for "real"..worked fine for test connections, and the games, etc.

    I ended up using a different cable, different port on the switch, AND giving it a static IP. Doing just one of those three things would improve it, but not make it great. But since I did all three, it has been doing just fine.
     
  4. Derek Nickel

    Derek Nickel TiVannosaurus Rex

    67
    0
    Oct 7, 2003
    San...
    Eek! It's happening to me as well. I just noticed my S3 hasn't successfully connected to the TiVo service for several days. Investigation shows that I'm getting the "unable to find DHCP server" (N02). The S3 is connected to a Linksys switch along with a S2DT. The S2DT works fine. I'm hoping that rebooting will help, but the S3 is currently busy doing what it enjoys doing best (recording HD).
     
  5. mbcook

    mbcook Nice Guy

    175
    0
    Jun 1, 2003

    Advertisements

    Well I continued to have problems and talked to a very nice rep at TiVo who determined that I needed to call Comcast (my ISP) and ask them to turn off something I've never even heard of before (and I know what I'm doing). Frankly I didn't believe it but I was going to do it today if I had to.

    That said, I forced a phone call last night and it managed to download an update (the previous attempt to do that failed because of people calling) and after a reboot... I have 8.0.1b.

    So I tried the network to confirm that my TiVo was bad (as that was what I was sure it was) and it picked up a DHCP lease in a blink (as opposed to a few seconds when it would manage to do it before). The test connection went through ulra-fast too. I had it connect to the service again (as a final test) and it completed that real fast too.

    Looks like 8.0.1b may have fixed my problem. I'm not too surprised because since the behavior didn't seem like a hardware fault, but I expected it would have problems (it would be just my luck recently).
     
  6. surfnutbry

    surfnutbry New Member

    12
    0
    Jan 21, 2004
    Michael,

    Just curious if you could elaborate on what Comcast needs to turn off. I have had to reboot my Tivo a number of times to fix the Ethernet port. Once it stops working I have not been able to find any way fix the problem other than a reboot.


    Bryan
     
  7. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    What was it they asked you to have the ISP turn off?
     
  8. mbcook

    mbcook Nice Guy

    175
    0
    Jun 1, 2003
    I wrote it down at home, I'm at work so I can't tell you right now. It's been mentioned once or twice on this board. It was called "Proxy Cacheing" or something wtih Proxy in it that I'd never heard of. I think both words started with a P but I'm not sure.

    Not I hadn't actually called Comcast yet, so nothing about that changed.

    I'll post it tonight when I get home and can look it up.
     
  9. bferrell

    bferrell Now in HD!

    129
    2
    Jun 22, 2005
    Cincinnati, OH
    Just for the record, my S3 is hardwired and seems to be working regularly and fine.

    Brett
     
  10. mbcook

    mbcook Nice Guy

    175
    0
    Jun 1, 2003
    OK: The term they used was "proxy paging". I should also mention that the update did... infact... NOT fix my problem. It's back. Maybe a restart will improve things. I'll have to fiddle this weekend when I have time.
     
  11. unit101

    unit101 New Member

    14
    0
    Feb 13, 2007
    Hi guys... i want to join the club. I have Tivo3 installed a few weeks ago... working fine on wired network... using same connection as Tivo2 did for year+. Saturday noticed it not on network... no gateway found N07 error... fiddled nothing worked till restart of tivo... bingo works fine...
    Tonight it was down again... only restart will fix.

    Using wired connection. swapped cable and port with other device.

    Listening to others... sounds like if Tivo loses the network it can't pick back up unless a restart.

    Hope we can figure this out...??
     
  12. jgsx

    jgsx New Member

    51
    0
    Jan 22, 2006
    My internal network adapter stopped working a long time ago. I am using an external USB adapter that I had from my old S2. I'm pissed that it died, but I can't go without TiVo long enough to send it in for repair.
     
  13. CrispyCritter

    CrispyCritter Purple Ribbon Wearer

    3,653
    2
    Feb 28, 2001
    North...
    Yes, I had this happen once. When the S3 lost the DHCP server, it would attempt to regain it every 5 minutes; my DHCP server would respond (linux fedora core DHCP server), and the TiVo would ignore the response. A TiVo bug. I had to reboot.

    If I had to venture a guess, I would say the S3 was looking for a brand new connection code after the drop, but the DHCP server was responding with a reconnection code (as it did) and the TiVo was ignoring it.
     
  14. tgibbs

    tgibbs New Member

    797
    0
    Sep 22, 2002
    Haven't had this problem so far. I'm using a D-Link router with Comcast Cable internet. Both my Series 3 and Series 2 seem to work well wired without difficulty.
     
  15. rgr

    rgr Member

    676
    58
    Feb 21, 2003
    I had/have this problem and called tech support while my series3 was still under warranty. They said the new software may resolve the problem, but didn't know for sure. Rebooting worked, but the N07 error would come back after a few days. Just got 8.1 yesterday, so am hoping that this will fix the problem.
     
  16. oldnacl

    oldnacl New Member

    168
    0
    Mar 23, 2007
    I have to chime in on this. I got a message that there were only 3 days of programing remaining, tried a connect and it failed. I have my TiVo hardwired to a wireless bridge. Since the Tivo is the only connection to the bridge, I figured it had gone down and fooled around a couple hours last night trying to reconfigure without success. This morning I strung a cable from my router and noticed no lights on at the ethernet connector. I connected the cable to my laptop and it immediately got an IP address. I unplugged the TiVo and saw the ethernet LEDS flash briefly. Plugged it back in and it's working again.
     

Share This Page

spam firewall

Advertisements