Trouble using TiVo Desktop in one direction

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Vale, Dec 23, 2005.

  1. Vale

    Vale New Member

    9
    0
    Nov 22, 2004
    With the holidays here, I decided to tinker with HME programming. I was unable to get my app to show up, which eventually led me to the problem that I am currently having.

    If I launch TiVo Dekstop on my PC, I can see both of my TiVos just fine. I can even successfully transfer shows onto my PC for viewing.

    If I publish pic and/or music, I cannot see them on either TiVo.

    My PC is connected directly to a Netgear RP614 wired router. In order to spread my connection around the home, I use wireless bridges. There is a Netgear WG602 connected directly to the router, and I have WG602's at each of my equpiment locations. All the WG602s are configured in dedicated point-to-point bridge mode. The remote access points use simple 5-port switches to distribute ethernet ports to the hardware.

    My PC is running ZoneAlarm, and I have all of the TiVo applications set to full access.

    I have tried shutting down ZoneAlarm (the winXP firewall is OFF as well), and still cannot get my TiVo's to see the TiVo desktop server.

    When I bring up the TiVo Server properties, it says the server is running.

    Any ideas why I can connect to the TiVos from the PC and yet the TiVos cannot find the media server?
     
  2. Vale

    Vale New Member

    9
    0
    Nov 22, 2004
    Ok... After a 2nd or 3rd shutdown of ZoneAlarm followed by a restart of the TiVo server, I was able to get the connection from a TiVo to the PC to work. After restarting ZoneAlarm, I could still access the PC from the TiVo. I guess I'll just have to fiddle around in ZA to find out what I have configured improperly.
     
  3. jcapple

    jcapple New Member

    5
    0
    Jan 10, 2006
    I went through similar problems with a recent switch from McAfee to ZoneAlarm (Zone Alarm - typed both ways for people searching for help).

    After trying literally everything else as you can see by the next steps:

    1) Enabling ports
    TCP/UDP 2190
    TCP 4430-4439, 8080-8089, 8100-8109, 8200-8209
    (per Tivo recommendations)

    2) Turning off filtering for all things Tivo:
    This will make it so your program is not scanned by ZA IM Secure:
    Double click the My Computer
    Double click the (C
    Double click the Program Files Folder
    Double click the ZoneLabs Folder
    Double click the ZoneAlarm Folder
    Double click on imf_editor
    Put a dot next to Filter all apps except blacklisted
    Click the Blacklist Tab
    Click the Browse Button
    Browse to the executable file of the program that is not working and
    double click it.
    Click OK.
    Restart your computer and test again for the issue.

    3) Creating excrutiating expert rules and protocol groups, etc.

    4) Various other BS with respect to the individual program settings to get it to work.

    5) AND the winner is . . . under ZA Anti-virus and Spyware:
    MAKE SURE ON-ACCESS SCANNING IS DISABLED!

    Who would have figured?

    You still do actually need to enable those ports in step 1) as an expert rule (or something like it) for the Tivo DVR to see all the files on your machine, but in the end, the only thing really screwing me up with the virus scanner. . . not the firewall.

    Hope that helps!!!
    :eek:
     
  4. Eptiger

    Eptiger TiVo N00b

    166
    0
    Jan 16, 2009
    Seattle, WA
    Not trying to bump this thread, just have new advice for Zone Alarm users:

    Go to "Alert & Logs" and you'll probably see an entry for your TiVo's IP. Hit the "Add to Zone" button and that will probably fix things.

    Elton
     
  5. shortwave8669

    shortwave8669 New Member

    1
    0
    May 3, 2009
    Thanks to Eptiger.
    I have explored my firewall, TD installation, and home network over the past 2 weeks trying to get Tivo Desktop to communicate with my PC.

    As your post suggested the solution to configuring my ZA firewall was in Alerts & Logs.

    Thank you again.
     

Share This Page