Toslink issues

Discussion in 'TiVo Premiere DVRs' started by alexofindy, Sep 8, 2013.

  1. alexofindy

    alexofindy Member

    82
    14
    Apr 15, 2010

    Advertisements

    I have a Premiere XL connected to an older Sony rear projection TV (KDS 60A2000) via HDMI which has worked pretty well.

    I just purchased a Zvox sound bar for my TV. My Sony TV won't pass through the digital sound from my Tivo (a design limitation of the TV), so I have connected my Tivo directly to my new soundbar via a Toslink optical cable.

    Usually it works fine. But sometimes I lose the sound. After a while - many minutes - it usually comes back. Troubleshooting is difficult since the problem is intermittent, but it seems to be an issue with the Tivo's toslink output, that does not affect the HDMI audio signal.

    Anyone know of unresolved problems with the toslink output of a Tivo Premiere? What would the recommended audio setting on the tivo - Dolby or PCM audio?
     
  2. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    If all you have is the sound bar, then I would suggest trying the PCM audio selection.

    If you have a 5.1 system also, then you will want to stick with the Dolby Digital selection.
     
  3. UCLABB

    UCLABB Well-Known Member

    5,381
    1,435
    May 29, 2012
    Riverside, CA
    Yeah, some combo of my cable company, TiVo and Sony receiver just won't let Dolby work all the time, most of the time but not all the time. So, I set the TiVo to PCM and everything is fine.

    The other day, I recorded a program and got no sound. Later, I tuned into a repeat of the program tried it with the TiVo set to Dolby. It was hilarious. There was a combo of narration and film clips. The films clips were without sound, the narration was just fine.

    I've given up trying to figure out the problem and I just stick with PCM. I only run a 3.1 setup anyway.
     
  4. aaronwt

    aaronwt UHD Addict

    23,363
    1,187
    Jan 31, 2002
    Northern...
    I would use DD on the sound bar too if it is capable. I have two sound bars and both handle PCM 7.1, DD and DTS. And one of them also handles DD+, Dolby TrueHD, DTS-HD MA.
     
  5. alexofindy

    alexofindy Member

    82
    14
    Apr 15, 2010

    Advertisements

    I did try PCM, and it didn't solve the problem, so I'm back to Dolby.

    But I still need to figure out what the problem is. I purchased the sound bar about a month ago, and had no problems until a couple of days ago. Now I only get digital sound intermittantly. Most annoying.

    I'll have to start swapping cables to see if I can determine if it's really the Tivo, or if my soundbar if flaky, or perhaps the toslink cable.
     
  6. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Yeah, things to try before blaming the Tivo...
    New TOSlink cable. At the same time, check for any dust in the port.
    Try composite cables if sound bar accepts them.
    Connect sound bar to different source.
     
  7. severe

    severe Member

    76
    0
    Dec 11, 2009
    Occasionally, I'll get intermittent pauses with audio in my system. Usually due to a weak connection somewhere. I'm using a toslink manual switch, due to owning a few devices running into one input.

    At any rate, disconnecting and reconnecting the cables normally fixes the issue. Could be a bad cable too.
     

Share This Page

spam firewall

Advertisements