Toshiba RS-TX20 Power cycling Problem

Discussion in 'DVD TiVo Units (Archive)' started by sm_xyz, Dec 18, 2005.

  1. sm_xyz

    sm_xyz New Member

    1
    0
    Dec 18, 2005

    Advertisements

    I have a 5 month old Toshiba RS-TX20 that I have used sporadically. A few days ago I noticed that it would get stuck loading a DVD and would reboot. After reboot it would take for ever to load the DVD, but did play the DVD ultimately. Two days ago, I inserted another DVD and it rebooted again and it has been power cycling continuosly since then! It would get to "please wait for a few more minutes" and then power cycle again. I have not been able to get to the Tivo screen. I have a DVD that is in the player that I cannot eject since the player will not get to a stable state, it keeps power cycling!! What could be the problem? How do I fix it? How can I get the DVD out? It is a rented DVD that I need to return this week. If anyone can suggest a fix, I would be grateful. Thank you!
     
  2. dipas

    dipas New Member

    4
    0
    Dec 2, 2005
    The same thing happens to me when I am recording DVDs on a RS-TX20. Have not found a solution yet.
     
  3. cbltvtech

    cbltvtech New Member

    2
    0
    Dec 21, 2005
    Boone, NC
    MY RS TX-20 has done the same rebooting however just for no reason also it has started having burning problems since 7.2.1 upgrade. TIVO says its Toshiba, they blame TIVO software!! DUH! After trying everything I unplugged unit overnight and it immediately burned two consecutive disks without problems!
     
  4. Soulbro

    Soulbro New Member

    3
    0
    Jan 10, 2006
    I have the same rebooting issue that you do. In fact a few nights ago while my TV and nothing was recording or updating, I heard the TiVo disk cycling. I had never heard it before. Then the other night I put in a DVD (Seven Samurai) and the TiVo just locks up and freezes the live TV. It wasn't paused, just frozen. After waiting several minutes I had no choice but to unplug the unit. When I plugged it back in I got the powering up and 'just a few moments more' screens but they just kept cycling. This went out for 20 or so minutes before I unplugged it for the night. Tried it again this morning and it's the same deal. Just cycles the power and shows me both screens. It won't boot for enough for me to get to any menus or do anything. HELP!

    I haven't had the unit very long. I'd say 6 months at most. I hope the warranty will cover it. Anyone find a way to fix the problem?
     
  5. chaogui

    chaogui New Member

    2
    0
    Jan 13, 2006

    Advertisements

    I had the exact same problem tonight. I put in a DVD and it locked my Toshiba RS-TX20 up. It simply wouldn't respond to anything but unplugging. Then it went into this infinite loop of trying to power up.

    I finally got it to boot:

    Hold the eject button on the unit continuously while it boots up (be patient!). It didn't open the tray until a couple minutes into the powering up process. After I took out the disc, it booted up normally at the next try.

    I am guessing that there's a very small window during the booting process that the dvd drive isn't locked and you have to push the eject button in that small window to get the tray open. Since we don't know when the drive is unlocked, the best bet is to hold down the eject button continuously.

    I hope this helps!
     
  6. mgulko

    mgulko New Member

    21
    0
    Feb 26, 2006
    Florida
    Just tonight, noticed that my unit was in the "Welcome" screen. It was stuck while powering up. I unplugged it, waited a minute, and plugged it back in. Same thing. :confused: Does anyone know if there is anything else I can do to get it unstuck? There is no DVD in the unit. Thanks! :)
     
  7. techkid123

    techkid123 New Member

    1
    0
    Oct 25, 2006
    chaogui ;) you are a genius...thanks ever so much for your help and suggestions. They worked perfectly for me!! :up:
     

Share This Page

spam firewall

Advertisements