Tivoweb/tivowebplus stress

Discussion in 'TiVo Series 1 - UK' started by Shemhamphorash, Aug 10, 2005.

  1. Shemhamphorash

    Shemhamphorash New Member

    15
    0
    Feb 5, 2003
    Workington,...

    Advertisements

    I've tried, tried, tried and failed. I'm trying my very hardest to install tivoweb or tivowebplus, i've been sat here for 5 hours now and i'm no further on. I've searched the forum but i'm assuming i'm thick because i didn't even know how to use telnet 2 hours ago. I used telnet to create the /var/hack directory then used flashfxp to transfer the various files then i used telnet to extract the file and finally came to run it, nothing happened the first time as i was following one website saying to type /var/hack/tivoweb-tcl/tivoweb, then i found out that i was supposed to be typing console on the end of it which i did and it set off but then stuck, i never got any message saying awaiting commands. so i deleted that and tried installing tivowebplus. Oh the fun. Telnet took off upon me trying to extract the file and just gave me a screen of junk then crashed. I'm very tired now and stuck in a rutt. Anyone please can you tell me where i'm going wrong?? :mad:
     
  2. Shemhamphorash

    Shemhamphorash New Member

    15
    0
    Feb 5, 2003
    Workington,...
    Cheers Fozzie I couldn't source Tivoweb.tgz.gz file only tivowebplus, i'm following installation notes to the letter but to no avail. :(

    i get the message when trying to install tivowebplus

    Unalbe to get crypto chip's attention.

    Cannot determin Tivo Software Version. Installation Aborted!

    Anyone any ideas about this?
     
  3. mike0151

    mike0151 A Friend of Dot

    752
    0
    Dec 13, 2001
    Liverpool,...
    TWP is mostly useful for US twin tuner systems, not really of any great benefit to UK series 1 users. Look at http://tivo.lightn.org/ for TiVoWeb 1.9.4 and give that a go. Works great for me (most of the time).
     
  4. Shemhamphorash

    Shemhamphorash New Member

    15
    0
    Feb 5, 2003
    Workington,...

    Advertisements

    Cheers for the speedy reply Mike, just tried that and downloaded the tivoweb file, the file ends in .tar.tar so i renamed it .tar.gz and extracted it and cot the tivoweb-tcl directory, fired it up using the command /var/hack/tivoweb-tcl/tivoweb console but it just says

    The program is licensed under the GPL.
    see the copyright bla bla bla
    No EventSwitcher active
    while executing
    "dbopen $dbPoolSize"
    <file "/var/hack/tivoweb-tcl/httpd-tt.tcl" line 612>

    then it freezes and i get no message saying Awaiting Connection.

    I'm well and truely lost, did i mention stressed, lol.
    I thought hacking the tivo would be fun but there's too many conflicting message boards with different ways of installing things :confused:
     
  5. davidlallen

    davidlallen New Member

    16
    0
    Jul 2, 2005
    TivoWeb has not been maintained in a couple of years. You may have better luck with TivoWebPlus, which is actively maintained and known to work on all software releases up to 7.1.b

    http://tivowebplus.sourceforge.net
     
  6. sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    TiVoweb works fine, which is why there has been no development.

    EventSwitcher is a key part of the TiVo software and is always active. Have you tried rebooting the Tivo?
     
  7. Shemhamphorash

    Shemhamphorash New Member

    15
    0
    Feb 5, 2003
    Workington,...
    Ahhhh cheers Sanderton i unplugged it and plugged it back in and now it works fine, now all i have to do is figure out how to log into it from another computer on the internet, Does anyone know if there's any websites that guide you through how it all works and how to log into it off the internet?? Much obbliged for any info.
     
  8. sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    There are a number of threads on this very site which explain how to do it.
     
  9. Jadawin

    Jadawin New Member

    24
    0
    Jan 19, 2002
    Just had this problem. Installed TWP 1.2.1 (renamed my 1.0 directory to tivowebplus-old, just in case, and did a 'restart' from the prompt). Came back
    up, and this was my log:

    bash-2.02# cat /var/log/tivoweb.log
    TmkLogger: <134>Mar 8 15:57:46 tcl[365]: Tcl created pool of 2916352 bytes
    TivoWebPlus Project - v1.2.1
    The program comes with ABSOLUTELY NO WARRANTY.
    This program is licensed under the GPL.
    See the 'copyright' and 'README' files for copyright and credit information.
    No EventSwitcher active
    while executing
    "dbopen $dbPoolSize"
    (file "./httpd-tt.tcl" line 640)

    Did another restart, and, um, it appears that my old 1.9.4 is running. Eep. :)

    Sigh. I just wanna back up my Season Passes before I run thru guided setup again, disconnect my digital cable box, and make sure the wife gets her soap opera in 2 hours. (I started an hour ago).

    So, move directories around, rather than remounting / as r/w and fixing my startup script, make a ln link, and restart again.

    While waiting for the reboot, I find, doh, I could have just installed the Backup script into 1.9.4...more Le Sigh.

    Everything works fine after a reboot. I think I might have confused things by trying to run two TivoWeb*s on the same port.

    Thank you. :) (Yes, I would have rebooted....eventually....probably AFTER the soap opera)....
     

Share This Page

spam firewall

Advertisements