TiVoWeb module: Now Playing with Folders and Sort

Discussion in 'TiVo Underground' started by LJ, Jan 18, 2003.

  1. Mar 10, 2003 #21 of 116
    BBQ Chicken

    BBQ Chicken Bling Bling

    435
    0
    Nov 26, 2002
    west coast
    As far as i know this is for series 1 only as Tivo locked out the series 2 from all the hacks.
     
  2. Mar 11, 2003 #22 of 116
    sterl1i

    sterl1i New Member

    21
    0
    May 14, 2002
    Missouri
    When has a "lock out" ever mattered to hacks? Where's your sense of challege? If you can "climb a mountain because it's there," you certainly can "hack a lock out because it's there"!!!!
     
  3. Mar 11, 2003 #23 of 116
    Combat Medic

    Combat Medic No guts, no glory

    8,325
    0
    Sep 6, 2001
    San...
    Come on Chicken :) I've got TivoWeb on my series 2 HDVR2 the unhackable box. Some things have issues, but it works great.

    -Mike
     
  4. Mar 11, 2003 #24 of 116
    sterl1i

    sterl1i New Member

    21
    0
    May 14, 2002
    Missouri
    Combat Medic:

    You can't be calling me a chicken! I can't even hack my own computer much less anything else! I render anything useless with one touch that's why I come here -- to consult the EXPERTS!
     
  5. Mar 11, 2003 #25 of 116
    Combat Medic

    Combat Medic No guts, no glory

    8,325
    0
    Sep 6, 2001
    San...
    No actually I was playing with BBQ Chicken.

    -Mike
     
  6. Jun 7, 2003 #26 of 116
    dms92969

    dms92969 Member

    41
    0
    May 24, 2003
    New Jersey
    I can't get Nowplaying or the folder addition to work.. this is what I get...


    Please help.. Thanks


    bash-2.02# tivoweb console
    bash-2.02# TiVo Web Project - TCL - v1.9.4
    The program comes with ABSOLUTELY NO WARRANTY.
    This program is licensed under the GPL.
    See the 'copyright' and 'README' files for copyright and credit information.
    Loading modules...
    folders
    NONE can't read "::uktivo": no such variable
    while executing
    "if {$::uktivo} {
    register_module "folders" "Folders" "Now Playing with Sort and Folders"
    } else {
    register_module "folders" "Folders" "Now Showing w..."
    (file "/hack/tivoweb-tcl/modules/folders.itcl" line 911)
    invoked from within
    "source $module "
    index
    NONE can't read "LogoGroups": no such variable
    while executing
    "foreach fsid $LogoGroups {
    RetryTransaction {
    set LogoGroupEntry [db $db openid $fsid]
    set LogoGroupSpace [dbobj $LogoGroupEntry..."
    (procedure "init_logoindex" line 16)
    invoked from within
    "init_logoindex"
    (file "/hack/tivoweb-tcl/modules/index.itcl" line 541)
    invoked from within
    "source $module "
    info
    logos
    logs
    mail
    mfsbrowser
    now_playing
    phone
    resources
    Loaded 89 resource definitions
    sched
    screen
    search
    theme
    ui
    webremote
    Accepting Connections
     
  7. Dec 31, 2003 #27 of 116
    jvanber

    jvanber New Member

    6
    0
    Jun 2, 2003
    I get the following error:

    -begin------------
    action_folders '' ''
    can't read "::version3": no such variable
    while executing
    "if {$::version3} {
    RetryTransaction {
    set state [db $db open "/State/MyWorld"]
    set sort [dbobj $state get NowShowingSortOrder]
    }
    set nowsh..."
    (procedure "::action_folders" line 17)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    -end---------------

    I am using tivoweb 1.9.4, however I am using the "falconx" version that supports HDVR2's. I don't know if that has anything to do with it. Please let me know if that's the case.

    Thanks!

    -Joshua
     
  8. Dec 31, 2003 #28 of 116
    LJ

    LJ New Member

    786
    0
    Nov 11, 2001
    West...
    falconx version? :confused:

    The 'version3' variable is used quite heavily in the standard version, so I guess the falconx version must be quite a re-write. Can you point me to where I can get more info on it?
     
  9. Dec 31, 2003 #29 of 116
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    The Other Place in the Series 2 forum - it adds dual tuner support and a link to start playing the selected prog in WMP.
     
  10. Dec 31, 2003 #30 of 116
    jvanber

    jvanber New Member

    6
    0
    Jun 2, 2003
    Ok, I'll check with them to see if they did something that changed the variables. Thanks.
     
  11. Jan 3, 2004 #31 of 116
    wintersn

    wintersn New Member

    13
    0
    Jan 3, 2004
    Merrimack, NH
    dms92969

    I was getting the same error you are. What OS are you running? I am running 3.0-01-1-000 on a HDR112. Tivoweb 1.9.4

    Anyway, got the same error. It looked to me like it couldn't find the 'uktivo=false' string set anywhere. I ended up editing out all the uktivo if-else strings to just go to the non-uktivo code. I'll attach it here. This is for non-uktivo users only, it will get it to work for you on the same tivo software version I am running. I'm not a programmer, just knew enough to cut out the uktivo stuff to get it working for me.

    I hope this isn't an inapropriate way to go about this, if LJ can figure out why we don't report a uktivo=false then maybe he can fix it. Hope i'm not stepping on anyones toes here.

    Nate

    Note:

    I've just had to perform the same 'remove uktivo references' from showcase.itcl to get it to work on my Tivo as well. I'm not sure if I'm running any of LJ's other scripts, but this seems to be common to them so far.
     

    Attached Files:

  12. Jan 4, 2004 #32 of 116
    LJ

    LJ New Member

    786
    0
    Nov 11, 2001
    West...
    I think the uktivo variable was introduced around beta 4 or maybe 5 of TiVoWeb. I'd try downloading a fresh copy of 1.9.4 final from lightn's site.
     
  13. Jan 4, 2004 #33 of 116
    jvanber

    jvanber New Member

    6
    0
    Jun 2, 2003
    Gentlemen,

    Since the tivoweb project has been dormant for a while, a few people who are active at *another* site have decided to improve TivoWeb to account for all the various versions of TIVO as well as all the various platforms. In particular, scheduling recording for dual-tuner units has been implemented. In their enhancement efforts, some minor bugs have presented themselves. At any rate, most of them have been/are being addressed.

    Officially, their latest release is considered Tivoweb-1.9.4.3. I encourage you to check it out. Unfortunately, I *can't* supply a link, but I'm sure you can all find it.

    LJ, thanks again for looking into this, and thanks for the great tivoweb modules.

    -Joshua
     
  14. Jan 4, 2004 #34 of 116
    LJ

    LJ New Member

    786
    0
    Nov 11, 2001
    West...
    Bringing TiVoWeb to more people by supporting more versions, dual tuners etc is IMO a good idea. I wonder what version of TiVoWeb they started with though - the questions I've seen about 'version3' and 'uktivo' variables pop up in the last few days make think it might be quite an old one. Have these people not heard of 'backward compatibilty' ?! ;)

    I have no intention of spending time writing or maintaining extra versions of my modules to run on a new base version of TiVoWeb that isn't backward compatible with Lightn's "1.9.4 final" release.

    From the two minutes I spent reading one of the threads at the 'other place' it concerns me that protection for service theft *appears* to have been one of the 'enhancements'. (Somebody please correct me if I'm wrong!)

    Is there a post I can look at with a list of the new features in 1.9.4.3 ? (PM me or email me if it won't post here ;))
     
  15. Jan 4, 2004 #35 of 116
    jvanber

    jvanber New Member

    6
    0
    Jun 2, 2003
    LJ,

    I've forwarded your concerns to the appropriate people. I'm sure they will be very interested to have a module developer's perspective. Hopefully you'll be contacted soon, and hopefully TivoWeb will continue to improve for everyone!

    Thanks again!

    -Joshua
     
  16. Jan 4, 2004 #36 of 116
    wintersn

    wintersn New Member

    13
    0
    Jan 3, 2004
    Merrimack, NH
    I reinstalled tivoweb over my existing install. Got everything going, reverted to the original folders/showcase modules and everything seems to work fine. I don't know what could have been different. I'm almost positive I had the 1.9.4 official release.
    The only problem after the re-install was that I got a genre problem. I had to download the ui.itcl from thread #1243595 (Can't post link yet). Sorry for the mixup.

    Nate
     
  17. Jan 4, 2004 #37 of 116
    LJ

    LJ New Member

    786
    0
    Nov 11, 2001
    West...
    No problem. Glad it's working. I think I needed more tea this morning. ;)
     
  18. Jan 4, 2004 #38 of 116
    damagi

    damagi New Member

    95
    0
    May 13, 2002
    service theft is not an 'enhancement', but rather the removal of anti-service theft code. the bottom line is that the previous code made some moral judgements on some tools which have a number of legitimate uses (as is noted in the thread). anything can be abused, and since dtv took over the subscription stuff for dtivos, the 'service theft' of tivo must be accompanied with dtv service theft...therefore, the script in question does essentially nothign but its true goals of privacy and upgrade prevention when used alone.

    one tool that was targeted was 'logsNull', which is simply a tool to clear the log files on the tivo consistently. now, one could say that it is used to cover the tracks of those who steal dtv...well, i guess thats one use. overall, its simply a tool to let you be proactive about your privacy, rather than assuming tivo will keep your viewing data annonymous and/or respect your opt-out status. in these days of laws such as the patriot act in the US, those 'agreements' could be violated, which causes concern for some - who wants the fbi knocking on their door just because they enjoy a certain set of programming which is similar to some terrorist's viewing habits?

    for example, while i could easily (and have in the past) restored my image on my dtivo directly, i have found that 25xtreme was a convienient tool to do it quicker and in fewer steps. that tool was labeled as a 'service theft' tool, which i disagree as a completely accurate statement.
     
  19. Jan 4, 2004 #39 of 116
    tmf aficionado

    tmf aficionado Critical Thinker

    119
    0
    Jan 4, 2004
    I am confused. Are you trying to tell us that your modules will not run properly if the giant ascii middle finger is removed from sched.itcl?
     
  20. Jan 4, 2004 #40 of 116
    damagi

    damagi New Member

    95
    0
    May 13, 2002
    there are some good changes to the new release, which could be utilized, but (other than one minor issue which will be updated shortly so i am told) it is totally backwards compatible to the 1.9.4 standard.
     

Share This Page