TiVoWeb Module : Manual Record

Discussion in 'TiVo Underground' started by cwingert, Jun 12, 2003.

  1. Aug 20, 2004 #81 of 287
    kelnt

    kelnt New Member

    10
    0
    May 8, 2004
    I have an unsubbed Phillips SA1 v3.0.
    I think i'm having a time zone issue. If I use the manual record module to schedule a repeating recording for before 7:00pm it will be scheduled properly. (GMT offset in my time zone is -6:00.) If I set a reapeating recording for after 7:00pm (after 12:00 gmt) the module outputs the proper dates, but when I checkl the TODO list every thing is set a day ahead of time. For example:
    I set a repeating weekday recording for 11:00pm, here is the output form the Manual Record Module:
    # beging qoute
    Season Pass
    Creating Season Pass... Done.

    ToDo Recordings (2 weeks)
    August 23, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 24, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 25, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 26, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 27, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 30, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    August 31, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    September 01, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    September 02, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    September 03, 2004
    Creating Recording... Done.
    Creating Showing... Done.
    Creating Program... Done.
    #Ending qoute

    When I look at the todo list this is what I see: (unnessary entries have been removed.)

    #Beginning Qoute

    Sun 8/22 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Mon 8/23 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Tue 8/24 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Wed 8/25 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Thu 8/26 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Sun 8/29 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Mon 8/30 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Tue 8/31 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Wed 9/1 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    Thu 9/2 11:00 pm KYTV Manual: keln Not an Episode--Program Info
    #end Qoute

    as you can see the recordings start on Sunday and end on Thursday.

    I'm not sure if this is an issue with Manual Record or a deeper issue with TivoWebPlus.

    Can someone point me in the rightr direction? Possibly with some troublshooting tips.

    Thanks,
    Keln
     
  2. Aug 23, 2004 #82 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    The manrec.itcl module uses the global tzoffset variable under TivoWeb+. It could be that the UI module that handles the TODO list may not be aware of this? Are you able to check the TODO list using the TiVo menu rather than the TivoWeb+ interface?
     
  3. Aug 24, 2004 #83 of 287
    kelnt

    kelnt New Member

    10
    0
    May 8, 2004
    I have not observed any differences between the on screen Todo List and the the TivoWeb+ Todo List. I do not use another time sensitve TivoWeb+ module that I can check with. I also don't know if the TivoWeb+ Todo List rely's on the tzoffset variable.
    Could I insert a test line in manrec.itcl to output the value of the tzoffest variable?

    If it is set wrong: do you happen to know where TivoWeb+ set the tzoffest variable.? I assume that it pulls it from a MFS location, but I have read conflicting locations depending on the TIVO software version.
     
  4. Aug 24, 2004 #84 of 287
    philhu

    philhu User Since Day ONE!

    972
    49
    Apr 11, 2001
    Funcity, AZ
    I tried to load manrec.itcl into tivowebplus 1.0-final.

    No error, just doesn't show in the menu

    I tried a full reload and even a quit, manual restart

    This is a Series 2 standalone, v4.01b

    Is it not made to work on this version?
     
  5. Aug 24, 2004 #85 of 287
    kelnt

    kelnt New Member

    10
    0
    May 8, 2004
    Well I tried outputting the value of txoffset. I get -18000.
    I assume this is seconds? equaling -300?

    My normal offset for my timezone is -6:00, but currently it is -5:00 because of daylite savings.

    Is -18000 correct?

    keln
     
  6. Aug 24, 2004 #86 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    kelnt:
    -18000 seconds equals -300 minutes, which equals -5 hours, so I think this is correct in your situation. We need to do a little more debugging... would it be possible to create a single manual recording a few days ahead using the manrec module, and then check the TODO list under the TiVo GUI to see if it is correct. And then would it be possible to create a "weekday" manual recording via the manrec module and check the TODO list via the TiVo GUI to see if it is correct. If you could report the findings then I will have a better idea of where the problem may be located.

    I am sorry about this but my TiVo's both use a txoffset of 0 as this is the value used in my EPG source. If I have time over the weekend I may play around with my timezone to see if I can duplicate the problem.

    philhu:
    I have absolutely no idea if the manrec module will work on a Series 2 (v4.01b) TiVo system. I do not have access to one of these systems so am unable to test or diagnose what the issue may be.
     
  7. Aug 25, 2004 #87 of 287
    kelnt

    kelnt New Member

    10
    0
    May 8, 2004
    I got the math on the time after I posted. whoops.

    Here are smoe scenarios and there results:

    If set a one-time recording for a date in the future at 10:00pm:
    it is accurate in the TODO GUI.

    If I set a weekday recording for a program starting Wed.:
    The TODO GUI show a recording for tonite at 10:00pm, Thursday, then Sunday, Monday, etc. Again the output from Manual Record shows the right dates.

    If I set a recording to repeat tonite (Wednesday) at 10:00pm and repeat on future Wednesday's:
    The TODO GUI shows recordings set for Tuesday 8/31 and Tuesday 9/7 but nothing for tonite (I presume because it was trying to schedule for yesterday(Tuesday.) Again the output from Manual Record shows the right dates: Wed. 9/1 and Wed 9/8.

    Of course if I scedule these same recordings to record before 7:00pm they will record on the proper date.


    If their is any information I can provide, I will be happy to do so.

    Thanks for your assistance.
    Keln
     
  8. Aug 27, 2004 #88 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    I have just set the timezone of my system to something other than 0 and was able to duplicate the problem. I have created a new version (0.1.0) that should resolve this issue for you.
     

    Attached Files:

  9. Aug 27, 2004 #89 of 287
    kelnt

    kelnt New Member

    10
    0
    May 8, 2004
    So far so good.
    I'll give it a thorough test over ther next couple weeks.

    I kinda assumed it was a problem with my system because nobody else had reported the bug.
    Well thank you so much for your help john1980. IMHO tivoweb /w manrec is a nessesity on un-subbed units.

    Thanks,
    keln
     
  10. Sep 6, 2004 #90 of 287
    Fred Smith

    Fred Smith Still learning

    779
    0
    Oct 5, 2002
    Reading,...
    John1980,

    Thanks for that. It has cured a problem on my UK machine where a season pass recording was recording one hour earlier than expected.

    Now can anyone point me in the correct direction to edit the file to correct the 12 midday to display 12PM and not 12AM as per "cgunn" post on the second page of this thread. I have looked at the text of both manual.itcl's but have yet to spot what needs to be changed.
     
  11. Sep 8, 2004 #91 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    I have modified the code to reflect this... technically speaking we should be using midnight/noon rather than 12AM/12PM. I have changed my mind and used midnight/noon... if you would rather use 12AM/12PM then just search the source for the strings contining midnight and noon and replace them... they are pretty easy to find :)
     

    Attached Files:

  12. Sep 10, 2004 #92 of 287
    Fred Smith

    Fred Smith Still learning

    779
    0
    Oct 5, 2002
    Reading,...
    John1980,

    I have already downloaded and installed the version posted yesterday with 12AM and 12PM and it is working fine, thanks. My DVD-R’s, STB’s etc use AM and PM and not midnight / midday.

    The reason I originally asked was because cwingert’s version showed 12 midnight as 0AM and 12 midday as 12AM and your version 0.1.0 showed both 12 midnight and 12 midday as 12AM so it was just confusing. Although I do agree with your now edited and removed comment about the drop down list.

    Anyway, it is all working fine so i'll leave it alone, thanks again.
     
  13. Sep 10, 2004 #93 of 287
    wheelbarrow

    wheelbarrow New Member

    17
    0
    Oct 17, 2002
    How do i get a manual recording to be saved "until i Delete".

    I'm using the diguide plugin, and have changed the keepdays to different numbers and it doesn't seem to change things.


    Regards

    Paul
     
  14. Sep 13, 2004 #94 of 287
    6022tivo

    6022tivo A Happy Member

    2,062
    1
    Oct 29, 2002
    North West, UK
    I have found that there is no option to save until I delete. I normally like doing this??. Any plans for this usefull module.
     
  15. Sep 14, 2004 #95 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    I have had a go at supporting the "Until I Delete" option for Keep Until. I have now had time to test this on my 2.5.5 system so have removed the "beta" label. Let me know if you have any trouble on your systems.
     

    Attached Files:

  16. Sep 27, 2004 #96 of 287
    6022tivo

    6022tivo A Happy Member

    2,062
    1
    Oct 29, 2002
    North West, UK
  17. Oct 6, 2004 #97 of 287
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    From another thread:

    Where is this log file? I couldn't find one on my machine.
     
  18. Oct 6, 2004 #98 of 287
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    Has anyone hacked manrec to support the HD Tivo? The problem appears to be that channel numbers are not integers for over the air digital channels.

    INTERNAL SERVER ERROR
    --cut here--
    action_manrec '/' ''
    expected integer but got "36.1"
    while executing
    "lsort -integer [array names channeltablenum]"
    (procedure "::action_manrec" line 21)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--
     
  19. Oct 6, 2004 #99 of 287
    6022tivo

    6022tivo A Happy Member

    2,062
    1
    Oct 29, 2002
    North West, UK
    I got the hacks mixed up, I meant endpad, not this one, although I direct output to a log file by putting > /var/logs/delman.log & after the command in the cron file.
     
  20. Oct 8, 2004 #100 of 287
    john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    Very simple problem to fix... you just need to replace the "-integer" with "-real". I have updated ManRec (v0.1.3) to support the digital channels. Let me know if it works for you.
     

    Attached Files:

Share This Page