tivoweb and sky broadband

Discussion in 'TiVo Series 1 - UK' started by chrisd, Aug 10, 2007.

  1. chrisd

    chrisd London, England

    1,239
    0
    Oct 24, 2003
    London
    Just moved ISP to SKY, and can't seem to get tivoweb to work externally, so port forwarding seems to not be working although I though it has been setup correctly.

    Can anyone out there point me in the right direction re: the settings I will need to enter.
     
  2. Mike B

    Mike B Senior Munkee

    445
    0
    Sep 16, 2003
    Reading,...
    As you've changed ISP, does that mean you have also had a new router?
    Have you set up specific port forwarding on the router so that:

    external-ip:random-port-number -> tivo-ip:80

    Also, can tivo see the outside world? Try pinging your ISPs gateway address from the tivo.
     
  3. chrisd

    chrisd London, England

    1,239
    0
    Oct 24, 2003
    London
    Yep, new router (netgear DG834GT).

    I can ping the outside world from Tivo, and have got port forwarding setup on the router, but it must be wrong somewhere.

    the way this router works is like this..

    You add a new "service" and say whether it is UDP/TCP, and the start and end port
    I have put the start and end ports as 85 (is this ok to use as a random port, or is this where the problem lies?)

    You then take this service, and allow it to come through the firewall by editing the inbound/outbound rules.. I have allowed the tivo service that i created above, and it sends to my router's ip address (or should this be the tivo address? Im thinking it should be the router because all the other port forwards that I have setup like for the slingbox all point to the router and not the other hardware. Either way, I tried putting in the Tivo address here and it still doesnt work)
     
  4. TCM2007

    TCM2007 New Member

    3,947
    0
    Dec 25, 2006
    The rule should specify the TiVo's address I'd have thought.
     
  5. Cainam

    Cainam Tivo Evangelist

    332
    0
    May 25, 2004
    Chester-le-S...
    I used to have a Netgear, and from what I remember it does port forwarding, not port redirection.

    In other words: if you are connecting to the router from the outside world, and putting a :85 at the end (to denote port 85), the router will forward it on to the IP address of your Tivo - ON PORT 85.

    So you need to have the following

    1) Tivoweb configured to run on port 85, not port 80 (the default)
    2) The entry on the Netgear say that for anything on Port 85, forward to the Tivo internal IP address (192.168.0.200 or whatever)
    3) When you connect from outside your network (it will not work from inside it), connect to:

    http:\\myname.homeip.net:85

    If should work OK, assuming
    a) you have registered "myname.homeip.net" with DynDns or whoever. Alternatively put in the IP address if you know it, but as it can change this is not what I would do.

    b) wherever you are in the outside world, it lets you send traffic on port 85. My work will not, so I used 443 instead of 85 (normally reserved for secure http links, but who cares :) )

    Let us know how you get on
     
  6. Cainam

    Cainam Tivo Evangelist

    332
    0
    May 25, 2004
    Chester-le-S...
    Did you edit your post? I am sure it said 85 last time I read it, and not 5450...Maybe I just imagined it - it has been a long day already!

    In which case, repace 85 in my post above with 5450!
     
  7. ruperte

    ruperte New Member

    50
    0
    Jan 4, 2002
    Reading, UK
    This describes it rather well:

    http://www.skyuser.co.uk/forum/sky-...t-up-port-forwarding-internal-web-server.html

    Annoyingly you can't use a random port number for the external port, so I highly recommend you turn on the username and password facility on Tivoweb. This is in the tivoweb.cfg file on your Tivo.

    Alternately change the port that TivoWeb runs on to a random high port in tivoweb.cfg and use these instructions instead:

    http://www.skyuser.co.uk/forum/sky-...port-forwarding-internal-server-any-type.html

    Rupert
     
  8. chrisd

    chrisd London, England

    1,239
    0
    Oct 24, 2003
    London
    Lol, yeah I changed the port to a different one to see if that made any difference, and edited my post to reflect it. Then it still didnt work so I just went back to the original posting :)

    Your other post describes how I have it all setup already, but still no joy.

    I have the line in tivoweb.cfg that says port =5450 (or 85 as it was previously, either way shouldn't matter)
    In the router config I have it so anything that comes to port 5450 goes to tivo's ip

    Incidentally, I cannot ping my external IP for some reason, would that be causing these issues perhaps? Maybe not, as my slingbox still works fine, but I thought i'd better mention it.
     
  9. TCM2007

    TCM2007 New Member

    3,947
    0
    Dec 25, 2006
    Silly question, but if you've changed ISP your external IP will have changed, and may now be dynamic?
     
  10. chrisd

    chrisd London, England

    1,239
    0
    Oct 24, 2003
    London

    Woo hoo! Nice one Rupert, that's cracked it... I got rid of all the fancy random port mappings and just told the router to direct any usual port 80 connections over to the tivo and yes indeedy it worked. 1st time.


    Of course, now that I have sky HD I don't actually use tivoweb externally (or internally for that matter!), but it's nice to have just in case. :eek:


    Thanks for the help all.
     
  11. TCM2007

    TCM2007 New Member

    3,947
    0
    Dec 25, 2006
    If it worked on 80, how were you trying to access it? Many companies block ports other than 80 and 443 on their firewalls if you were trying from work.
     
  12. chrisd

    chrisd London, England

    1,239
    0
    Oct 24, 2003
    London
    Yes I am trying it from work... I think the problem was me trying to be clever and using random ports, which as you say are probably blocked.

    As soon as i went back to port 80 (which is how I used to have it with my old ISP, don't ask me why I suddenly decided to try using other ports!) it worked no problem.
     

Share This Page