TiVo's support forum gone? Site terribly slow

Discussion in 'TiVo Coffee House - TiVo Discussion' started by videobruce, Oct 25, 2019.

  1. videobruce

    videobruce OTA is still alive

    510
    18
    Nov 30, 2012
    Buffalo NY

    Advertisements

    Anyone know about TiVo's own forum being dead?
    Also, trying to navigate around their site is as slow as dial-up, anyone comment on either? It took over a full minute to load their contact support page. :confused:
     
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,817
    3,616
    Dec 7, 2012
    Ashland, PA...
    This is their forum and it took me over a minute to get in: https://tivoidp.tivo.com/tivoCommunitySupport/s/

    Blame it on adding Edge support.
     
  3. videobruce

    videobruce OTA is still alive

    510
    18
    Nov 30, 2012
    Buffalo NY
    Cool!
    The 'forum' link on their site is bad.

    Ok, what does one that to do with the other?? :rolleyes:
     
  4. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,817
    3,616
    Dec 7, 2012
    Ashland, PA...
    Just checked, back to normal.
     
  5. Diana Collins

    Diana Collins Well-Known Member TCF Club

    3,336
    799
    Aug 21, 2002
    New York...

    Advertisements

    Microsoft has given up and implemented the Chromium browser engine in Edge, so now you have to blame Google.
     
    aristoBrat and tenthplanet like this.
  6. dlfl

    dlfl Cranky old novice

    8,955
    749
    Jul 6, 2006
    Dayton OH
    You mean that forum still exists? Has it ever done anyone any good? I tried the link just now -- no response -- no big loss IMHO.
     
  7. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,817
    3,616
    Dec 7, 2012
    Ashland, PA...
    I keep forgetting that there are now two "Edge" even though I have Win 10. I still get by with IE11, but not for much longer. My comment was referring to the TiVo Edge being added to the "support" site.

    The old TiVo spam forum died over a year ago.

    I still can't make myself use EDGE even though that's the TiVo product.
     
    Last edited: Oct 25, 2019
  8. NorthAlabama

    NorthAlabama tabasco rules

    11,004
    2,825
    Apr 19, 2012
    sweet home, al
    i'm using the latest edge beta from ms, and i'm enjoying the added benefits of chromium sans google, especially since they finally fixed the xfinity streaming issue i was having with live tv and on demand. :)
     
    tenthplanet likes this.
  9. slowbiscuit

    slowbiscuit FUBAR

    4,545
    559
    Sep 19, 2006
    In the ATL
    If you want to use chromium there are way better browsers out there, such as Brave and Vivaldi. No way am I using an MS browser for anything.
     

Share This Page

spam firewall

Advertisements