tivoftpd problems

Discussion in 'TiVo Underground' started by trickyech, Apr 14, 2004.

  1. trickyech

    trickyech New Member

    31
    0
    Aug 13, 2002
    Sunnyvale, CA

    Advertisements

    I'm trying to transfer some files to my tivo using tivoftpd but am running into a problem.

    I used Steve Jenkins guide to install turbonet in my T60 and all went great.

    I have the copy of tivoftpd from his bootcd in /var/hack/bin. It starts up ok and I'm able to login from my windows machine via the command line ftp. When I try to send a file though I get this error:

    "503 Only ASCII and binary modes are supported"

    I get this error even after I manually set the transfer mode to ascii by doing "ftp>ascii"

    Anyone have any thoughts as to why tivoftpd is doing this?

    tricky
     
  2. Prof. Yaffle

    Prof. Yaffle Member

    255
    0
    Aug 2, 2002
    Nottingham
    I'm sure you shoud be transferring files in Binary mode not ascii. Try typing "bin" followed by enter and then try transferring.
     
  3. Piggers

    Piggers FavoriteColorIsClear

    419
    0
    Dec 17, 2003
    Try using a ftp client. I use smartftp and cuteftp.
     
  4. Prof. Yaffle

    Prof. Yaffle Member

    255
    0
    Aug 2, 2002
    Nottingham
    Personally I've found Filezilla to be the most reliable Windows ftp software with TiVo. Just remember to set it to binary not auto and make sure it's set for single connection. Also don't forget to Disconnect before closing it otherwise you'll need to restart ftp on TiVo
     
  5. Alessan

    Alessan New Member

    66
    0
    Feb 23, 2002

    Advertisements

    where can I get the tfp program. I am a newbie to doing ftp on tivo and would to try to set it up.
     
  6. Piggers

    Piggers FavoriteColorIsClear

    419
    0
    Dec 17, 2003
    It is no different then doing ftping to a computer or server. Try smartftp, wfsftp, cuteftp, filezilla, bulletproof.....

    What ever ftp program you choose...maybe you should read the help or readme to find out how to use them. It is actually pretty simple.
     
  7. TivoGeezer

    TivoGeezer Snow-ina-ear

    4,587
    0
    Dec 3, 2003
    Danbury, CT
    You can find it and other hacks here.
     
  8. gmiller

    gmiller New Member

    6
    0
    Mar 20, 2003
    Your FTP client isn't sending the mode properly. As everyone else said, switch to a different FTP client.
     
  9. tartan_haggis

    tartan_haggis MacTiVo

    130
    0
    Jun 13, 2005
    Cambridgeshire
    I have had the same problem using an Apple Mac running in Terminal mode. After certain commands, you get the following messages:

    500 Syntax error, command unrecognized.
    227 Entering Passive Mode (192,168,0,200,4,2)
    503 Only ASCII and binary modes are supported.

    Don't see why this should be a problem when ftp'ing from another UNIX host - I'm using Mac OS X Tiger 10.4 which is UNIX based.

    Any suggestions, or is a commercial FTP package the only answer? On my Windows PC, I can use Microsoft FTP client and it works fine.
     

Share This Page

spam firewall

Advertisements