1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo stream can't setup, no help from Tivo

Discussion in 'TiVo Stream' started by howdoin2, Jun 30, 2014.

  1. howdoin2

    howdoin2 New Member

    Nov 30, 2008
    Hopefully someone has seen this before, could not find any answer on this error.

    New Tivo stream, ipad (2 of them), iPhone, android = tivo app on ipad! iphone and android cannot connect and crashes network.

    Tivo Roamio Plus is working fine:
    - setup ok
    - access online via Ethernet
    - network remote enable
    - media access key ok

    When I download the Tivo app on ipad (or any other unit even remote app on android) I get an error message : at first it tells me that Media Access Key invalid, then I try connecting with tivo.com credentials and that is when the app just returns an error : connection to tivo lost and my entire network crashes (yes my router loses total connection to internet !!!).

    Tivo support just sent me a new Tivo unit... But I still have the same problem with apps, I cannot open them at home and do the setup.

    I have been able to successfully access my Tivo from 3G network (as in outside of house) but cannot stream as it was not setup in the house, android app also connects when outside to schedule recordings.

    As soon as I come home, devices on same network, apps won't open, crash entire network...

    Only clue I have is error on ipad that shows up on/off :


    Using Tivo Roamio Plus
    Router Netgear Blackhawks on - try on original firmware and DDWRT firmware
    2 different ipad minis, 1 android phone, 1 iphone

    I have been on phone with Tivo for a couple months but aside from sending me a new unit they cannot help with the apps, they tell me it is a problem with my network.

    For the record, no other problem with network, it only crashes when I try to open a tivo app an a mobile device.
  2. jrtroo

    jrtroo Chill- its just TV

    Feb 4, 2008
    You have a Roamio Plus, with included Stream functionality, AND have a new Stream? Why?

    Android does not yet support Stream.

    Just because you don't see any other network issues does not mean there are not problems. I would not discount that being an issue so quickly.
  3. moyekj

    moyekj Well-Known Member

    Jan 23, 2006
    To determine if your iOS devices can event connect to the Stream do as follows:

    1. Determine your Stream IP address from your router (MAC address is normally one digit different than the main TiVo IP address if using your Roamio Pro built in Stream).

    2. From Safari browser on one of your iOS devices try the following URL (obviously replace <Stream IP> with the proper IP #):
    http://<Stream IP>:49152/sysinfo
    If above doesn't work then most likely there's an issue with your local network.
    NOTE: Stream IP #s are dynamically assigned - there's no option to define static IP # for it, so you must have DHCP working properly for your router. The issue you describe with crashing your router makes me suspect some kind of IP conflict is happening.
  4. telemark

    telemark Active Member

    Nov 12, 2013
    Somethings wrong with your network. No app should be able bring down a whole network.

    Who's your ISP?
  5. Jul 1, 2014 #5 of 19

    lgnad Pantless Mofo

    Feb 14, 2013
    By "crashing your network" Im going to assume you mean crashing your router?

    Sounds like something on your network is corrupting packets. I'd disconnect every other device from the network other than your router, with the Roamio Plus directly connected to it via ethernet and one Ipad to eliminate about a zillion variables.

    If it still "crashes your network" its either one of the two remaining ethernet cables, your router or cable modem's hardware.
  6. Jul 3, 2014 #6 of 19

    moyekj Well-Known Member

    Jan 23, 2006
    Don't you hate it when OP posts a question, gets some useful responses, but then never responds again?
  7. Jul 7, 2014 #7 of 19

    howdoin2 New Member

    Nov 30, 2008
    OP actually had to leave for a few days and did not have the chance to go online (or actually was lucky enough to be in a place where he could not go online for a few days).

    In other news I found and fixed the problem - here are a few clarifications:

    - I originally posted in the wrong forum as what I was trying to do is set-up streaming on a Roamio (and not setup a Tivo Stream).

    - Tivo Customer Service had no idea what my error message in Tivo app on Ipad was referring to and told me they would check with engineering... I never heard back from them.

    - After testing 2 separate Tivo Roamio and a Tivo Premiere unit I figured out my problem and the solution.

    Problem was : impossible to setup Tivo apps on iOS and Android with my Tivo Premiere and Roamio. The app would open but not find any Tivo on my network, told me I had to be on a Local Network.
    Android App would just crash and not connect
    iOS App would not even open, just search for Tivo units then return error message "error:MindUnavailable".
    Afterwards both apps would cause my entire internet connection to go down.

    Solution and what caused the problem:
    all Tivo units where connected by ethernet directly into my router (Netgear Nighthawk)- I also had an Ethernet Switch connected to the same router (but Tivo units were NOT routed through the switch.
    Apparently the presence of the switch caused Tivo app to not being able to find the Tivo units and setup.
    I planned on unplugging everything from router to test - first thing I unplugged was the Ethernet Switch... and VOILA! I opened the app on iPad and was immediately able to access the Roamio, setup the streaming (and everything else).
    Once I reconnected the Ethernet Switch the problem disappeared... although the app still seem to think that I am streaming from outside my home but it still works for me.

    Bottom line : Tivo / Tivo app do not like it when you have an ethernet switch on your network.
  8. Jul 7, 2014 #8 of 19

    telemark Active Member

    Nov 12, 2013
    Could you post the model number of the ethernet switch?

    Lots of people run with a Wifi router+1 switch. It's more likely you had a bad switch or bad cable.
  9. Jul 8, 2014 #9 of 19

    eboydog Just TiVo'ing.....

    Mar 23, 2006
    Must have been something more than just a "switch", such as a routing switch or something as it's already been proven that "TiVo devices don't work on switches" is a support issue with TiVo and not a technical issue.

    Again, what model and brand was this offending "switch"?
  10. howdoin2

    howdoin2 New Member

    Nov 30, 2008
    The switch I use is a Linksys Se2500.

    I also spoke too fast regarding the switch not interfering after setup - tried to watch Tivo on Ipad inside the house yesterday and the app could not connect. There is definitely an interference somewhere as, as soon as I unplug the switch everything works fine.
    Again, my Tivo is connected via ethernet to the router, not via the switch. It seems that Tivo or at least the apps on iOS and Android get confused when the switch is on and cannot find my Roamio.
  11. eboydog

    eboydog Just TiVo'ing.....

    Mar 23, 2006
    There is nothing fancy about the switch, it's a simple nonmanaged switch. I would start by changing patch cables as you may well have a cat 3 cable or a bad cable.

    Many network issues are found to be caused by bad ethernet cables it's easy to overlook. Does your router provide any ethernet port statistics to monitor any errors that may be occurring? This is why I hate the resudental unmanaged switches, if they work they work but should you have problems there is no way to figure out what is causing it.

    Myself I have overkill and use a full managed enterprise ethernet switch just so I have full port control.

    Another thing too, do you have any older ethernet devices attached to the Linksys switch? I have seen older 10 mb ethernet devices that don't play nicely with auto negotiate gb unmanaged switches.
  12. aaronwt

    aaronwt UHD Addict

    Jan 31, 2002
    I run over twenty GigE switches on my home network including my APs and wireless bridges(which also have GigE ports). This causes zero problems with my TiVos and other devices. But I am also using Asus and Dlink switches which have been rock solid.
  13. JWhites

    JWhites New Member

    May 14, 2013
    I have the 8 port SE2800 version of that switch and I have no problems at all and two of my three Premieres are on this switch (the other connected directly to the EA4500 router) as well as the Stream. You could either have a faulty switch, which is unlikely since I'm assuming the other devices connected to it work fine, or you could have a problem with the cabling between the switch and the router, or something else on that switch that was causing the problem.
  14. byonik

    byonik New Member

    Apr 9, 2014
    I know this thread is a little stale now, but FWIW, I thought I would also mention that I may be experiencing the same issue as the OP.

    I also have a Roamio, a Netgear R7000 Nighthawk router, and several unmanaged switches on my network (both 100Mb and 1Gb).

    As with the OP, the TiVo app doesn't work on our iPad Mini, my wife's iPhone 5 or any of my Android devices.

    When launching the app on my Android, connected to the same network as the Roamio, it scans and finds the Roamio, along with my 4 minis (2 Ethernet & 2 MoCA connected).

    When I select my Roamio in the app, and then attempt to 'complete setup' by entering my MAK, it just bombs out. When I alternatively use my TiVo.com credentials, it works, but I then have to do that every time I launch the app.

    I had just chalked this up to the app being buggy, but after reading this, I'm wondering if the common theme here is the Nighthawk. Again, just like the OP, I have experienced this with the stock Netgear FW, as well as DD-WRT.

    I also experience Chromecast disconnects with this router when casting from a chrome browser on a PC, and other Nighthawk users have reported this issue as well. I'm wondering if the two issues are somehow related. Maybe something to do with UDP or a handshake service?

    Anyway, I just wanted to share my experience so the OP and anyone else having this issue knows they are not alone.
  15. JWhites

    JWhites New Member

    May 14, 2013
    That's so weird because on all my iOS devices all I had to do was enter my TiVo email and password and it was all automatic at first launch. I don't have to reenter any of the credentials unless there was a network problem like an access point went down or I was switching between LTE and WiFi but even then it just worked perfectly next time I launched the app after forcing it closed by double clicking the home button and swiping up.

    I'm really thinking the issues you guys are experiencing is a bad router or you are just farther away then it wants you to. For example my wireless router is on one side of the house and my bedroom is on the other side. I get good reception on my laptop and iPhone and iPad in the bedroom but when I try to stream usually I get an "unknown error has occurred" for no reason, so I hooked up another wireless router, put it in bridge mode in the bedroom and now I have no problems at all streaming three programs at the same time.
  16. telemark

    telemark Active Member

    Nov 12, 2013
    If I were in your position, I would first replace the router with whatever else I had on-hand to see if the symptoms goes away.

    For comparison, in my lifetime I've seen
    Countless bad routers
    Countless bad cables
    2 bad AP's when excluding Negotiation, Security, and Weak Signal
    0 bad managed switches but often they're set wrong
    0 bad unmanaged switches when excluding negotiation
  17. eboydog

    eboydog Just TiVo'ing.....

    Mar 23, 2006
    I had a situation some time ago when my wireless router put all the connections in an isolated mode were none of the wireless connections could see a local network device. This caused my Apple app to believe it was out of home despite being at home.

    I replaced the router with a new one and all was good. later went back to the old router to test with and found I had to do a factory reset to remove the wireless isolation mode despite it being unchecked in the original configuration.
  18. n0est

    n0est New Member

    Jul 11, 2017
    Adding another "Me too" to this list - Refurb Bolt replaced my S3+Tivo stream. Same network, same iOS devices - worked perfectly before. I cannot complete setup. Tivo support is worthless.
  19. alfred01234

    alfred01234 New Member

    Sep 11, 2013
    Me too.
    New Bolt. Not refurbished.
    Called TiVo. They claim it is a iphone issue.
    Asked if I could get a android device to try. I don't have one so no.
    They said they would put it in my notes.

Share This Page