TiVo Sever stops running - Help!

Discussion in 'TiVo Help Center' started by NJ_HB, Dec 21, 2011.

  1. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    I'm hoping one of you smart :) guys can help me here.
    I've crawled the web for hours and performed all the installs/re-installs relating to TiVo Desktop and cannot find an answer.

    The TiVo server that runs in the task bar will stop at random times, which stops all automatic downloads. Of course this means you cannot see your recording(s) on the PC while viewing the actual TiVo.

    If anyone knows how to fix this please explain in detail, there are others on the TiVo site with the same problem.

    Running 64bit Win7, no virus software only Microsoft Security Essentials.
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,706
    926
    Apr 6, 2000
    SF Bay Area
    This was the reason I switched over to PyTivo, and I haven't looked back.
     
  3. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I'm one of those 'others'.
    When did this start happening for you? For me, I think it started about six months ago.

    I did replace my router a while back, I wonder if it has to do with some configuration in the router settings? :confused:
    Only other reason I can think of is maybe a Windows update 'broke' something, and Tivo Desktop needs a software 'patch'.

    I would like to find a fix, but I'm just dealing with it for now. When I have the desire to transfer from PC to Tivo, I just restart the server. Otherwise, I'll restart the server when I know I should have some auto transfers queued up.

    So far, it's not that big a deal for me, but it is making me look harder in to switching to PyTivo.
     
  4. mchief

    mchief Morey

    339
    1
    Sep 10, 2005
    Alexandria, VA
    Try running Tivo Desktop with Beacon. I changed from Bonjour nearly a year ago after problems with dropped transfers and lost Tivos, and have not had a problem since.
     
  5. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    I too wonder if its a Windows update. I just got a new Dell XPS and it was working for about 1 week before this started happening.
     
  6. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    I did try this to no avail.
     
  7. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I'm currently running with Tivo Beacon. Switched from Bonjour soon after Tivo Desktop started using it as default, probably for the same reasons you changed.
    It was rock solid until about 6 months ago. :(:confused:

    ETA: I'll try switching back to Bonjour and see what happens.
     
  8. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,706
    926
    Apr 6, 2000
    SF Bay Area
    I think I heard clearing the Tivo Desktop cache would fix the server problem.
     
  9. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Nope. Been there done that.

    I switched to Bonjour when I made my last post. In the time it took me to see your response to this thread and make this post, my Tivo Server has already stopped.
    I restarted it, we'll see how long it lasts.
     
  10. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,706
    926
    Apr 6, 2000
    SF Bay Area
    Ever since I switched over to PyTivo, I never had a server problem but once in a blue moon, I would not see my PC folders on the list and I simply restart the server.
     
  11. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Posting again. My Tivo Server has already ceased functioning...in 20 minutes.:(

    Now switching back to Tivo Beacon. I don't think it will make a difference.
    Something else is going on, we just have to narrow it down.
     
  12. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    My experience is now the same as yours - I can get the server to be present for about 20mins. If you are using WIN7 and run RELIABLITY history it shows the TiVo server crapping out every day.
     
  13. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Interesting. I did not know about that reliability history in W7.

    One of my reports shows this:

    If only I knew what to do with that information.

    Edit:

    BTW: As long as the Tivo Server stays busy, it will keep running. I transferred 8 hours worth of shows last week, and the Tivo server stayed running for over 48 hrs.:confused:
    But usually when nothing is going on, it won't stay running for long.

    Edit #2

    Another BTW, do you know about the logs in Tivo Desktop?

    On Win 7: Start -> All programs -> TiVo Desktop -> Logfinder

    I enabled the Tivo Server log back when I first suspected a problem.
    I can post the log if somebody thinks it might help. It's all a foriegn language to me.
     
  14. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I just found out about and installed Tivo Desktop 2.8.3.
    I'll see if this issue is fixed (for some reason, I doubt it is).

    Looks like TD was updated just to accomodate the new DirecTV Tivos.
     
  15. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    I'll check it out myself.
     
  16. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    Give your TiVos and everything else on your network that doesn't travel a fixed IP address.

    Can't hurt, might help.

    Of course I've also found that it helps to give the TiVos their own computer.:)

    That doesn't mean I never have problems.

    The free version of TiVo Desktop is sometimes worth no more than I paid for it.
     
  17. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Nothing has changed, server still stops running after sitting idle.
     
  18. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I gave my Tivos a static IP a while back when this problem surfaced. Didn't help, but it didn't hurt either. ;)
    I don't think this is network related. I've been running Desktop for years without a problem.
    My suspicion is a Windows 7 update borked the system. I did notice after installing 2.8.3, Windows popped up the "program might not have installed properly" message and when I tried to re-install using recommended settings, I got a message that the installer was unable to run under compatibility mode (or something like that). I cancelled the re-installation.

    There is the workaround to manually restart the Tivo Server whenever you want computer/Tivo interaction, but it makes the auto transfer feature worthless.
     

Share This Page