Tivo Server Stopped

Discussion in 'TiVo Help Center' started by gersch, Sep 15, 2011.

  1. gersch

    gersch New Member

    4
    0
    May 31, 2010
    Tivo Desktop 2.8.2 had been working perfectly since I first installed it and I was able to play my Music files and view my Photos on my Tivo Premiere with no problem until about 2 weeks ago. Now there is a red X through the Tivo Server icon in the taskbar and when I try to restart the Tivo Server I get an error "An internal error has occurred". When I run the Tivo Desktop Troubleshooting program, the log contains the error "PC server cannot be found by Bonjour for Windows".

    I am running Windows 7 Professional on a Dell Inspiron 15R. I have tried uninstalling Tivo Desktop and running the TivoDesktopCleaner and reinstalling Tivo Desktop 2.8.2 but with the same results. I have also tried restarting Bonjour and even uninstalling and reinstalling Bonjour but that didn't help either. I then tried installing Tivo Desktop on an old laptop running XP and it worked flawlessly, so I know it's not a network issue with my Linksys router or the Tivo Premiere itself. I also looked at the Programs and Features control panel and nothing has been installed in the last month save for the latest Windows Updates.

    Any suggestions would be most appreciated.
     
  2. shamilian

    shamilian Member

    471
    12
    Mar 26, 2003
    NJ
    I think mine stopped working about that time too. I switched to Tivo Beacon ( in properties/network menu) and it works again....
     
  3. Oct 3, 2011 #3 of 30
    tajbabydoll

    tajbabydoll New Member

    3
    0
    Oct 13, 2007
    I am having the same problem with my computer and it started a few days ago. I talked with TiVo and they were about as much help as nothing. I had already done everything they told me to do, multiple times. I'm running Windows Vista, so I don't think the problem is that you're on 7. Have you found a solution yet? Also, I'm not finding a way to switch to Beacon because I'm getting the message Error 1359 something.
     
  4. Oct 3, 2011 #4 of 30
    gersch

    gersch New Member

    4
    0
    May 31, 2010
    I tried switching to the Tivo Beacon Service as well but when I try to start the service I get Error 1359: An Internal Error Occurred. Not a very helpful error message if I say so myself.

    The odd thing is I would feel better if it had never worked at all....but the fact that it did at one time makes this even more frustrating!!!!
     
  5. Oct 3, 2011 #5 of 30
    steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    If using Windows 7, click on the start icon (Windows icon, lower left) and select: All Programs -> TiVo Desktop -> TiVo Desktop Troubleshooting.

    That will run a test of your connections and such.

    Using the same path, click on LogFinder. You can enable various logs that may help in troubleshooting.
     
  6. Oct 4, 2011 #6 of 30
    gersch

    gersch New Member

    4
    0
    May 31, 2010
    I have done that and this is what I get:

    >>General Information
    TiVo Desktop 2.8.412.369 is installed for United States

    Windows Firewall is on and is set up for use with TiVo Desktop.

    TiVo Server
    PC server cannot be found by Bonjour for Windows

    The following TiVo DVRs should be able view the content shared by TiVo Desktop.

    DVR74D5 7xxxxxxxxxxxxxx

    TiVo DVRs on your Network
    Successfully connected to the following DVRs:

    DVR74D5 7xxxxxxxxxxxxxx

    Playback and Conversions
    You have upgraded to TiVo Desktop Plus

    Web Video
    This PC can auto-transfer web video to your TiVo DVR(s) and can
    assist in delivering web video from the DVR’s Video on Demand menu

    TiVo Server is unable to listen for requests from the TiVo Service to download web videos to a DVR.
    This may cause a delay between when you request a web video and when it downloads to your DVR.
    Restarting the PC may resolve this issue.

    There are no videos currently scheduled to transfer automatically to your DVR.<<

    Does this provide any clues for anyone???
     
  7. Oct 4, 2011 #7 of 30
    steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Not that I believe it really matters, but you might want to edit your post to remove your Premiere's TSN.

    Having said that, have you talked to Tivo Support? Use online chat or call the support line. Maybe they have a clue as to what Error 1359 is.

    I wonder if this might be a bug strictly related to the Premiere.
     
  8. Oct 5, 2011 #8 of 30
    gersch

    gersch New Member

    4
    0
    May 31, 2010
    Thanks Steve....good advice. I have contacted Tivo Support and they barely seem to know what Tivo Desktop is let alone provide any help in this matter.

    It can't be related to the Premiere since it has worked with 2 other computers on the same network running through the same wireless router. A friend is bringing his Windows 7 laptop over later this week and I'm going to try installing Tivo Desktop on that machine and see what happens.

    Should be interesting.....
     
  9. machpost

    machpost Member

    32
    1
    Dec 22, 2010
    I've been having nearly identical problems for months. It used to work flawlessly, but then one day, it quit working. I'm guessing it's a conflict with something else I'm running that uses Bonjour, or else some Windows 7 update has broken something, and knowing the glacial pace at which TiVo's developers work, they really don't care too much about fixing it.
     
  10. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    If Windows broke it, are we sure that TiVo can fix it without Microsoft's active assistance?

    And what are the chances MS wants to do that?
     
  11. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Don't rule out that Apple might have changed something in Bonjour.
    That is why some people recommend switching to Tivo Beacon for troubleshooting purposes.

    ETA: If you're using Bonjour w/ Tivo Desktop, check to make sure the Bonjour service is running.
    For Windows 7, open the control panel and start to type ' administrative ' in the search box. Click on 'Administrative Tools' and then 'Services'.
    Check to make sure the Bonjour Service is enabled.
     
  12. machpost

    machpost Member

    32
    1
    Dec 22, 2010
    Bonjour seems to be running fine on my system, because there are lots of other applications that use it all the time (AirFoil, iTunes/Apple TV/AirPlay, AirPrint, etc.). I've tried switching to Beacon, which if I remember correctly required some convoluted process since the TiVo Server was not running, and I could never get Beacon to run, either.

    Not a big deal, since I rarely use the server function and the ability to move shows from the TiVo to the PC is more important than the other way around, but it's just annoying that suddenly it doesn't work anymore.
     
  13. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    I just started having a problem with mine, I can't think of what could have changed.
    I switched from Bonjour to TiVo Beacon and got the same results. I reverted back to an earlier version of TiVo Desktop to see if the problem goes away.
     
  14. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    Thanks for the tip, I did this but a within an hour the service stopped on its own.
     
  15. andyprchrd

    andyprchrd New Member

    1
    0
    Aug 3, 2008
    tivo server won't start, same error message - "internal error has occured." started within the last month or so. Worked fine up until recently. Tried all the same fixes as above, no resolution. Windows 7 pro, 64 bit. Tivo Series 3, 4 years old with weaknees hd upgrade. Maybe multiple complaints will get Tivo interested in resolving...
     
  16. machpost

    machpost Member

    32
    1
    Dec 22, 2010
    Is anyone aware of any progress in getting this issue resolved?
     
  17. ggieseke

    ggieseke Well-Known Member

    5,676
    700
    May 30, 2008
    FWIW I have W7 Pro 64-bit, Windows Firewall and MSE. All updates from Microsoft are current, and it works perfectly with TiVo Beacon.

    When I upgraded from 2.8.2 to 2.8.3 I did notice that the firewall exceptions were wrong. It set up the rules to allow packets though on Public networks, but not Private or Domain. Once I fixed that my TiVos could see the PC again.
     
  18. NJ_HB

    NJ_HB TiVo/MCE/PSP

    730
    0
    Mar 21, 2007
    Piscataway,...
    Can you explain how to do this for us losers?
     
  19. ggieseke

    ggieseke Well-Known Member

    5,676
    700
    May 30, 2008
    In Windows Firewall click Advanced settings, then click Inbound Rules. Open each entry with Bonjour or TiVo in the name and click the Advanced tab.
     
  20. machpost

    machpost Member

    32
    1
    Dec 22, 2010
    What should it be set to? I set all the Bonjour and TiVo entries to Domain and Private, and it still doesn't work for me.
     

Share This Page