1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Server Service Disappeared

Discussion in 'TiVo Home Media Features & TiVoToGo' started by ADG, Sep 7, 2016.

  1. Sep 7, 2016 #1 of 15
    ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    I've been using Tivo Desktop Plus (2.83) on two computers in my house for years. i just noticed that Tivo (Roamio Plus) does not see one of them and when I opened Tivo Desktop the Network options is not in the Services dropdown. I checked my Services and Tivo Server is not there. I uninstalled and reinstalled Tivo Desktop, but Tivo Server is not installing.

    Both computers are high end systems running Windows 10. Can anyone think of a reason why Tivo Server would not appear or install in Services? Thanks in advance.
     
  2. Sep 7, 2016 #2 of 15
    oscarfish

    oscarfish Member

    151
    2
    Mar 1, 2009
    I'll bet it's related to Tivo Desktop being unlinked from your tivo account. Why that happens I don't know, but it's a known problem that a lot of people are having. It's been mentioned in several tivocommunity.com and tivo support threads. Some people are able to get it to sort of work temporarily by chaning part of the email id to upper case, but your mileage may vary. You'll have to search around for the threads.
     
  3. Sep 8, 2016 #3 of 15
    ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    I just noticed that the Tivo Service is no longer on the second computer either. HOWEVER - the tivo sees the second computer but not the first. It can pull from #2 and Tivo Desktop appears to be working fine, even though the Tivo Server is not present. Also, in Network Settings in the Tivo Desktop app it now lists Bonjour and Tivo Beacon. I seem to recall that previously it listed Bonjour and Tivo Server, and Tivo Beacon Service was no longer used.
     
  4. Sep 8, 2016 #4 of 15
    tivoknucklehead

    tivoknucklehead Active Member

    869
    29
    Dec 12, 2002
    Orlando Florida
    starting yesterday same problem. using 2.8.3, has worked for years, now tivo server keeps stopping after a few minutes even after I hit "restart server". I can open tivo desktop and transfer from the tivo to the PC, but the PC is not showing up in "my shows" on my Roamio, so I can't transfer from my PC to my Roamio
     
  5. Sep 8, 2016 #5 of 15
    ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    Well, now 2 of my 4 tivos have cannot receive any channels. Had cable company (Optimum) unbind/rebind & send authorization multiple times.

    UPDATE - Just spoke with TiVo (when did they contract for offshore support?) and they say everything is tied to the recent updates. The updates CAN break the Desktop connection to Tivo and once the update finishes (3 stage proccess - s/w update, guidance update, integration) the Desktop app "should" work again. We'll see. Meanwhile I have 3 more Tivo's going through the update process.
     
  6. tivoknucklehead

    tivoknucklehead Active Member

    869
    29
    Dec 12, 2002
    Orlando Florida
    so, is anyone still having success with tivo desktop 2.8.3 ? Specifically, can your Tivo see your PC in "my shows" ?
     
  7. JoeKustra

    JoeKustra in the other Alabama TCF Club

    8,182
    509
    Dec 7, 2012
    Ashland, PA...
    Sure. In Windows 8.1.
     
  8. ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    Okay, turns out that Tivo Server Service doesn't appear in the Services list. It's an .exe file that runs as a service. I uninstalled Tivo Desktop, ran the Tivo Desktop Cleaner app, and reinstalled. After doing this 3 times, everything is back to normal. And oddly enough, the signal problem on the two Tivos turned out to be (seemingly) unrelated to the Tivo software upgrade.
     
  9. tivoknucklehead

    tivoknucklehead Active Member

    869
    29
    Dec 12, 2002
    Orlando Florida
    doing what you did got my server back and running and my Tivo sees my PC, but I still cannot link to my tivo account, thus auto-transfers to my Tivo will not work( must be done manually). I can transfer to my PC fine

    I've tried all the variations of CAPS, no caps, etc and am done with that nonsense, nothing worked
     
  10. ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    Yes, as of today Tivo Desktop can't link to my Tivo account either (after working just fine since it was first released).
     
  11. JoeKustra

    JoeKustra in the other Alabama TCF Club

    8,182
    509
    Dec 7, 2012
    Ashland, PA...
  12. ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    Yes, I'd already seen that - but thanks :)
     
  13. sjmyst

    sjmyst New Member

    26
    0
    Apr 24, 2004
    ADG,

    I have been using TDP for years. One of my "goto" work around to give TDP a "kick" and have it start the "auto" transfer is to change from Bonjour to Tivo Beacon. Or, change from Tivo Beacon to Bonjour. It's been Tivo Beacon for as long as I can remember. And, I do this "trick" fairly often. So, I really believe I would have noticed if this had changed.

    I used TDP 2.8.3 for a couple of years (about 5 years ago). Wasn't finding it reliable. So, I downgraded to TDP 2.8.2. I used 2.8.2 for several years until yesterday.

    My auto uploads (from PC to TiVo) have stopped working. TiVo support had me run a "clean" procedure to uninstall everything, and put me back on 2.8.3. After all of that, I can't link my TDP to my TiVo account.

    Everything I'm seeing in the logs tells me that the TiVo Mind Server is broken (at least for me). I believe it is the reason my auto transfers stopped. And, it seems to be the reason I can't link TDP to my account right now. The logs for both scenarios point to the Tivo Mind Server being the problem.

    It's really putting a crimp on my TV watching as I move videos from my PC to the TiVo on a regular basis.

    I guess I'm now at the mercy of TiVo to get the Mind Server fixed.

    Regards,
    sjmyst
     
  14. ADG

    ADG Allan

    2,211
    30
    Aug 19, 2003
    New Jersey, USA
    Thanks, but everything is working fine now except for PyTivo pushes. I should have posted back - sorry.
     
  15. Scott9mm

    Scott9mm Member

    35
    3
    Apr 4, 2015
    Rural NC
    In the last six months (or so) I see TiVo Desktop problems right after an update from Microsoft. I'm running Win 7-64 on that particular box. Symptoms vary: sometimes the tray icon is totally missing and other times Tivo Server quits repeatedly after a brief time and/or I get a "wrong server version" message. Sometimes I need to use the task manager to kill the TiVo Desktop process. Sometimes, I can start TiVo Desktop only by running the executable "AS ADMINISTRATOR."

    The temp fix that worked (until the next Microsoft update) is to run the cleanup utility AS ADMINISTRATOR and then run the desktop 2.83 installer AS ADMINISTRATOR. I ignore the message that says elevated permissions are not needed.

    I also notice that these Microsoft updates reset the Chrome desktop icons to blank so I guess Microsoft plays with many registry items with their updates. The chrome icon fix is easy: Control Panel/Default Programs/Set Program Access and Computer Defaults/ expand Custom, and click the Chrome radio button.

    Update: I discovered that the Task Scheduler was all messed up as a result of Win 10 rollback (which rolls back the registry nut not the task schedule). I fixed the corrupted task schedules using this app: Repair Tasks - Home and then reinstalled Desktop. Here's hoping that prevents future TiVo Desktop problems
     
    Last edited: May 12, 2017
    ClearToLand likes this.

Share This Page