TiVo Server As Service Problem

Discussion in 'TiVo Help Center' started by paladintom, Sep 30, 2007.

  1. paladintom

    paladintom New Member

    7
    0
    Aug 19, 2007

    Advertisements

    Hi All,

    I've tried getting the TiVo server running as a windows service, but I am having problems.

    I get an "internal error has occurred" dialog when trying to start the service. I have set up the service to run tivoserver.exe with the appropriate permissions per the instructions.

    Does anyone have any advice? I am running WinXP SP2 with TiVo Desktop 2.5.

    I've also noticed that the switches "/start", "/stop", and "/pause" work from the command line, but not when running as a service.

    Any help is appreciated.

    Regards,
    Tom
     
  2. Rooth

    Rooth New Member

    3
    0
    Aug 18, 2002
    I'm having this problem, too. I tried uninstalling 2.5, and installing 2.5.1 from scratch, but I get the same problem. It does create a server in my tray, but when I double click on it, it shows the loading window briefly, then says:

    Unable to start TiVo Desktop. An internal error has occurred.


    It later says: "The service did not respond to the start or control request in a timely fashion."

    Help?
     
  3. Rooth

    Rooth New Member

    3
    0
    Aug 18, 2002
    Aha, I found a solution.

    Uninstall TiVo Desktop, and TiVo Photos (if that is installed).

    Go into the registry editor by going to Start -> Run, and typing "regedit"

    Select "My Computer" in the regedit window (top of the left column)

    Hit control-F to bring up the "find" dialog.

    Make sure Keys, Values, and Data are all checked. Enter "tivo" into the search field and hit enter.

    For every key of set of keys (folder) this search finds, delete the key or folder. After each deletion, use the F3 key to continue searching until you get to the end of the registry. You can leave the ".Tivo" entry in the file extensions folder there. You may also find some keys that Windows will not let you delete. That's okay.

    After you've deleted all keys, reinstall TiVo Desktop (no reboot needed). It should come up fine. It did for me, and I'm already transferring some episodes of Journeyman. Woot!
     

Share This Page

spam firewall

Advertisements