Tivo Series 3 Stuck on Welcome Powering Up

Discussion in 'TiVo Help Center' started by PoweringUp, Dec 28, 2019.

  1. PoweringUp

    PoweringUp New Member

    10
    0
    Dec 28, 2019
    I know there are tons of threads on this topic but I have replaced the power supply and the hard drive and am still having this issue. Wondering what else it could be...

    My TiVo Series 3 TCD652160 first started having issues after a power outage in our area.

    When the house power came back on my Tivo did not power back up. Nothing happened on the unit when plugged in (no lights, fan or hard drive spinning).

    Replaced the power supply and the unit powered on to the the Welcome Powering up screen.

    Next replaced the hard drive with a identical TCD652160 Western Digital hard drive.

    Same result, powers up to Welcome Powering Up and does not advance from there. Hard drive seems to be spinning. There is a solid green light on the front of the unit and lights near the ethernet port on the back.

    What else could be the problem? Is it a motherboard issue?

    Got all of my replacement parts from Ebay with sellers stating that the replacement parts are in working condition.

    Have called Tivo support 3 times. One lady told me to replace the hard drive and the other times they just wanted to refer me to Weaknees or to upgrade my Tivo stating it is a hardware failure.

    Have lifetime so trying to salvage this unit.
    20191228_111347_1577554586479_resized.jpg 20191228_111418_1577554585187_resized.jpg
     
  2. kpeters59

    kpeters59 Well-Known Member

    2,865
    582
    Jun 19, 2007
    Houston, Texas
    Did you put a valid Image on the Drive?

    -KP
     
    unclehonkey likes this.
  3. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,691
    922
    Apr 6, 2000
    SF Bay Area
  4. PoweringUp

    PoweringUp New Member

    10
    0
    Dec 28, 2019
    Do I still need to put an image on the hard drive if it was pulled from an identical model (TCD652160)?
     
  5. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,691
    922
    Apr 6, 2000
    SF Bay Area
    Yes, it needs a proper image, and a known good drive. or else, it would not get past the Power Up screen. With a caveat, once its up and running, you would need to do "Clear & Delete Everything" (If the image came from another Tivo S3) or else it will not record or play any shows currently on there. (Error 51). In effect, the image would be married to the Tivo and no other Tivo will be able to read its content, should the drive be switched to another box.
     

Share This Page