Tivo Series 2 DVD Recorder question...

Discussion in 'TiVo Help Center' started by Cynicize, Jan 21, 2006.

  1. Cynicize

    Cynicize New Member

    30
    0
    Mar 13, 2005
    I used to have TiVo back in the day...Series 1 and all that, and never had a problem with billing and/or the equipment (except the hdd fried and I was such a complete noob back then that I didn't know you could swap out hdd's and stuff). I'm now having one problem with billing, and one with the actual equipment. The billing thing is that I bought the gift sub (yearly), activated it online in My Account, went to the Tivo box and everything was fine...except I got billed $12.95 this month. They did some "internal testing" for a week and removed the bill...and 7 days later the bill's back on, and everything's messed up again...it's really getting quite annoying.

    As for the equipment, I'm getting this...kinda whistling sound. While it's active, recording, or even idle. It whistles all the time, and without the stereo up it's VERY prominent. Anyone have a clue what it is?
     
  2. litzdog911

    litzdog911 TechKnow Guide

    12,025
    0
    Oct 18, 2002
    Mill Creek,...
    You'll have to deal with Tivo on the billing problem.

    The "whisting sound" could be either the Tivo's internal fan or hard drive. Since it's new, and covered under warranty, you should just replace it. It shouldn't be whistling.
     
  3. Cynicize

    Cynicize New Member

    30
    0
    Mar 13, 2005
    I called Humax and they're sending me a new one...I couldn't bear to bring up yet another issue with Tivo..one is more than plenty...seeing as how long it's taking this to get resolved.
     

Share This Page