Tivo Series 2 dual tuner won't power on

Discussion in 'TiVo Help Center' started by ufauxreal, Mar 30, 2015.

  1. ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008

    Advertisements

    I have a series 2 Tivo with Lifetime on it that I no longer use. I gifted it to a friend but we couldn't get it hooked up. She has Comcast Infinity, and we do have the M card installed.

    After many phone calls she was told that if she couldn't get the green 'on' light to come up, the Tivo was basically dead.

    We hate to give up that easily. The unit worked perfectly the last time I used it, but that was about two years ago.

    Any suggestions to get this up and running? Could it be a faulty power cord?

    Thanks.
    JB
     
  2. Bongo

    Bongo New Member

    15
    0
    Mar 21, 2015
    There is no cable card slot on a series 2. Is it a series 3?
     
  3. unitron

    unitron Well-Known Member

    16,594
    62
    Apr 28, 2006
    semi-coastal NC
    Look at the sticker on the back where the power cord plugs in.

    There's a model number that starts with TCD.

    What's the rest of it?


    Series 2 or Series 3, most likely explanation is you'll need about $10 worth of replacement capacitors for the power supply.

    If there really is a cable card, remove it.

    Disconnect any cable or antenna input, anything plugged into the USB jacks and the Ethernet port, and any HDMI cable.

    Have nothing connected but the power cord and a composite video cable to one of the yellow jacks and a corresponding input jack on a video display

    Plug the other end of the power cord into the wall socket.

    See if you get any response.

    If so, start hooking the other stuff back up. If anything kills it, then it's only one chance in a zillion that it's not the power supply.

    But a cheap fix if you know which end of a hot soldering iron to not pick it up by.
     
  4. Apr 2, 2015 #4 of 14
    ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008
    Yes, it's a Series 2, and yes, not only are there 2 cable card slots, there is an 'M' card inserted!
    JB
     
  5. Apr 2, 2015 #5 of 14
    ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008

    Advertisements

    Thanks for your reply. We've ordered a new power cord and I'm waiting to see if that works. Neither of us have the ability to do any soldering. Any idea who would be able to do that?

    My friend was told by a Tivo tech that if any parts were replaced by any non-Tivo person, it would void the Lifetime subscription. How would they know?

    JB
     
  6. Apr 2, 2015 #6 of 14
    scandia101

    scandia101 Just the facts ma'am

    11,107
    154
    Oct 20, 2007
    MN, greater...
    Bongo was correct. There is no cable card slot on any series 2.

    Having two cable card slots would make it a series 3 tivo
    Does it look like this?
    [​IMG]
    or this?
    [​IMG]
     
  7. Apr 2, 2015 #7 of 14
    scandia101

    scandia101 Just the facts ma'am

    11,107
    154
    Oct 20, 2007
    MN, greater...
    There is absolutely no chance of that happening.
     
  8. Apr 2, 2015 #8 of 14
    ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008
    Well, I apologize if I gave the wrong information. I could have sworn i looked it up from the model number.

    What I know for sure is that there are 2 cable card slots. I put the M card in the right hand slot myself.

    Unfortunately, I am now back in New England and the Tivo is in FL, so I do not have ready access to it.

    JB
     
  9. Apr 2, 2015 #9 of 14
    unitron

    unitron Well-Known Member

    16,594
    62
    Apr 28, 2006
    semi-coastal NC
    Are the cable card slots in the back, or in the front behind a swing down panel?
     
  10. ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008
    They are in the front, behind a swing down panel.
    JB
     
  11. unitron

    unitron Well-Known Member

    16,594
    62
    Apr 28, 2006
    semi-coastal NC
    Then you have a later Series 3 model, the HD (TCD652160) or the identical looking HD XL (TCD658000).


    I assume your friend is in Florida with the TiVo of which she just became the owner?
     
  12. ufauxreal

    ufauxreal New Member

    35
    0
    Sep 16, 2008
    Thanks for your continued replies. Yes, my friend is in FL. and I'm back home in New England. She just emailed me that the 'new' power cord did not make the green light come on. I think at this point we will just give up.

    Since the unit can not be powered up, do I need to somehow remove my info from it, and if so, how?
    JB
     
  13. scandia101

    scandia101 Just the facts ma'am

    11,107
    154
    Oct 20, 2007
    MN, greater...
    There is no personal information on it.
     
  14. unitron

    unitron Well-Known Member

    16,594
    62
    Apr 28, 2006
    semi-coastal NC
    Disregard this post.
     

Share This Page

spam firewall

Advertisements