TIVO Roamio plus is acting nuts. Please help

Discussion in 'TiVo Roamio DVRs' started by Johnny Danger, Nov 3, 2019.

  1. Nov 3, 2019 #1 of 11
    Johnny Danger

    Johnny Danger Member

    201
    10
    Dec 27, 2016
    Hello.

    My TIVO Roamio first had the HDMI output stop working. I switched over to component.

    Maybe 8 months later, the Ethernet does not seem to work. It said like " invalid gateway address" for 192.168.1.1(which is correct gateway address for my router)

    The video is now scrambled. The cablecard shows as installed.

    I tried to do the secret codes and when I reset the unit, the amber/yellow light never blinds but is solid when the unit is reset.

    I did upgrade to a 8TB hard drive which is like at 90%+ capacity.

    There was also some lightning storms and power surges in my house however the unit is on a surge protector strip.

    It seem that everything is wrong with this machine.

    What else can I try before burning it then throwing it in the ocean?

    Thanks.
     
  2. Nov 3, 2019 #2 of 11
    Mikeguy

    Mikeguy Well-Known Member

    24,673
    7,802
    Jul 28, 2005
    Perhaps, contact TiVo customer support about a possible sweetheart deal on a replacement, given the failure of the TiVo equipment? I'm not sure about a complication from the hard drive, though (i.e. if you would want to put the original drive back in before calling, to avoid TiVo seeing that as an issue/barrier).
     
  3. Nov 4, 2019 #3 of 11
    Wigohwt

    Wigohwt Member

    123
    30
    Jun 9, 2019
    That's a lot to lose. See if you can still use kmttg to pull most of that off in case you replace the unit.
    Of course, with the Ethernet problem. :(
    Check router. You can set an IP in the Roamio as well.
    Did the built-in wireless option work for the guide, etc.?
    Did you lose pairing? When pairing goes out, usually those protected channels aren't video scrambled, but act as unauthorized channels. So maybe a different issue. A problem now with the component output? Check your connections and try a different TV if possible.
    Bad CC?
    If you have a spare 8TB drive lying around, I'd try a clone just as a test.
     
  4. Nov 5, 2019 #4 of 11
    Sywlgee

    Sywlgee New Member

    28
    2
    May 8, 2017
    Usually, as advised from one of the reps that I've talked to before, repalacing the drive causes malfunctions.
     
  5. Nov 5, 2019 #5 of 11
    Wigohwt

    Wigohwt Member

    123
    30
    Jun 9, 2019
    Of course they are going to say that. They want you to buy a new box.
     
  6. Nov 8, 2019 #6 of 11
    jonw747

    jonw747 Member

    604
    21
    Aug 2, 2015
    Given the circumstances, the power supply may be failing. If you're interested in fixing the box, you could explore testing/swapping that out yourself or contact Weaknees have them try to fix your unit.
     
  7. Nov 9, 2019 #7 of 11
    Diana Collins

    Diana Collins Well-Known Member TCF Club

    3,326
    787
    Aug 21, 2002
    New York...
    You say you have a surge protector power strip, but do you have one on the coax? A lightning strike on an utility pole can send a surge down the coax and damage solid state devices. Is the coax at least grounded outside?
     
  8. Johnny Danger

    Johnny Danger Member

    201
    10
    Dec 27, 2016
    I ran diagnostic on the hard drive and still did not work. I replaced the hard drive and reformatted everything. Still did not work.

    HDMI port went out like a year ago during a thunderstorm but everything else seem to be ok until recently.

    Do you know if these use standard power supplies or if there is a way to test if the power supply is working correctly?

    Thanks.
     
  9. Johnny Danger

    Johnny Danger Member

    201
    10
    Dec 27, 2016
    Hello.

    UPS was for power but not for coax. I forgot the UPS have a port for the coax cable. There was a storm in which I heard thunder very close to the house. All the power went out for the house and my computer stopped working. In the aftermath, the only damage I saw on the TIVO was the HDMI stopped working however everything else was working fine until now.

    Brand new hard drive did not fix the problem. What option do I have left?

    Replacement motherboard, power supply,etc?

    Thanks.
     
  10. jonw747

    jonw747 Member

    604
    21
    Aug 2, 2015
    I haven't replaced the power supply in my Roamio. If you can't find a replacement or don't feel comfortable doing it, call Weaknees and try to find out how much it would cost to repair (maybe you can send them a picture of the insides/components?), and/or contact TiVo and see what they might do for you.

    If there's lightning damage, you may see signs of burnt out parts or even burnt out traces (albeit with multi-layer boards it can be internal traces that fry). Also look for bulging or flat out missing caps. If anything burnt up, there may even be a lingering smell.
     
  11. shwru980r

    shwru980r Well-Known Member

    2,862
    222
    Jun 22, 2008
    If you are paying a monthly or yearly subscription then you have the continual care warranty and I think Tivo will send you another unit for $49. If you have all-in service, Tivo may transfer your service to another unit for a fee. You could look for a used tivo with the same model number and swap out the power supply and hard drive and see if that resolves your issue.
     
    Johnny Danger likes this.

Share This Page