Tivo Roamio can't connect to network with an apostrophe?

Discussion in 'TiVo Roamio DVRs' started by mtnagel, Oct 18, 2020.

  1. mtnagel

    mtnagel Well-Known Member

    25,247
    2,046
    Nov 15, 2003
    Cincinnati, OH

    Advertisements

    I just bought a eero mesh wifi system and I tried to connect my Roamio, but it seemingly doesn't like the apostrophe I used in the network name. It shows it as "\xe2\x80\x99". I still tried to connect to it and it failed. I manually typed in the network name with the apostrophe and it accepted that but it still failed. Or am I going to have to change the name and connect to every other device again (none of which had a problem with the apostrophe)?
     
    Last edited: Oct 18, 2020
  2. gkottner

    gkottner Member

    67
    15
    Jun 5, 2010
    West...
    Fellow Cincinnatian here. I remember from my old coding days that sometimes you needed to type '' to get the apostrophe recognized. Just a wild guess though whether that would work for you.
     
  3. mtnagel

    mtnagel Well-Known Member

    25,247
    2,046
    Nov 15, 2003
    Cincinnati, OH
    Hey neighbor! I'm assuming that's 2 apostrophes and if so, that didn't work either.

    I just can't believe this is an issue as no other device I connected had any issue with the apostrophe. Grrrr...
     
  4. HerronScott

    HerronScott Well-Known Member

    7,536
    1,102
    Jan 1, 2002
    Staunton, VA
    I just did a quick search and found a number of hits on other devices and clients having issues with apostrophes in SSID (general recommendation appears to be avoid special characters even though not explicitly excluded by the standard) so the Roamio doesn't appear to be unique.

    Scott
     
  5. mtnagel

    mtnagel Well-Known Member

    25,247
    2,046
    Nov 15, 2003
    Cincinnati, OH

    Advertisements

    Thanks. I did the same and saw the same. Of course it was the last device I tried to connect and it's the only one out of ~15 devices with an issue., several of which are definitely older than the Roamio.
     
  6. dianebrat

    dianebrat wait.. I did what? TCF Club

    13,123
    2,238
    Jul 6, 2002
    boston'ish
    Special characters in an SSID while not forbidden are never a great idea for exactly this reason, the odd item that won't accept it.
    It's not nearly as cut and dry as not broadcasting an SSID which is a bad idea since it's out of spec, and besides, it doesn't work because machines will repeat the name so it's easy to find.
     
  7. mtnagel

    mtnagel Well-Known Member

    25,247
    2,046
    Nov 15, 2003
    Cincinnati, OH
    Now you tell me ;)
     

Share This Page

spam firewall

Advertisements