Tivo Premiere XL stopped archiving - ReadyDLNA KUID logic problem?

Discussion in 'TiVo Help Center' started by markcalexander, Dec 21, 2011.

  1. markcalexander

    markcalexander New Member

    1
    0
    Mar 24, 2010
    I have had a running battle trying to get consistent archiving from from Tivo (Premier XL) to ReadyNas Ultra 6 plus - for a while it seemed to mostly work but since July it only very rarely works with only about 5 successful archive attempts since that time, one as recently as Dec 2nd.

    My Ultra 6 Plus is now running new firmware image. (RAIDiator-x86 4.2.19) which I updated today while trying to reset both the Tivo and ReadyNAS. I have rebooted both and launched several attempts of archive but same issues remain.

    I have been searching the forum and see that others have problems with files not properly recognized as KUID. Noting these similar problems, but I did not seem to find a post with any solution I will try to state my situation here.

    My logs show many many listings such as this today, each and every day it tries to archive:

    [2011/12/20 18:01:10] tivo_utils.c:249: info: Modern Family (Two Monkeys and a Panda) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

    this entry is repeated for virtually everything on my Tivo currently. Very strange, but today was the first time I looked at the Tivo log as I did not know one existed until seeing the other posts I simply thought the ReadyNAS and Tivo did not connect at all.

    I checked the Tivo and this program is clearly marked KUID (Keep until I delete) and should be archived. I managed to get some shows archived on Dec 2nd and Nov 25th but no matter what I mark KUID on the TIVO box does not seem to matter - the archive simply skips over it.

    I have RAIDar 4.3.0 and all "lights" on the RAIDar are Green. I can also see and play any archived files on Tivo or my mac. Just can't seem to add any new shows.

    Under the Streaming Services tab / ReadyDLNA it shows v1.0.22 not sure if this is current or how to update?

    Any other info needed to troubleshoot?

    Any ideas on how to fix as I am running out of disk space on the Tivo?

    Thanks!

    PS. I also reviewed the ReadyNAS community forum and many have a similar problem.

    I got one response that is interesting and maybe someone in Tivo Community can help:

    I'm experiencing the same problems as you. ReadyNas Ultra 4 w/ RAIDiator 4.2.19 which includes readytivo 1.3.7 and readydlna 1.0.22. I have two TiVo's. A Series 3 HD and a TiVo Premier.

    Videos from both TiVo's that are KUID show up with logs like the following when the ReadyNas attempts to archive them:
    [2011/12/20 22:49:21] tivo_utils.c:249: info: Bones (The Male in the Mail) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

    The file is KUID on the TiVo, and the database does not list that program id (I've used prune.txt to wipe the database clean and have verified that the database is empty via manual sqlite3 commands run from a different box on the db file)

    One theory is that perhaps it is a TiVo update that broke readytivo here? Maybe in the past the TiVo's would set KUID expiration dates to a specific value (say, 2050) and a TiVo update changed it so that KUID values are now set to 2038. And if readytivo was checking with logic like "If expiration date is > 2049 then this is KUID". But if TiVo changed the KUID date to be earlier, now readytivo no longer views that as KUID.

    The logic is in tivo_utils.c... If I could see the source code, perhaps I could find out more. Any chance we can get source here?
     
  2. perry_n_myers

    perry_n_myers New Member

    2
    0
    Jan 7, 2010
    Bump. I'm also experiencing this problem.
     
  3. perry_n_myers

    perry_n_myers New Member

    2
    0
    Jan 7, 2010
    As an alternative to readytivod on ReadyNAS devices, you can just use kmttg on a dedicated Windows/Linux/OSX box. On the one hand, it's not ideal because you need a dedicated box vs. just putting everything on the ReadyNAS. On the other hand, the ReadyNAS isn't really powerful enough to handle encoding/decoding anyhow, so more than likely you've already got a separate box for that.

    Check out kmttg it's really slick software and unlike readytivod, it's open source :) (Google it, the forum here won't let me post a link to it since it still considers me to be a bot as I haven't posted enough yet)
     
  4. nfrhtp

    nfrhtp New Member

    17
    1
    Apr 23, 2007
    I'm also experiencing this issue and I'm hoping I'll eventually be notified about a solution posted here.

    Tivo Premiere sw v14.9.2.2-01-2-748
    ReadyNAS Ultra 2 Plus
    RAIDiator 4.2.20-T4
    ReadyDLNA v1.0.22
     
  5. SonyTiVoLover

    SonyTiVoLover New Member

    40
    0
    Feb 27, 2002
    I too am experiencing the same problem. Netgear ReadyNAS Ultra 6 successfully backed up a TiVo Premier XL and a Pioneer DVR810H for about two months, then quit mid December 2011. Just got off the phone with a Netgear tech who is trying to escalate but isn't aware of a fix currently.

    We both suspect that maybe TiVo updated their software in some way that creates a problem for the ReadyDLNA service which does the backing up. The posts on the ReadyNAS forum about this issue all seem to be around the mid-December 2011 timeframe which is why we suspect this. If so, there may not be a workaround until Netgear gets around to coding a fix.

    If anyone has any other suggestions (or a solution) would appreciate your posting it here.

    Thanks!

    Tivo Premiere XL sw v14.9.2.2-01-2-748
    ReadyNAS Ultra 6
    RAIDiator 4.2.19
    ReadyDLNA v1.0.22
     
  6. alexofindy

    alexofindy Member

    82
    14
    Apr 15, 2010
    Same issue here. No solution. Hopefully Netgear will code a fix soon. Netgear still prominently advertises tivo compatibility on their web site, even though it simply doesn't work at present.
     
  7. nfrhtp

    nfrhtp New Member

    17
    1
    Apr 23, 2007
  8. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    Did it quit backing up the Pioneer as well, or just the Premiere?

    I'm pretty sure TiVo hasn't sent any new software down to the Pioneer in quite some time.
     
  9. Impulse0022

    Impulse0022 New Member

    11
    0
    Aug 14, 2010
    The ReadyTiVo 1.3.8 fix worked for me as well running 20.2-01-2-748 on my Premiere XL.
     

Share This Page