TiVo Premiere keeps won't get past splash screen, reboots continually

Discussion in 'TiVo Help Center' started by timepieces141, Aug 28, 2011.

  1. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    TiVo Premiere, purchased in November 2010, upgraded very soon after that to a 2TB hard drive (WD20EARS ).

    Last night I unplugged my TiVo premiere and set it aside, as I was cleaning out the cabinet it sits in. It was safe on the table, never jostled, while I cleaned for the next 20 minutes or so.

    When I returned it to the cabinet, it began its startup. First the Welcome! screen, then the screen that says “just a few more minutes.” The first time, it started up normally, but didn't show the shows in the My Shows list – but I had had that problem before, it was because there was no internet.

    Well, before I got a chance to plug the Ethernet cable into the back, it decided to reboot itself.

    Then, it would do the Welcome! screen, the “just a few more minutes” screen, and very soon into that the fan would go off and I would get a black screen on the TV. I waited 10 or so minutes, tried my remotes, to no avail. So I pulled the plug and tried rebooting.

    This continued for several reboots – the very same screens, and then black.

    So then I came to the forums, where I was told to test if the hard drive had failed. I tried the kickstart codes, but I am still not convinced they ever worked. But I tried 54, which was supposed to test the hard drive, but I never got the testing menu screen. At this point, I started to fear the worst about my hard drive. But instead of getting the testing menu screen, on the next reboot, the 2nd screen instead told me it was installing a service update.

    Again, I went to the forums for research and discovered that earlier this month 14.8c was released. I am almost positive (even more so now, based on the rest of my story) that this TiVo was still on 14.8. I know my other TiVo has not been updated yet.

    So I decided to go to bed, figuring it was late and the update might take quite some time.

    I woke up this morning and the “installing” screen was still showing. Very bummed out, I decided to pull the hard drive and see if I could tell if it was dead. I plugged it into an EZ-Dock and it spun up and mounted with no problem on my wife's Windows XP machine. I will point out that it showed up in Disk Management as a drive with no partition. I was expecting this since I had Series 2 TiVos, back when they were Linux, but then I thought about it more and maybe that is not a good thing. Based on the UI and the Vista-esque spinning circle, I'm pretty sure TiVo went Windows sometime between my two models. So, maybe it's a bad thing that I can't see the partition. But there is more...

    So, I took the drive that came with the unit and placed it back in, figuring it would tell me if there was something wrong with the unit. It started up with no problem what-so-ever. In fact, on the next connection to the TiVo servers it downloaded update 14.8c.

    The only thing I can think of, outside of there being something wrong with my 2TB drive, is that 14.8c was trying to install and it got itself in a catch-22.

    I just put the 2 TB drive back in, just to see if anything changed, and alas, no.

    Here's what I am looking for....

    The drive spins up, so I am guessing it is ok – but if I JMFS it again, I am guessing all of my movies (the thing was 57% full of movies) will be toast.

    Can I recover the .tivo files from the hard drive before performing a JMFS on it again?

    Or, is there any chance that I am doing something wrong, or possibly not doing something right, that would allow me to get this hard drive back on track. It would also stink to lose all of my season passes – I live in a full house and we had quite a few different shows on that list. I am having trouble piecing the list back together ;-)

    Any help would be greatly appreciated. And thanks especially if you made it this far into my story.
     
  2. dwit

    dwit Active Member

    1,660
    0
    May 4, 2004
    Atlanta, GA
    The only possible way of accessing the recordings(outside of being a "real" computer hacker) is to get the drive booted up in the unit they were recorded in, and watch them or transfer them over a network to a pc or another Tivo.

    It is possible that you may be able to save your seasons passes by accessing your account at tivo.com and link on the "Season Pass Manager". You will probably see a list of your passes. I have never used it, so am not sure how it works. Check the instructions there. It may be automatic.

    No advice on what to do about the 2 TB drive outside of reimaging, if you cannot get it booted up. Same thing happened to me. I never bothered about it as I had decided the Premiere sub rates were too high for me and I never subbed it.

    Good luck.
     
  3. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    Well, I'm not afraid to do some "hacking" if it comes to that - in fact I do a bit of that for a living, but TiVo is a not my specialty ;-) So if anyone has those thoughts, I game...

    Unfortunately, I found out the hard way that the "My Shows" and the "Season Pass" sections of the website are tied to the TiVo's last check-in. And I didn't check until I had already booted up and updated using the factory drive. That's my bad - but it does point towards something TiVo could do to make the service better - it would be great if the online stuff was a sort-of backup for such things, just in case your box dies. I won't hold my breath, they have a laundry list of other stuff to do that people requested long ago ;-)

    Thanks, by the way!
     
  4. jfalkingham

    jfalkingham Member

    213
    20
    Jul 23, 2002
    New Hampshire
    Hi Timepieces...


    TiVo is still all Linux based, no Windows code at all, and on the premiere there is a flash layer, but again the OS is all Linux.

    I had a very similar thing happen to me with my HD XL. I took out the 1tb Western Digital drive that shipped with the unit and used winmfs to copy the content and settings to a new 1.5tb seagate drive. I then 'super sized' it and installed and everything was fine. This process takes a bit, but, if you have the time, its worth a shot to see if you can get your recordings, season pass, etc over to the new drive. I would keep the original drive you current have installed as your fail safe. Use a new drive for the winmfs.

    If (when) you have a lot of weird behavior that does not clear with a reboot, popping the drive is the first step imo.
     
  5. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    Well, I will say it is great to hear that it is all still Linux-based, as that explains how it shows up in XP's disk management. As a side note, though, that doesn't explain why the design team made their spinning wheel look like Vista/7 - not to mention that the UI has become verrrrrry slow. I was hoping to blame Windows for that ;-)

    As per your suggestion, I guess that assumes there is something physically wrong with the drive, since if it were something software related then the problem would just get transferred from the bad 2TB drive to a new one. Also - a slightly expensive experiment - but worth it if I were able to get everything back.

    I'm going to try to mount it on a Linux box first, just see if I see anything. Then if not, I will try the winmfs tools.

    By the way, winmfs was what I used when I expanded my series 2 - but not what I used to expand the premiere. Are those tools compatible with the premiere? I assume so, since you had the HD XL, but just wanted to check...
     
  6. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    Hook the EARS back up to your better half's 'puter.

    Don't bother with Disk Management, it doesn't read Apple Partition Maps and if you don't have it open it can't screw it up.

    Run WinMFS.

    Select the drive. If WinMFS crashes when you try to get it to select the WD20EARS, then it's probably severely screwed.

    If it'll let you select the drive, do so, then click on mfsinfo and see if it's set to boot from partitons 2,3, and 4, or from 5, 6, and 7.

    If it's set to 2-4, use the second option of fixboot, or whatever it was that spike called it.

    If it's set to 5-7, use the first option.

    Run mfsinfo again to make sure it swapped which set of partitions it uses to boot from, then exit the program, turn the computer off, and try the drive in the TiVo again.

    Might help, probably can't hurt.
     
  7. nooneuknow

    nooneuknow not quite dead yet

    3,556
    3
    Feb 5, 2011
    I've seen this happen many times with multiple premieres.

    With software version 14.8 (any letter sub-version), they eliminated the infamous GSOD (Green screen of death).

    The GSOD would warn the tivo user that there had been a serious error detected, it would attempt repairing any problems, that it could take (several) hours to finish repairing, and TO ABSOLUTELY -NOT- INTERRUPT THE POWER UNTIL THE WELCOME SCREEN CAME UP AFTER THE REPAIR process had completed.

    Now, you just get a black screen, while the TiVo does it's "repairs", which can still take hours (like go to sleep, and pray it's working when you wake up, hours).

    So, it is possible that you pulled the plug while it was repairing, and at a critical point, thus, (more likely, than not) rendering the image on that drive toast.

    As far as Kick-start tests go, they have been more likely to nuke my drives, than maintain them, if I use them without actually having a serious problem, or valid reason to use them.

    Tip of the Day #1: For future reference, never KS a TiVo on it's first reboot after a long time running (especially over a month - more so at three or more). They do their own checking and fixing during boot up (which is why TiVos take so long to boot).

    Tip of the day #2: Reboot all your TiVos without using any KS diags monthly, and they should keep running. This seems more true when the drive has been upgraded, and the TiVo has more things to hash over and check at boot time.

    Tip of the day #3: If you feel the need to do KS diagnostics, let the TiVo reboot without using any KS diags, then reboot again, and do what you want to do as far a KS diags go. I've still nuked a couple drives this way, but not like it used to be.

    Note: KS57 will result in a blank screen, as it runs (roughly) the same test that your unit was running, and the GSOD is removed for that at well.

    See this post:
    http://www.tivocommunity.com/tivo-vb/showpost.php?p=5643823&postcount=2

    It needs to be updated about the GSOD being removed with 14.8, but otherwise it's from a very reliable source, who got the info from a very reliable source. Also, I have best luck with KS in this order: 57, 58, 52 (then 54, if needed). Make sure to let the TiVo fully reboot in-between each one!

    It's also a good idea to connect the the TiVo service, and check for pending software updates notice BEFORE you unplug a TiVo and/or KS test it.
     
  8. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    I'll give this a try... As you say, it can't hurt ;-)

    Of course, I have to wait until Wednesday night to do so. But thanks everyone for posting great ideas and information, and so quickly. I'll post back when I have results.
     
  9. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    Yes, in fact that was the posting I went to when I first learned of the kickstart codes. It would probably help many people in the future if we could get the original author to update the post with the "black screen, no GSOD" warning.

    And might I say, BAD TIVO! That was a huge mistake on their part. What could they possibly gain from performing important tasks while showing the user a black screen? If I did this to my factory drive they'd have a box they'd have to fix under warranty. And for what? Because they REMOVED a useful warning screen! I'm a software developer, and sometimes I wonder if my brethren have all their marbles ;-)

    Thank you for all of the useful information about the boot care of my TiVo. To be honest, I'd been told directly by TiVo that it was a simple action in the past - nothing other than pull the plug or place the plug - and clearly there is more nuance to it than that. From this day forward I will always (when possible - power outage comes to mind) perform a manual connection before bringing my TiVos down. And I won't be spooked by a blank screen - I'll leave it overnight and be patient if I have to. Setting a reminder on my phone now to monthly restart them.

    Again, thanks for the good info.
     
  10. nooneuknow

    nooneuknow not quite dead yet

    3,556
    3
    Feb 5, 2011
    You could always forward or PM these posts to the aforementioned author of the KS post sticky post. I've been meaning to, but he and I don't always agree on the best -order- to use the KS diags, and I figured he'd either have noticed by now, or somebody would have told him...

    What else has changed, is that the blue LED no longer lights during the KS running period (it only flickers on a very brief moment when power is applied, or upon a reboot), then after initiating the KS, the red and yellow lights flicker back and forth, like the light bar on a police car (unlike how with the original process, the red, yellow, and blue would stay lit, and the blue remained on throughout the process (also new to 14.8).

    I figured that TiVo felt it was better for customers to not see the GSOD screen (less warranty demands from customers saying their TiVo "has encountered a serious problem")... That's my guess. I don't agree with that sort of "hide things from the customer" approach. But other than, by error, what other logical reason can be thought of...

    If you find yourself imaging and installing a drive with software older than 14.8, you'll find that the old behavior will remain, that is, until after 14.8 is downloaded and installed. So that proves that the behavior is not related to any sort of "firmware" update.
     
  11. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    So I plugged the WDEARS into my wife's computer tonight and ran winmfs. It let me select the drive - no crashing - but when I tried to view mfsinfo it told me that the selected drive was not a TiVo drive. So, unfortunately I can't see whether it is set to 2-4 or 5-7, and thus don't know which option to choose when performing the bootfix.

    Any thoughts?

    I don't want to give up just yet, but I'm pretty sure most would tell me it is time to do so. At very least I plan to just mount it on a linux box and see I can see any files.
     
  12. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    I would, but unfortunately I only have 7 posts, and it seems I need 10 to PM!

    Well, after this it will be 8 ... and I'm sure before I am finished with this issue it will be over 10 ;-)
     
  13. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    Boot from the MFS Live cd v1.4, and see what pdisk -l has to say about the partitions.

    If you actually still have TiVo partitions, do

    bootpage -?

    and then do

    bootpage -whichever option it says will tell you what the current root or boot partition is. I think there's also a "which one's the alternate?" switch as well.

    Once you know what's what you can do

    mfsinfo /dev/wherever the TiVo drive is

    just to see what it has to say.


    Then go back to WinMFS and use whichever option of bootfix or fixboot or whatever that'll change it to use the three partition's it's not using now.

    Then try it in the TiVo.

    Maybe you'll get lucky.
     
  14. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    Thanks for the quick reply! I will try that now.

    ...and this is my 10th post, so I can send that PM ;-)
     
  15. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    I ran pdisk -l and it showed 15 items. I'm afraid I don't know what to look for to note if I still have "Tivo" partitions, but I can see the 1.5T partition that probably has my data!

    One thing to note was this:

    pdisk: No valid block 1 on '/dev/hda'
    pdisk[837]: segfault at 10 ip 08050295 sp bfa01cf0 error 6 in pdisk[8048000+86000] Segmentation fault

    ---

    bootpage ? gave me:

    Error opening device ?!

    when I do bootpage /dev/hda, I get:

    Device "/dev/hda" does not appear to be a TiVo drive!
    Signature bytes 0x33 0xc0 do not match expected byte values 0x14 0x92

    Sounds like I got the same info from the live CD ... it doesn't see it as a TiVo drive, and thus can't make any changes?
     
  16. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    pdisk -l (and that is a lowercase L)

    will show something for all drives, TiVo and non-TiVo, and any cd or dvd drives as well.

    The 15 items should have looked something like this

    Partition 1 - Modified Apple Partition Map
    Partition 2 - Bootstrap 1
    Partition 3 - Kernel 1
    Partition 4 - Root 1
    Partition 5 - Bootstrap 2
    Partition 6 - Kernel 2
    Partition 7 - Root 2
    Partition 8 - Linux Swap
    Partition 9 - /var
    Partition 10 - mfs application region 1
    Partition 11 - mfs media region 1
    Partition 12 - mfs application region 2
    Partition 13 - mfs media region 2
    Partition 14 - mfs application region 3
    Partition 15 - mfs media region 3
    Partition 16 - Apple free

    You need to know which /dev your TiVo drive is.

    It sounds like maybe /dev/hda is your Windows hard drive on that computer. Is it a PATA drive perhaps? /dev/hd"x" tends to be PATA/IDE 40 pin devices and /dev/sd"x" tends to be SATA or USB (I think it was originally SCSI drives)

    Or could it be that /dev/hda is the cd or dvd drive on that computer? pdisk will throw up error messages when it tries to read something that isn't a hard drive.

    ---
    That's supposed to be

    bootpage hyphenquestion mark, otherwise it thinks you're specifying ? as a drive.

    These command line commands tend to be

    command hyphenoption (a hyphen followed by the choice of option without a space between the hyphen and the option) target

    so

    bootpage -a /dev/sda

    should, if my memory works, give you the alternate boot or root partition on the first sata drive if that drive is a TiVo drive. (I don't know if it would tell you anything about an old Apple drive or not).

    Often, if the option selected is "h", as in

    command -h

    you'll get what little help screen there is built into the command, but just in case the command uses "h" as an option for something else, I prefer to start with

    command -?

    and either the command is designed to respond to the question mark by returning the help screen, or it's designed to respond to unrecognized options (like a question mark) by returning the help screen.

    ---

    Boot with the MFS Live cd

    do

    fdisk -l


    That'll show any Windows/DOS type partition tabled drives.

    do

    pdisk -l

    That'll show any Apple partition map drives, including a TiVo.


    That should let you figure out which /dev is which.

    Report back. Then we'll go from there.
     
  17. bd3521

    bd3521 New Member

    13
    0
    Aug 3, 2010
    Hello Unitron: I saw this thread and was wondering if you could help as the problem appears very similar.

    I ended up purchasing the 1TB WD10EVDS as it was only $60 on Amazon and was already DVR optimized.

    I am having a big issue with WINMFS (Windows 7). I went to backup my existing tivo drive and it correctly labels the drive when I select drive "Tivo". But when I goto to perform a truncated backup or click msinfo it says "not a tivo drive". So I cannot backup my current drive to my new WD10EVDS.

    I wanted to make sure my stock tivo drive still works. Now when I put the original (was previously working fine) tivo drive back it constantly reboots after 10 seconds or so and all lights on the premiere blink. Reboot loop.

    So I tried "option 1" and then "option 2" of the bootpage fix with no luck. What should I do to at least get my original drive operational again?

    Thank you
    -Bryan
     
  18. timepieces141

    timepieces141 New Member

    14
    0
    May 8, 2007
    Just to round out this thread... I tried all of the tricks I had and nothing was recoverable. Clearly while my TiVo was performing extremely important tasks, and otherwise should have been telling me to UNDER NO CIRCUMSTANCES pull the power, I pulled the power.

    In fact I pulled it many times, rebooting every time I saw that blank screen. I am a casualty of the GSOD-turned-black! In the end I basically destroyed my partition table, so I was unable to get any Linux OS or Linux-based tool to help...

    On a good note, my drive was not toast so I was able to just re-copy from my factory drive, expand, supersize, and I am back up and running.

    In regards to the post about kick start codes, I PM'd the poster and turns out he was in the middle, that very night, of doing something to his TiVo and he was noticing the same thing. Since he's knee deep in this community he probably knew well enough not to keep pulling the plug like I did - and saved the drive he was working on. He said he'd do some more testing and then append his post appropriately. At least my pain helps others avoid the same ;-)

    Thanks everyone for your help!
     
  19. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    Don't know anything about Windows7 yet, just moved from 98 SE to XP Home in the past year, but from stuff I've seen elsewhere the whole "WinMFS" can't see the drive" thing seems to be related to there being different levels or versions of running as administrator in W7, and WinMFS only plays nice with one of them on W7, and otherwise doesn't recognize or do anything to drives.
     
  20. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    Yes, for some reason Tivo recently removed the GSOD (green screen of death) that warned you not to do anything to the Tivo until the process is complete. Now you just get a blank screen.

    These days, I never unplug the box unless I'm right at the Welcome screen or at the main menu.
     

Share This Page