Tivo plugin for Plex

Discussion in 'TiVo Home Media Features & TiVoToGo' started by dadrepus, Mar 9, 2013.

  1. bareyb

    bareyb Under Maintenance TCF Club

    26,363
    145
    Dec 1, 2000
    Silicon Valley

    Advertisements

    I just launched Plex from my TiVo and I'm streaming a video without my laptop being open. :eek:

    It's on of course, but the top is closed. How is that possible? All I did was open the Plex app on TiVo and all my videos are there. I know with PyTiVo you have to leave the laptop open for it to work.
     
  2. toddk63

    toddk63 New Member

    28
    2
    Jul 29, 2014
    First off. Great Plugin.

    I'm almost there, I think. I have installed the plugin and curl to my Linux server that is running Plex. In Plex, I can see my TiVo HD and all the programs on it. However, when I try to play one, I get the error "Video Unavailable. We're unable to play this video..."

    I have tried lowering the resolution on the Plex Client and giving the server a location for temporary transcoding. Could it be the slow USB WiFi that is it is delivering the program to the server? Any other ideas?

    Thanks,

    Todd K.

    Update: I ruled out the Wi Fi connection as it is clicking along at 9.5Mbps. I am suspecting it has something to do with the decoding part of the process. I ahve opened up the linux permissions to the TiVo ToGo bundle folder as well as tivodecode.
     
    Last edited: Nov 17, 2015
  3. Dec 8, 2015 #263 of 277
    EWiser

    EWiser Active Member

    549
    226
    Oct 2, 2008
    Man this plug in is not user friendly. Anyone know a good set of Mac instructions?
     
  4. Saturn

    Saturn Lord of the Rings

    12,825
    225
    Apr 10, 2001
    Did you ever get this resolved? I'm getting the same errors - timeout / broken pipe. I have two Series 3 tivos, both give the same error. Manually entering the curl command (after wrapping the url in quotes) works on the command line, and starts spewing data to the console...
     
  5. Feb 1, 2016 #265 of 277
    Saturn

    Saturn Lord of the Rings

    12,825
    225
    Apr 10, 2001

    Advertisements

    I spent some time trying to track down the timeout errors and I got stuck when I figured out it is the call to write the data (back to the transcoder) that is timing out. I suspect this broke when Plex switched to the new transcoder, but that's just a guess.

    I found this in the logs though:

    Code:
    Feb 01, 2016 21:31:42 [0x7f5115ffb700] DEBUG - Job running: /usr/lib/plexmediaserver/Resources/Plex New Transcoder -i http://127.0.0.1:49492/aHR0cDovLzE3Mi4yMC40LjIwNTo4MC9kb3dubG9hZC9UaGUlMjBTaW5nLU9mZi5UaVZvP0NvbnRhaW5lcj0lMkZOb3dQbGF5aW5nJmlkPTU4MzM1NzQ= -threads 0 -y -f dash -loglevel quiet -loglevel_plex error -map_metadata -1 -progressurl http://127.0.0.1:32400/video/:/transcode/session/eos04idmy7v/progress -vcodec libx264 -crf 19 -maxrate 3000k -bufsize 6000k -vsi 1920x1080 -preset veryfast -x264opts cabac=0:8x8dct=1:bframes=0:subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none:cabac=0 -min_segment_duration 1 -initial_segment 0 -force_key_frames expr:gte(t,n_forced*1) -sn -acodec aac -strict -2 -cutoff 15000 -ac 2 -ab 217k dash
    Feb 01, 2016 21:33:06 [0x7f5114ff9700] ERROR - [Transcoder] [mpeg2video @ 0x2682c60] 0x0 is invalid
    Feb 01, 2016 21:34:12 [0x7f5115ffb700] ERROR - Failed to start session successfully.
    
     
  6. May 9, 2016 #266 of 277
    KenNashua

    KenNashua New Member

    11
    0
    May 24, 2001
    Nashua, NH USA
    Alas, no. Very disappointed as I have a Amazon FireTV box upstairs and a Roamio downstairs and would love to be able to access my content from upstairs without having to purchase a Stream.
     
  7. May 9, 2016 #267 of 277
    Brrew

    Brrew New Member

    1
    0
    May 9, 2016
    Streaming your content via Stream and/or Roamio...

    Setup a VPN server built in on a router or Windows. There are plenty of tutorials on the net. This makes it so you're connected "in home" and the Tivo will stream to you.

    This works for the Tivo app in tablets and laptops. Just connect to VPN before starting the app when away from home.
     
  8. Jun 5, 2016 #268 of 277
    msadesign

    msadesign New Member

    24
    0
    Dec 30, 2003
    Naples, Fl
    Would you mind expanding your comment just a tiny bit?

    Don't need a tutorial, just a couple of hints.

    No problem with VPN and the related network details. I'm not getting: which device reaches out? and what device does it reach out to?

    Computer [Mac in this case] to the Tivo box?
     
  9. Revhead

    Revhead New Member

    1
    0
    Jun 11, 2010
    Been trying to get this working on linux for the past few days with some success.
    I have PMS set up on an Amahi 9/Fedora 23 headless server. Can see the Tivo To Go channel and see the programs on my Tivo HD, but it won't let me stream or download them?
    As an aside whatever I did installing this plug in has made the Plex DLNA server available to my WD TV Live which wasn't working before.
    Am I wasting my time or does this still work?
     
  10. dadrepus

    dadrepus Active Member

    362
    64
    Jan 4, 2012
    Plugin seems to be dead for Plex. I posted on the Plex forum with no response from the developer. The newer Plugin hosted on github was called TVOTOGO.bundle. He stopped work on it in 2014. His nickname was TIVOGUY. Does he post here?

    This seems to be a recurring problem with "Channel" creators for Plex. Very little followthrough and eventually it gets abandoned. I use almost no channels now in Plex as it seems that the only people to update their product are the core team in Plex. And there they mostly are building new features into Plex instead of refining the basic product. The forums filled with people saying: "I can no longer do this, something is broken, what happened to me videos, can no longer log in after update, android update broken, etc."
     
    Last edited: Nov 15, 2016
  11. Lexipher

    Lexipher LOVES Raspberry Pi 3 (2 is awesome as well)

    13
    3
    Aug 26, 2005
    Chi-town Burbs
    I'm running Plex Media Server on a Raspberry Pi 3.

    It was running on a Raspberry Pi 2, which I've since upgraded using the supplied rpi-update package.

    Anyway, Plex Media Server on the RPi [2|3] has been running fine, both before & after upgrade.

    Today, I finally got the notion to try TiVoToGo Plex Bundle on the RPi. I'd previously not attempted it as I could not locate a tivodecode executable for the RPi's architecture.

    No problem... found the source code for tivodecode and compiled.

    Before installing the TiVoToGo Plex Bundle, wanted to give tivodecode a kick in the tires.

    If I do a two step process of wget, followed by tivodecode, magic happens.

    However, and for reasons that I cannot explain, if instead I try to (as best that I can tell) emulate the TiVoToGo Plex Bundle via curl, then piped to tivodecode, no such luck.

    So, installed TiVoToGo Plex Bundle onto the RPi, hoping for magic, and, no such luck. Behaves like my curl piped to tivodecode experiment.

    For reference, I have the same TiVoToGo Plex Bundle installed on an x86_64 machine, works perfectly.

    Curl version on the x86_64 machine is 7.47.

    Curl version on the RPi is 7.38.

    Any thoughts?

    My reason for asking being that while its great that I have two Plex servers, I really only want one. I'd prefer it to be the RPi as I have no objections to keep it running 24/7. While with the x86_64 machine, even though I was really choosy with its hardware (its fanless & uses "little" power... for an x86_64 machine), it still draws more than the RPi.

    I'd prefer keeping the x86_64 turned off until I need to use it... it boots in less than 3 seconds, anyway.

    My interest in getting the TiVoToGo Plex Bundle operational on the RPi being ease of viewing recorded programs on other TV's (they have Roku devices attached), without the need for a TiVo Mini.

    Thank you!
     
  12. jimsearle

    jimsearle New Member

    2
    0
    Dec 17, 2006
    Did you every figure out how to get this working on an RPI 3? I have GitHub - sander1/TiVoToGo.bundle: TiVo To Go Plex Server Channel installed and it looks good, except of course tivodecode fails.
     
  13. bglf83

    bglf83 New Member

    7
    1
    Oct 15, 2014
  14. Sep 5, 2021 #274 of 277
    eohrnberger

    eohrnberger Member

    48
    3
    Oct 14, 2002
    Troy, MI
    Hi, I know it's been awhile since anyone last posted to this thread.
    Does anyone know if the sanders1 fork of TiVoToGo.bundle operational? Supported?
     
  15. Sep 5, 2021 #275 of 277
    dadrepus

    dadrepus Active Member

    362
    64
    Jan 4, 2012
    All plugins related to 3rd party apps are dead. Very few still work.
     
  16. Sep 5, 2021 #276 of 277
    eohrnberger

    eohrnberger Member

    48
    3
    Oct 14, 2002
    Troy, MI
    That's a bummer, but thanks for the info.
     
  17. windracer

    windracer No More TiVo :-(

    12,330
    247
    Jan 3, 2003
    St. Pete, FL
    I had forked the original code way back when, but since I exited the TiVo ecosystem over a year ago I haven't tinkered with it anymore. But yeah, I think plug-ins are dead.
     

Share This Page

spam firewall

Advertisements