Tivo Now Playing RSS Feed

Discussion in 'TiVo Underground' started by BOfH, Nov 16, 2005.

  1. Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005

    Advertisements

    Thanks, Markman! Everything is all fixed with 'view' and the RSS feed is great! Thanks to bushman and BOfH for the script.

    For the record... running Tiger 10.4.4 on a Mac with Safari using More Internet to define tivo://

    Jim
     
  2. Gunnyman

    Gunnyman Just a boring dude

    31,876
    906
    Jul 10, 2003
    Upstate...
    more internet ROCKS!
    For some reason the feed is broken in my safari. Works fine in newsfire, and shiira which is odd since shiira uses webkit too.

    here's the error:
    Code:
    Safari can’t open the page “feed:http://”. The error was: “unknown error” (NSURLErrorDomain:-1) 
    Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.
     
  3. bushman4

    bushman4 New Member

    108
    0
    Jun 6, 2005
    Massachusett...
    Gunny,

    Did that message resolve itself, or are you still having problems?

    Bushman
     
  4. Gunnyman

    Gunnyman Just a boring dude

    31,876
    906
    Jul 10, 2003
    Upstate...
    still having problems.
    What's odd is, it used to work just fine
    I think Apple did something to safari.
     
  5. Gunnyman

    Gunnyman Just a boring dude

    31,876
    906
    Jul 10, 2003
    Upstate...

    Advertisements

    and I THINK I just figured it out.
    The rss feed doesn't seem to like using my hostname (livingroom) to get to the tivo
    it works just fine if I browse tivoweb using the actual IP.
    newsfire works fine using the hostname though.
     
  6. pdawg17

    pdawg17 Here's Julia!!

    362
    0
    Mar 1, 2003
    Is there a way to use WMP when clicking on a show in the RSS feed?
     
  7. Leddy

    Leddy Guest

    35
    0
    Dec 8, 2002
    Hopefully this project is still alive. Have an issue with PPC rss reader. Was hoping you could take a look at it.
     

    Attached Files:

  8. bushman4

    bushman4 New Member

    108
    0
    Jun 6, 2005
    Massachusett...
    Sure...

    What is the problem? Is it the lack of Episode Title in the list? Or is it the squares at the end of each line?

    Thanks for the (inadvertent) pointer on an RSS reader for pocket PC... it even supports authenticated feeds, which is a requirement if you have your TiVo behind a reverse proxy...

    Bushman
     
  9. Leddy

    Leddy Guest

    35
    0
    Dec 8, 2002
    I don't mind the title thing. Once you click on it you see all.

    I just don't like seeing the square ;)

    You're welcome.They have a number of good RSS readers, but this one is great, especially for free :)
     
  10. bushman4

    bushman4 New Member

    108
    0
    Jun 6, 2005
    Massachusett...
    To get rid of the square, either download and install this new version (attached) or just change one line.

    Find this block of code:
    Code:
      puts -nonewline $chan "<title>"
      puts -nonewline $chan "<!"
      puts -nonewline $chan "\x5b"
      puts -nonewline $chan "CDATA"
      puts -nonewline $chan "\x5b"
      puts -nonewline $chan "$title"
      puts -nonewline $chan "\x5d\x5d"
      puts $chan ">"
      puts $chan "</title>"
    and modify the second to last line:
    Code:
      puts -nonewline $chan "<title>"
      puts -nonewline $chan "<!"
      puts -nonewline $chan "\x5b"
      puts -nonewline $chan "CDATA"
      puts -nonewline $chan "\x5b"
      puts -nonewline $chan "$title"
      puts -nonewline $chan "\x5d\x5d"
      puts -nonewline $chan ">"
      puts $chan "</title>"
    You just need to modify the second to last line, and add a "-nonewline" to it, to remove the carriage return/line feed between the actual title and the "Close Title (</title>)" tag.

    HTH,

    Bushman
     

    Attached Files:

  11. Leddy

    Leddy Guest

    35
    0
    Dec 8, 2002
    Editing the file worked awesome!!

    Thanks
     
  12. lloyd

    lloyd New Member

    87
    0
    Feb 15, 2003
    Bedfordshire
    Has anyone got nowplayingrss working with google reader? I can't seem to make it recognise the output from my Tivo as an rss feed.

    Lloyd
     
  13. luder

    luder New Member

    245
    0
    Sep 7, 2006
    Chicago, IL
    anyone know how to play tivo://tivo.ip/2893099 from tivowebplus?

    *edit*

    I have change the now playing list links to the above link but, unable to have a rss aggregator to view the shows anyone have any ideas please pm thanks
     
  14. ruexp67

    ruexp67 New Member

    479
    0
    Jan 16, 2002
    I just had the same problem. I got -View- to appear in the feed using IE7 as the reader, but it is not a link. I tried it with FeedDemon and the link is there. It looks like IE7 does not support embedded links.

    I am going to continue to research this, and see if there is a way to turn on Embedded links in IE7 RSS feeds.
     
  15. jack

    jack New Member

    49
    0
    Aug 13, 2000
    Southlake,...
    Does this stuff still work? I have a DTV Tivo with 6.2 on it. I download the last
    version of this posted here and I get:
    Code:
    http://tivoa/nowshowing What's on Living Room Tivo? en-us Fri, 31 Aug 2007 08:58:15 GMT http://www.tivocommunity.com/tivo-vb/showthread.php?t=271578 NowPlayingRSS (http://blog.durdle.com/nowplayingrss/)
    
    INTERNAL SERVER ERROR
    --cut here--
    action_nowplayingrss '' ''
    can't read "cache_ns_rec": no such variable
        while executing
    "lsearch $cache_ns_rec $fsid"
        (procedure "print_nsrow" line 121)
        invoked from within
    "print_nsrow $chan $rec"
        ("uplevel" body line 7)
        invoked from within
    "uplevel $body"
        invoked from within
    "ForeachMfsFileTrans fsid name type $nowshowingdir "" 15 {
    
    
    set rec [db $db openid $fsid]
    
    
    print_nsrow $chan $rec
    
    
    }"
        (procedure "MOD::action_nowplayingrss" line 127)
        invoked from within
    "$cmd $p1 $p2 $p3"
        (procedure "do_action" line 19)
        invoked from within
    "do_action $action $chan $part $env 1"
    --cut here--
    when I try and use it.

    Thanks - jack
     
  16. BOfH

    BOfH New Member

    15
    0
    Sep 9, 2003
    Hi,

    I wrote the Now Playing code when I was using a Series 1 UK Tivo - a long discontinued device which is now gathering dust in my attic.

    If anyone wants to take the code and ensure it works for later models (including all the new spiffy HD models you get in the US) then feel free. Maybe, if we're very lucky, we might some day get Tivo back in the UK, but I somehow doubt it.

    Cheers,
    Howard
     
  17. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    You're running an external module with TWP2. 2 problems with that:

    1) TWP2 clearly states it broke compatibility with external modules... only those that specifically state they run on TWP2 work

    2) TWP2 already has the rss feed rolled into it

    try deleting the module and then running "update" within TWP to load the latest version
     
  18. jack

    jack New Member

    49
    0
    Aug 13, 2000
    Southlake,...
    your right.. I'm a idiot.... I removed the added module, restarted TWP 2.x and
    see the RSS link now. it works.

    Sorry.
     

Share This Page

spam firewall

Advertisements