Tivo, Linksys WRT54G (Wired)

Discussion in 'TiVo Home Media Features & TiVoToGo' started by trelix, Jan 23, 2005.

  1. trelix

    trelix New Member

    11
    0
    Jan 16, 2005
    Help.

    I posted before but for I am still in a jam.

    I called Tivo.

    I called Linksys.

    My Tivo is connected to the Linksys Router via Cat-5 Connection.

    My computer is connected to the same router and is able to get internet connectivitiy. (cable modem/cablevision)

    On the Tivo, it shows as Gateway not found. (This message has begun the bane of my existence.)

    A Mac Address shows up on the Tivo.
    My computer cannot see the Tivo though. (Although it saw the Tivo MAC address brielfy the other day but I was still not able to connect. Moreover, the associated IP address was wrong as 192.168.1.0)

    Here's what I have done/tried to date:

    I set IP address at 192.168.1.148
    Subnet default.
    Gateway 192.168.1.1
    And specified the DNS from the ipconfig/all results.

    I am using a cable modem from Cablevision. (I do not use AOL.)

    I wanted to do the DHCP feature but since it cannot find the DHCP server, I set the static IP as stated above.

    I have set the port forwarding to 2190 for TCP and UDP.
    I have set the port forwarding 8080-8089 for TCP. Still nothing.

    I tried port triggering. Still nothing.

    I tried setting up a policy. Still nothing.

    I removed the firewall on the Linksys and also on XP. Still nothing.

    I have powercycled the equipement. Still nothing.
    I have reset the router still nothing.

    I am just plain old stumped and I am beginning to feel very stupid.

    I feel desperate and I beg for some help.

    Thanks.
     
  2. ellinj

    ellinj Seems Very Friendly TCF Club

    13,117
    189
    Feb 26, 2002
    NoVa
    Linksys should work out of the box. I would try upgrading the firmware and then doing a factory reset. I am using a WRT54G with DHCP with no problems.
     
  3. will792

    will792 New Member

    22
    0
    Jan 4, 2005
    CT
    Do basic network troubleshooting; ping and telnet from PC to Tivo. Something is not right since DHCP is not working correctly. Probably DHCP request times out. Make sure that you have "good" firmware on Linksys router. I personally use HyperWRT 1.3. Also a network adapter on Tivo should be fully supported by drivers since DHCP timing is set by a driver.

    You did not describe if you are able to get Tivo updates over a network connection. It would change troubleshooting path.

    Will
     
  4. BirdmanF14

    BirdmanF14 New Member

    21
    0
    Jun 11, 2004
    Some longshot possibilities on router problems

    1) router advanced routing setup as router instead of gateway and (3)
    2) security for mac address filtering being used and doesn't include network device mac address
    3) netmask or subnets setup with routing so that different devices are not visible to each other for routing
    4) Wireless security settings not consistent between router and network device
    5) Static IP address being used isn't part of routing subnet
    6) Access restrictions or port restrictions
     
  5. essjay

    essjay New Member

    7
    0
    Jan 10, 2005
    This sounds like a similar problem to what I have recently experienced. Not sure how to fix it but here is a test. Go to your TCP/IP settings for your internet connection and choose "Use the following IP address". Put in a known good 192.xxx.xxx.xxx type address, subnet 255.255.255.0, no default gateway, then close, close to set this up. Now try your connection to TiVo. See if you can now communicate with TiVo. If this works you have proven that the problem is with the DHCP setup to your modem.
     
  6. hoagie

    hoagie New Member

    51
    0
    Oct 22, 2004
    Maybe it's a bad network cable?? Sometimes the obvious answers are the correct ones..



    I know that when I got my Tivo hooked into the network it was plug and go.. It found the DCHP server on the router and I have had no problem get guide data through that..
     
  7. BirdmanF14

    BirdmanF14 New Member

    21
    0
    Jun 11, 2004
    Another longshot possibility is router needs to be configured for Mixed mode to support both 802.11b and 802.11g.
     
  8. hoagie

    hoagie New Member

    51
    0
    Oct 22, 2004
    The Tivo is using a wired connection and not wireless.
     
  9. trelix

    trelix New Member

    11
    0
    Jan 16, 2005
    ZOUNDS!

    Last night, I brought home a CAT-5 cable and plugged into router in kitchen on port 3 and used by laptop. It worked. Then I used the network adapter that I am using for my Tivo plugged into port 3 in the kitchen and confirmed that also works with my laptop. (This is good.)

    Next I plugged laptop into end of Cat-5 cable near Tivo in bedroom connected to router in kitchen. That didn't work. Then I also tried network adapter plugged into cable in bedroom connected to router in kitchen as I assumed it also didnt' work. (This is bad.)

    Therefore, I can ascertain that it is indeed the Cat-5 cable!! Morever, I should have figured this out sooner because I had just installed the Cat-5 drop three weeks ago and I never tested connectivity before the installer left. (Shame on me.) Anyway, I called the installer and told him that the CAT-5 cable doesn't seem to work and he is coming Wednesday to check it out.

    Hopefully, there is a light at the end of this long Tivo Tunnel.

    Thank you everyone for your ideas and support!
     
  10. hoagie

    hoagie New Member

    51
    0
    Oct 22, 2004
    No problem.. Glad it'll be taken care of.. Sometimes the low tech solutions get forgotten..
     
  11. BiloxiGeek

    BiloxiGeek DeleteAccount

    506
    1
    Nov 18, 2001
    DeleteAccount
    I'm not sure how familiar you are with Cat 5 cable but in case you're not:

    Sounds like he might have used a crossover cable instead of a normal straight through cable, or vice-versa. It most likely should be a straight through cable, make sure the wire colors are identical on both ends. Pin 1 on one end should be the same color wire as pin 1 on the other end, same for pins 2 through 8. This might be difficult to see depending on how the cable was manufactured/built. But something to check at least.
     
  12. edgardner

    edgardner New Member

    10
    0
    Jan 3, 2005
    After the 7.1 upgrade, I had to set my Tivo to a hardcoded IP address with the Linksys router, DHCP seemed to stop working.

    I had to manually set IP, subnet, gateway and DNS servers.
     
  13. corners

    corners New Member

    17
    0
    Jan 25, 2005
    After 7.1 upgrade, my network connection seems to have stopped working.

    At first it was OK, and I was halfway through downloading a program onto my PC, when that operation crapped out. Now I can't connect to my TiVo at all.

    Under Network setup it says "Gateway not found". However, it does seem to acknowledge the wireless adapter (Linksys in my case).

    Any ideas?
     
  14. trelix

    trelix New Member

    11
    0
    Jan 16, 2005
    All,

    My Tivo network anguish has come to a positive end.

    Last night I had the guy over that installed the network cable.

    He tested it and it appeared to be working from a breakage perspective.

    But the Tivo still didn't connect.

    Then I showed him how I can connect via my laptop with 3 foot cable to router but not with the connection he did.

    Then he ran another cable through my house. YIKES.

    However, this cable ALSO did not work. OMG.

    Five hours later, he thinks maybe it is the connectors. He didn't run the cable to a plate in the wall but had the ends sticking out. (He said this is for better connectivity.)

    He spliced the cable that I was using to show him how I can get on the Internet, he connected the wires to his cables (one at a time) and VOILA. Network connectivity. It was those pesky connectors. (They'll get you everytime.)

    Thanks again everyone.

    Of course, my dilemma now is I can't see the Tivo Server on my network server that is attached to the router that my Tivo shares. I only had a few hours to tinker with that. I will post when I get desperate. Thanks again, you guys are geniuses!!
     
  15. bdjohns1

    bdjohns1 New Member

    12
    0
    Jan 13, 2005
    IL
    Make sure 802.1x and loopback are turned off in the Admistration panel for the router. That had me screwed up for a while.

    (note, 802.1x doesn't have anything to do with most wireless connections - it's a mini server for certain clients that have issues)
     
  16. gt2112

    gt2112 New Member

    1
    0
    Feb 26, 2006

    I have the same problem, but didnt see a response to yours. Did you get it working? Can you point me to a link perhaps?

    Thanks-
    Jm
     
  17. corners

    corners New Member

    17
    0
    Jan 25, 2005
    I think ultimately, I just rebooted both my WiFi access point and (more importantly) the TiVO. That seemed to do the trick.

    Problem is, TiVO seems to lose the WiFi connection every few weeks. If I forget to recheck, no program update!

    Still, being used to Windows PCs, I've gotten used to the bug.
     

Share This Page