TiVo iPhone app connection issues over 3G

Discussion in 'TiVo Help Center' started by premiereman, Aug 23, 2011.

  1. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    Hey guys,

    About 4 out of 5 times or so when I try to connect to my TiVo remotely using the iPhone app (or iPad) over AT&T 3G, I get the popup "Lost Connection - Unable to connect to network. Press 'OK' to retry connection."

    If I am connected to a WiFi network, I have no problems connecting remotely. Has anyone ever experienced this issue? If so, what is your solution to the problem?

    Thank you!
     
  2. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,735
    1,906
    Jul 6, 2002
    boston'ish
    You can't connect to control via 3G, you have to use it in "offline" or tivo website only mode.
     
  3. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    The real question is how are you getting it to work 1 out of 5 times?
     
  4. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    I am not looking to control The TiVo, just connect to schedule recordings remotely which you are able to do. It will establish a connection sometimes, but most of the time I'll get the lost connection popup forcing me to restart the app and try again. It doesn't happen with any other apps, very strange.
     
  5. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    Just go to m.tivo.com in safari.
     
  6. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,735
    1,906
    Jul 6, 2002
    boston'ish
    Ok then that's a different issue than the way you described it in the OP.
     
  7. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    I've been using that but why continue when a specific iPhone app is now available direct from TiVo? Also, the iPhone app schedules recordings instantly as opposed to m.tivo.com which sends a request to record which could take the tivo unit a few hours to fulfill.
     
  8. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    It only schedules instantly if you're on your home network so it can communicate directly with your TiVo. If you're connecting over 3G, the app is just logging into tivo.com and scheduling things the same way you would through the web.
     
  9. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    Are you sure about that? Try scheduling a recording over 3G through the app; the TiVo schedules it immediately as opposed to the web page.
     
  10. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    I did, and it took about 15 minutes to schedule. Are you sure you're connected over 3G and not your WiFi network? When you first launch the app, does it scan for TiVos and fail? Then do you click the button that says "Sign in to tivo.com"?
     
  11. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    Yes, I am sure; I signed in and then get the limited options (can't see my shows, etc.). As soon as I schedule something to record on 3G, it instantly is scheduled. If it's a show already in progress, it will start recording immediately.
     
  12. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    And you're hitting the "Sign in to tivo.com" button?

    Now I'm confused about your original problem. If you're signing into tivo.com through the app, what is it that's not working sometimes?
     
  13. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    I just tried it with another one of my TiVos, and you're right it looks like it scheduled it right away. But then I tried it with yet another TiVo, and it says the TiVo is not connected to the Internet so it can't be scheduled (even though it is). The original TiVo took about 15 minutes to schedule.

    It looks to me like offline mode is pretty buggy.
     
  14. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    Just to add to the bugginess, I tried to cancel the recording the same way I just scheduled it (through the app on 3G), and I get "The app has encountered a problem and needs to restart". I tried it again and got the same thing.
     
  15. dkraft

    dkraft Member

    124
    0
    Dec 20, 2004
    I just turned off my Iphone Wi Fi which left me with only 3G. I opened the Tivo App on the Iphone and it scanned for a Tivo. It did not find a Tivo and asked me to Log into Tivo.com. I logged in, clicked on guide, clicked on a show to record and the Tivo started recordings instantly. Correction: Tivo was recording by the time I picked up the remote and brought the Tivo out of sleep mode, 4 seconds tops.

    I never new the App had this ability. Nice feature.
     
  16. generaltso

    generaltso Well-Known Member

    1,062
    25
    Nov 3, 2003
    Vermont
    Try cancelling the recording the same way. Does it work or does it crash the app?
     
  17. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    The original problem is that when I try to sign in through "tivo.com" it will drop the connection before I get to see my guide and connect to my TiVo over 3G.

    Yes, it's an amazing feature which is why I wish my app was working properly. Now you don't have to miss parts of a recording on a show that's starting within the next 30 min (or even 1hr sometimes) because the request hasn't been pushed to your TiVo yet. The scheduling through the App is instant as if you were at home on your WiFi connection.

    It crashes it, looks like this app is still a work in progress (It's only the first release after all).
     
  18. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    BTW, as for my issue, so far I've tried:

    1) Reinstalling the app
    2) Resetting my network settings
    3) Changing my tivo.com PW

    No solution yet to this glitch/issue
     
  19. Publius

    Publius New Member

    145
    0
    Jul 28, 2003
    Irvine, CA
    Has anyone solved this issue? I've had the same problem.
     
  20. premiereman

    premiereman New Member

    53
    0
    Aug 18, 2011
    Nope, I haven't been able to figure out how to solve this. I've tried so many things. Hopefully when the TiVo app update comes to the app store (Facebook will be integrated), it might address this bug.
     

Share This Page