TiVo HD HDMI Output not working after power surge

Discussion in 'TiVo Help Center' started by switch998, Jun 22, 2011.

  1. switch998

    switch998 New Member

    4
    0
    Mar 20, 2009
    Just earlier today we had a pretty big lightning storm, which took out my living room power, and broke my bedroom TV (We replaced the fuse in that, and it works fine now). Anyway, we have a UPS in the living room that the TiVo, TV, and AV Receiver are connected to, which supplied power during the outage. Since we have the UPS, it seems odd that the TiVo is having any problems at all.

    Since that outage, I can't get the tivo to detect an HDMI cable. The TiVo powers up, and I see the welcome screen for a minute or so, and then the TV goes blank. Component works fine on the unit, but I prefer to use HDMI.

    In any case, it seems that whatever circuitry the TiVo is using to detect an HDMI cable is now broken. Has anyone had any success with resolving this issue?
     
  2. dslunceford

    dslunceford Well-Known Member

    6,560
    319
    Oct 19, 2000
    No. VA/D.C.
  3. turbobozz

    turbobozz New Member

    211
    0
    Sep 21, 2006
    MD/VA
    No UPS or surge protector is a perfect defense against lightning strikes.

    I had a bad strike last year that killed almost all of my network equipment, and nearly every HDMI port on TiVos, PS3, and A/V receivers that were connected.
    Even through surge protectors and UPS.

    HDMI for some reason seems particularly sensitive to damage from lightning strikes.
    (Or perhaps they just ended up being the path of least resistance.)

    I now have an S3, a PS3, and an A/V receiver that work fine aside from broken HDMI ports.
     

Share This Page