TiVo HD and Color Space

Discussion in 'TiVo Series3 HDTV DVRs' started by Charles R, Aug 22, 2007.

  1. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    Anyone else see this issue?

    I installed a TiVo HD today and everything went fine. I had it hooked up to an analog TV during the setup process and once it was working great I connected HDMI from the AV receiver and at that point every thing went downhill.

    All I get is "off colors" (white being green, etc.) being displayed via HDMI. If I remove the HDMI cable the analog signal displays fine.

    I tried the following...

    1. Unplugged the HDMI cable from the TiVo HD back into the PS3 and it worked great.
    2. I tried switching to RGB video on the projector and it looked worse.
    3. I bypassed the AV receiver by plugging the projector's HDMI cable directly into the TiVo HD.
    4. Various reboots.

    Nothing works. Playing around I noticed if I did a cold boot the first TiVo splash screen's colors are fine and they don't get messed up until the second screen. Which is when TiVo probes your hardware?

    At this point TiVo thought I had a bad video card or some such thing. For the heck of it I connected it to a HD set via HDMI/DVI and the colors are fine. Which makes me think it's sending RGB video since I have to select RGB when I use the PS3 on that set.

    Although if it's sending RGB why doesn't my projector correct the colors when I switch over to RGB. I'm lost and at this point it just appears to be a compatibility issue and I'll simply install another cable DVR.
     
  2. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Just curious, but what video output format are you using? Native? Hybrid? Fixed? It sounds like the signal being output by the TiVo isn't compatible with your projector. Does it need 720p? 1080i? Try playing around with those settings.
     
  3. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    I tried all of them and the projector will take everything up to 1080p. The image looked sharp with the only issue being the colors.
     
  4. AbMagFab

    AbMagFab What happened, TiVo?

    3,638
    0
    Feb 5, 2001
    It's most likely your projector, doing some weird mapping. Try plugging directly into one of your HDTV's and see what happens.
     
  5. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    I noted above it worked fine with a HD set via DVI. I don't have a HDMI set to check. My cable's DVR works great with the projector along with several Blu-ray players so it is rather strange.
     
  6. vman41

    vman41 Omega Consumer

    10,879
    564
    Jun 18, 2002
    My TV's HDMI setup menu gives you 3 (non-auto) choices for signal type: RGB, YCbCr 4:4:4, and YCbCr 4:2:2. The series 3 appears to put out (or negotiate) 4:4:4, forcing 4:2:2 (or RGB) throws the colors off in different ways. There is also a setting for 'dynamic range', which gives the picture a green tinge if I select 'out of standard'.
     
  7. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    The projector offers RGB and YCbCr (not sure which one). Picking one the colors do change unfortunately though never display correctly. I do think it's some type of HDMI handshaking or color space issue. I had two DirecTiVo's and was looking forward to going back to TiVo.

    My guess is one side is confusing the other. Since I have used the projector with around a half dozen other HDMI devices my guess is it's the TiVo HD starting the problem.
     
  8. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    I called TiVo a second time this morning and this time they stated it was a known issue (not with all displays of course) with no resolution currently available. She called it Rainbows colors...
     
  9. Saturn

    Saturn Lord of the Rings

    12,671
    158
    Apr 10, 2001
    Can you use component instead? There's no negotiation there.
     
  10. TiVoJerry

    TiVoJerry Caavo employee (Ex-TiVo, '00-'16)

    1,554
    36
    Jul 26, 2005
    Woodside, CA
    Charles R,

    I'm not aware of this being a known issue and may need to coach the agent. Can you please send me a PM with your case number so I can research the report and work with you directly?
     
  11. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    PM sent.

    I asked the second agent if I could talk to someone who might be more familiar with the issue and she stated she was second level and after some "research" said it was a known issue. The gentleman last night felt it was a bad video card.
     
  12. Charles R

    Charles R Well-Known Member

    614
    269
    Nov 9, 2000
    USA
    You are right I'm sure I could. However with a 110-inch image I try to squeeze the last drop I can out of the source and in most cases HDMI will look a little better than component. I know it does with the Motorola DVR however with an older HD set component looks better with the Motorola so there are exceptions!

    It just didn't seem right not to be able to use HDMI. Heck it's a brand new projector and a brand new TiVo. I had enough grief using DVI and HDMI with my last generation.
     

Share This Page