Tivo Edge OTA doesn't receive the same channels as TV with the antenna

Discussion in 'TiVo Edge' started by Zaylyn, Nov 20, 2020.

  1. Zaylyn

    Zaylyn New Member

    7
    3
    Dec 7, 2019

    Advertisements

    I am having problems with my Tivo Edge waking up, and Tivo sent me a replacement (reburbished). However, this new Edge does not get 2/3 of the channels I received on my old Edge as well as when I plug the antenna directly into the TV. This new refurbished edge receives the strongest channels 10 miles from my house; but not the less strong channels 35 miles from my house. I have an antenna rated to receive channels 50-60 miles from my house and the specs for the antenna shows that I should receie these 35 mile distant channels without any difficulty. Is it possible, for some reason, that this new box is attenuating the signal more than the old box when it splits the antenna signal among the 4 tuners?
     
  2. phone man

    phone man Member

    62
    5
    Nov 4, 2011
    If you can argue that the previous Edge had no problems with reception but the "new" replacement Edge does and, that your TV tuner fed by the very same coax has no trouble receiving your normal stations, you should contact Tivo and arrange for another replacement.

    It makes sense that very weak stations might be harder to receive or may not be received at all by a four tuner unit compared to a TV or a 2 tuner Tivo. A two way splitter, - 3.5dB , four way splitter, -7dB.
     
    Last edited: Nov 28, 2020

Share This Page

spam firewall

Advertisements