TiVo Desktop won't start

Discussion in 'TiVo Help Center' started by danschn, Jul 29, 2006.

  1. danschn

    danschn Member

    111
    0
    Apr 22, 2004
    New York

    Advertisements

    Everything was working fine with TiVo Desktop 2.2.

    I upgraded to 2.3, and everything continued to work. But it seems that the next time I rebooted my host PC, I get an error message: "Beacon service not running".

    I dug around for help, and tried to start the TiVo Beacon service through the Computer Management application. The result is:

    "Could not start the TiVo Beacon service on Local Computer."
    "Error 1359: An internal error occurred."

    I have rebooted the TiVo (Pioneer w/ DVD).
    I have rebooted the PC (running XP, all security updates).
    I have de-installed, re-downloaded, re-installed TiVo Desktop 2.3.
    I have confirmed all home networking through the router continues to work, even communications between the PC and the TiVo - Galleon applications continue to work!

    Without the Beacon, the TiVo Desktop software apparently won't start, so I can't examine the settings & properties, but I know I entered the Media Access Key successfully a long time ago, and everything was working fine for the last several years until this month.

    What else?

    thanks,
    Dan
     
  2. CBNJ

    CBNJ New Member

    5
    0
    Jan 9, 2005
    USA
    I am having the exact same problem. Multiple installs/uninstalls..reboots..etc..nothing seems to fix it. Can't even get into Tivo Desktop.

    Thanks for any help
    Curt
     
  3. arucaria

    arucaria New Member

    2
    0
    Dec 1, 2005
    I had the same message in a Retry/Cancel box. Retry would do no good, the only way out was Cancel.

    I tried installation "Repair" but with the same results.
    Finally, I completely de-installed Tivo Desktop 2.3a re-booted the system, and then went for a fresh install. It didn't ask for media access key, presumably it already had it.

    After that the beacon service started OK. I think it started failing actually when I tried a re-install/Repair the first time. Maybe something up with the "Repair" part of the install.
     
  4. CBNJ

    CBNJ New Member

    5
    0
    Jan 9, 2005
    USA
    After about an 1hr and 15 minute phone call to Tivo support....w/ the majority on hold ....I too got it to work w/ a reboot. Before calling a did an uninstall...and full reinstall. This seemed to work.

    Also..since I had someone on the phone, I asked about using a NAS link w/ Tivo desktop. Apparently using a NAS device, like the Linksys I have, means (in their eyes) that you are using teh NAS to back up...or archive ( which I am) ...and Tivo Desktop doesn't support this. This is why I guess, when you go to choose where your media will be , as in where TD looks for it, you can choose a network device, but it then prompts you again.
     
  5. pickles102

    pickles102 New Member

    1
    0
    Aug 27, 2006

    Advertisements

    I'm having the same problem. Multiple installs/uninstalls..reboots..etc..nothing seems to fix it. Can't even get into Tivo Desktop. Everything worked fine with the 2.2 I didnt tell it to update to 2.3 and now the desktop doesnt want to work at all.

    Any Help???
     
  6. pdhenry

    pdhenry Ruthless

    32,056
    6,858
    Feb 27, 2005
    PA
    There's a 2.3a upgrade out there; I think it addresses this.
     
  7. docmcconl

    docmcconl New Member

    1
    0
    Aug 28, 2006
    First, I'd like to thank you all for your help, then I'll tell you what I did to fix it.

    I had the same problem: I would start the TiVo Beacon service over and over again, and it would stop spontaneously, finally giving me a message saying it could not be started on "Local Computer."

    So I uninstalled the program, rebooted, and reinstalled, but I think the main thing I did to fix it was delete my firewall rules for the TiVo applications (I use McAfee), and allow them to request access during the reinstallation process. It turns out that I had restricted some of the TiVo applications to "Outbound Access Only" when they required "Server Access" to run properly.

    Hope this helps, and again, thanks to everyone for posting their own solutions!
     
  8. Sep 1, 2006 #8 of 16
    heyjudii

    heyjudii New Member

    63
    0
    Jul 26, 2006
    i think mcafee is the problem. i have 3 computers, 2 running norton and sygate and 1 new one running mcafee. the 1st 2 never have any problems. the new one (with the mcafee) is constantly freezing, giving me the "beacon service not running" and in general freezing up and frustrating me.

    i will try adjusting the firewall rules.
     
  9. Sep 8, 2006 #9 of 16
    bcaz

    bcaz New Member

    1
    0
    Sep 8, 2006
    I had the same problem and found a different solution. First of all, I was running Tivo Desktop 2.1 and wasn't having any problems. I then upgraded to 2.3a and things seemed to work fine for a few days and then I started to get the same error (Tivo Beacon Service not started, Error 1359..). I tried uninstalling the desktop software, rebooting and then reinstalling but this didn't work. I tried disabling my Mcafee software and reinstalling 2.3a, still no luck. I even tried going to 2.2 but still received the same error. Then I noticed that I had an old JavaHMO Tivo program still installed. I used this for a couple of months but found too many problems with it so I discontinued using it. I noticed the Service, "JavaHMO TiVo TCM" was still running and set to startup at every boot. When I disabled this I was successful in "restarting" the Tivo Beacon and now the Tivo Desktop 2.3a software works again. I'm not sure if this will help anyone but there could be similar services disrupting the Tivo Beacon.
     
  10. skauffman

    skauffman New Member

    1
    0
    Sep 11, 2006
    bcaz, you're beautiful!!! I was having the exact same problem and spent hours trying to get the beacon to run until I came across your post. Thanks a lot!!!!

    -------------------------
    My very first post.
     
  11. bdpayton

    bdpayton New Member

    1
    0
    Sep 12, 2006
    I ended up uninstalling TD 2.3a AND Galleon 2.3.0 in addition to removing all firewall rules dealing with HMO, Galleon or Tivo. Rebooted and reinstalled TD 2.3a, and all is well.
     
  12. Marconi

    Marconi TiVo Junkie

    451
    0
    Sep 8, 2001
    Page, AZ USA
    I have a similar problem with Mac TiVo Desktop 1.9.3. As soon as I start it, it stops again. Won't stay running. Even more curious is that on another Mac with the same version of TiVo Desktop and OS X, it works just fine.

    Any Mac users know why this is?
     
  13. thetguy

    thetguy New Member

    1
    0
    Oct 28, 2006
    I had the same problem with the Tivo Beacon service error and, unfortunately, the suggestions given above didn't resolve it. Sometimes I would restart my PC and Tivo desktop would work and sometimes I would get the beacon error. Once the error occurred, the only way to resolve the issue was to keep rebooting until the Tivo Beacon service started OK.

    Today, I finally found that the Tivo Beacon service does not like having Galleon starting before it does. Galleon is a 3rd party program, so not everyone will it installed with Tivo Desktop. I determined that my Tivo Beacon error was caused by Galleon by doing the following. If you are having such an error, give it a shot. These instructions are for Windows XP.

    1. Click the Start button.
    2. Click “Run”
    3. Type “services.msc” (without the quotes) and click OK.
    4. Scroll down the list. If you don’t see a “Galleon” service, then this is not the problem. If you do see a “Galleon” service, double-click on it and press the “Stop” button. Once it has stopped, click the OK button to return to the services listing.
    5. Scroll down until you see the “Tivo Beacon” service and double-click on it. Then, click the “Start” button. Does it start without an error? If so, the “Galleon/Tivo Desktop” conflict is the problem.

    You can resolve the issue in two ways. One is safer for people not comfortable editing the registry, but requires you to start the Galleon service manually every time you start your computer. The other will resolve the issue without such interaction, but requires a registry change.

    To resolve without editing the registry:

    1. If the services listing is still in front of you skip to step 2 below. If not, perform steps 1 through 3 listed above.
    2. Scroll until you see the “Galleon” service and then double-click on it.
    3. Change the “Startup type:” to manual and click OK.
    4. Restart your PC. Once the desktop has appeared, give your PC a few minutes to start all its services.
    5. Click the Start button.
    6. Click “Run”
    7. Type “net start galleon” (without the quotes) and click OK. You’ll get a DOS like windows temporarily while the service starts.

    You will have to do steps 5 through 7 every time you start your PC.

    To permanently fix the issue by modifying the registry, do the following. Keep in mind, you need to be VERY careful as making a mistake when modifying the registry can have very bad consequences.

    A suggestion is to create a “System Restore” point before modifying the registry.
    To edit the registry for the Galleon/Tivo fix:

    1. Click the Start button.
    2. Click “Run”
    3. Type “regedit” (without the quotes) and click OK. The registry editor will start. If someone has modified the registry in the past, there will be multiple items listed on the left. Press your “left arrow” keyboard key until all you see is “+ My Computer” on the upper left.
    4. Click the + next to “My Computer” to open it.
    5. Click the + next to “HKEY_LOCAL_MACHINE”
    6. Click the + next to “SYSTEM”
    7. Click the + next to “CurrentControlSet”
    8. Click the + next to “Services”
    9. Scroll down until you see “TivoBeacon2” (or something similar, mine is TivoBeacon2” but I am not sure if this due to the version of Tivo Deskop I have installed or because I installed it so may times because of my issues. Regardless, write yours down. You will need the EXACT name of your Tivo beacon service for the steps below. I am not sure if caps count, but to be safe make sure to write it down with uppercase and lowercase letters as it appears.
    10. Scroll up until you see “Galleon” and the right-click on it.
    11. Move the mouse to “New” and left-click on “Multi-String Value”
    12. It will immediately prompt you name the key. Type “DependOnService” (without the quotes but with the uppercase/lowercase letters as shown”
    13. Now that you have created the key, double-click on “DependOnService” on the right.
    14. In the “value data” area, type what you wrote down in step 9. In my case this was “TivoBeacon2” (without the quotes)
    15. Click OK
    16. Close the registry editor and reboot.


    That should do it.
     
  14. Marconi

    Marconi TiVo Junkie

    451
    0
    Sep 8, 2001
    Page, AZ USA
    I appreciate all the effort to post this but as I noted, I'm on Mac. No beacons, registries, etc.
     
  15. bteichman

    bteichman New Member

    1
    0
    Mar 27, 2005
    thetguy - well done! I've been having this Tivo Beacon issue for years and I've reinstalled, etc. and eventually it always comes back. I'm on 2.4a and it occured again, but this fixed it. Indeed it was a conflict with Galleon and your registry hack worked! Thank you!
     
  16. reshelman

    reshelman New Member

    1
    0
    Feb 4, 2005
    This worked for me - ahve been trying to fix this problem for over a year now - thank you thank you thank you!!
     

Share This Page

spam firewall

Advertisements