TiVo Desktop Plus hangs after starting

Discussion in 'TiVo Help Center' started by justrick, Sep 19, 2011.

  1. justrick

    justrick New Member

    12
    0
    Dec 23, 2009
    After I start TiVo Desktop Plus, it hangs. No amount of restarting, terminating TiVo processes, etc. seems to help.

    I believe it's the latest version (2.8?), but I can't check because, well, it's inoperable. Any thoughts on what to do?
     
  2. RMBittner

    RMBittner Member

    215
    0
    Aug 19, 2003
    Charlotte,...
    Yes, 2.8 is the current version (although I think it's several years old). You should see the version number on the splash screen you get the minute you launch the program. (I'm assuming the "hang" happens after that, as the program is loading, searching for your TiVo hardware, etc.)

    I'm no expert, just a long-time user. But I think we're going to need to know more about your setup before we can offer any suggestions.

    What TiVo box are you using? How is it connected to your network? Have you tried restarting your computer? Anything more you can tell us will help.

    Bob
     
  3. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    2.8.2 is the latest version. Look for the TiVo guy in your system tray. You can access the Tivo Server Properties without having to start Tivo Desktop.
    Right click on the TiVo guy and select Tivo Server Properties.
    Under the 'About TiVo Server' tab, you will see what version of TD you have.
    Under the 'Access Control' tab, make sure your Tivo(s) are listed.
    Under the 'Network' tab, if you are currently using Bonjour, try switching to TiVo Beacon (or vice-versa).
     
  4. windracer

    windracer joined the 10k club

    12,259
    216
    Jan 3, 2003
    St. Pete, FL
    Try clearing the cache. Make sure no TiVo*.exe processes are running and then delete everything under:

    C:\Users\<username>\AppData\Local\TiVo Desktop\Cache

    (assuming you're running Vista or Win7)
     
  5. ggieseke

    ggieseke Well-Known Member

    5,691
    702
    May 30, 2008
    If the above suggestions don't help, try moving EVERYTHING in your My TiVo Recordings folder to a temporary folder somewhere else. If Desktop starts up okay after that you can move them back a few at a time. It reads a small portion of every file when it starts up, and a corrupt file can lock it up.
     
  6. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    I've got the MTR folder on it's own partition on one drive. Inside that folder are 2 shortcuts, one to a folder on a separate drive and the other to a folder on a second separate drive. Inside those folders I've got folders for actual shows into which I move shows after copying them to the MTR folder.

    When Desktop starts up and reads part of each file in the MTR folder, does it "drill down" into folders inside the MTR folder and into folders it has to follow a shortcut to find? That would help explain why it takes so long, considering it's got 4TB to look through.
     
  7. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    IME, Tivo Desktop is temperamental. Sometimes it starts right up, sometimes it takes longer, but is has never hung up on me.
     
  8. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    TiVo has an uninstall utility you can run after uninstalling it via the Windows Control Panel method that's supposed to clean out all of the crap left behind in the registry.

    You could try that and then re-install.
     
  9. ggieseke

    ggieseke Well-Known Member

    5,691
    702
    May 30, 2008
    Yes.
     

Share This Page