Tivo desktop install problem on Vista. HELP!

Discussion in 'TiVo Home Media Features & TiVoToGo' started by pparadis2, Mar 17, 2007.

  1. pparadis2

    pparadis2 New Member

    28
    0
    May 10, 2004

    Advertisements

    I recently upgraded to vista home premium, and now I can't install the tivo desktop software. I have even tried the older 2.2 version with no luck. I keep getting "internal error 2753 tivo transfer.exe32"

    I've turned off vista's UAC, and tried installing as admin. Anyone have a similar problem? Or any ideas?

    Thanks
     
  2. srcousino

    srcousino New Member

    9
    0
    Mar 10, 2007
    i have vista home premium and i had no problem at all installing or running tivo desktop
     
  3. sparky9365

    sparky9365 New Member

    4
    0
    Feb 15, 2005
    I'ver upgraded to Vista Business Edition. I'm having the same problem that you are experiencing.
     
  4. tivoray

    tivoray New Member

    34
    0
    Feb 3, 2005
    Make sure that program files/common files/Tivo Shared has been deleted from any previous installation. I assume you uninstalled all previous versions.

    This worked for me with Tivo 2.2 - I can't get any higher version to work. I am on both Home Premium and Business.

    Good luck

    TivoRay
     
  5. Jabo4

    Jabo4 New Member

    21
    0
    Feb 17, 2007

    Advertisements

    I have 2.3 installed on both ultimate and business, all I did was run the installer with Admin Rights @_@
     
  6. yukit

    yukit Member

    211
    1
    Jul 23, 2005
    This is probably not practical for most people, but here is how I got around the problem.

    I am using a WinXP virtual machine running on Vista. Tivo Desktop is running in the virtual machine. It works well enough for me, but most likely not suitable for you:

    1. You need to setup a virtual machine. Microsoft requires you to have a license for the OS even if it is in a virtual machine.

    2. I am saving the files to a NAS on my network. It is not practical to store the Tivo files in a virtual machine. However, you can store the files on the Vista machine through network or shared folder access.

    [​IMG]

    Full size image here:
    http://farm1.static.flickr.com/226/467913078_9f7681775e_o.png
     
  7. wizzy

    wizzy S1, (2) S2, TivoHD

    78
    0
    Nov 11, 2001
    Chicago, IL
    I've been unable to get 2.3a to work on Vista since Thanksgiving. It always works immediately after install, but upon reboot, TivoServer reports that the transfer service isn't running. It shows up in blocked programs, but doesn't start when I request it manually.
     
  8. aenima99x

    aenima99x New Member

    16
    0
    Apr 26, 2007
    I've had TiVo desktop and Galleon running on Vista Enterprise for a couple months now. Just run Tivo Desktop in XP SP2 compatibility mode. I do get the "Transfer service not running" error every once in a while when logging in, but hitting retry starts it.
     
  9. zeke009

    zeke009 yeap...

    38
    2
    Sep 18, 2004
    Minnesota
    There are a lot of reports of Vista upgrades causing problems. You're better off in the long run of backing up your data and starting fresh with a clean Vista install.

    If you only have a vista upgrade disc, you can still do a clean install. It just takes twice as long to perform.
    1) Backup existing data
    2) See step 1
    3) Whipe that drive clean and install vista
    4) DO NOT ACTIVATE
    5) Run the install again from the DVD and select upgrade and follow the prompts
    6) Now activate
     
  10. BJ411

    BJ411 New Member

    66
    0
    Jun 5, 2006

    I have a new laptop with vista home premium and it will NOT let tivo2go download.. the 2.4 freebie... i had the paid version on the laptop that died.. ridiculous tivo rips us off at every opportunity... so now i don't get the featured i paid for on the new laptop. and the dang program will not download (free version) will not download on vista home premium..


    you get a msg that says "sorry you need xp....."


    and per this page: http://www.tivo.com/4.9.4.1-2_win.asp


    fine print: "tivo2go is not yet compatible with windows vista"


    this is ridiculous that i'm paying for alllllll these services and tivo was not prepared for the vista OS...
     
  11. justinalpertesq@

    justinalpertesq@ New Member

    2
    0
    Jun 1, 2006
    Hey, i finally got tivo working on vista. downloaded 2.3a to the harddrive, right clicked the download file and ran the .exe as XP SP2. Once the set up was complete, i ran the extracted program file as XP SP2 also and specifically authorized my Tivo.

    Finally, I can both upload movies to the computer, and access music and pictures through the Tivo. Happy happy.

    As an aside, I am digging vista... very 21st century.
     
  12. kkasten

    kkasten New Member

    4
    0
    Mar 18, 2007
    I got screwed when I had 2.3a running on Vista Home Premium edition and tried to install 2.4a - which had me uninstall 2.3a and then told me that it wouldn't install unless it was under XP-Svc pack 2.

    So now I'm looking to install the MSFT Virtual Machine or an old version 2.3a.exe.

    Does anyone have a old version of 2.3a they can email me or the location of one on the net?
     
  13. hal_lavender

    hal_lavender New Member

    2
    0
    Jul 22, 2006
    Okay.. I have figured out how to make this work and it explains why with new installs, why those people never have a problem.
    Turns out that when Tivo installs itself, it sets the permission on the LEGACY_BEACON keys in the registry to READ only! Therefore, when you try to re-install desktop it fails. You have to go in to regedit (run it as as administrator), locate the LEGACY_BEACON keys (there are 2 of them. I did it 20 minutes ago and already forgot.. it might be LEGACY_BEACON2), right click on it.

    first unisntall any existing version
    Got to start on the computer
    Run "regedit"
    Find the key LEGACY_B (using Find)
    Right click on it and go to permissions
    click on the Advanced button
    Go to owner tab
    click on "replace owner on subcontainers"
    click apply
    click ok
    Now add full control to your user ID
    Click OK

    Now delete the key

    Do this for all of the Legacy_Beacon keys
    click on the owner tab
     
  14. skilansing

    skilansing New Member

    1
    0
    Mar 25, 2007
    hal_lavender,

    I tried your suggestion, but I didn't have a LEGACY_BEACON key. The closest thing that I have is LEGACY_BEEP.

    Any other suggestions?

    Thanks,

    Ski
     
  15. Robart999

    Robart999 New Member

    16
    0
    Feb 23, 2005
    where can i get 2.3a????
     
  16. ocntscha

    ocntscha Member

    149
    0
    Oct 22, 2003

Share This Page

spam firewall

Advertisements