Tivo Desktop - How to force network adapter?

Discussion in 'TiVo Help Center' started by pldoolittle, Oct 16, 2011.

  1. pldoolittle

    pldoolittle Tivo'ing since 2001

    299
    45
    May 2, 2002
    I run vmware on my Tivo Desktop machine, and thus have several network adapters. After a reboot, and apparently after sleeping, TivoDesktop seems to pick the FIRST adapter. Since this is a vmware virtual adapter, all the DVR's lose connection to TivoDesktop.

    Since it will never be correct for it to use any adapter expect the physical adapter, does anyone know how to force desktop to use a particular network adapter and *not* change?
     
  2. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,727
    1,898
    Jul 6, 2002
    boston'ish
    Tivo Server properties will let you specify an adapter, that should be sticky.
     
  3. ggieseke

    ggieseke Well-Known Member

    5,703
    705
    May 30, 2008
    The adapter you set in TiVo Server Properties should stick unless you're running an old version of Desktop. Back when I had the same problem I started Desktop with a batch file and used a Microsoft utility called devcon to disable the VMWare adapters, start everything else, then enable them.
     
  4. pldoolittle

    pldoolittle Tivo'ing since 2001

    299
    45
    May 2, 2002
    Unfortunately, even with 2.8.2 it seems to revert to the first listed adapter. I've checked ini files and even the registry, but cannot find any location where this value is stored.

    That would work, but it's a kludge.

    For a company that started off developing game changing technology, they sure have gotten content re-selling the same old half-baked products year after year...
     
  5. ggieseke

    ggieseke Well-Known Member

    5,703
    705
    May 30, 2008
    It's stored in the registry in the "HKEY_CURRENT_USER\Software\TiVo\Desktop\Server\CurrentNetworkAdapter" key.

    If you use TiVo Beacon instead of Bonjour, also see the "HKEY_LOCAL_MACHINE\SOFTWARE\TiVo\Desktop\Beacon" key.

    I tried it yesterday on 2.8.2 without using devcon or my batch file and it worked fine for me. One thing you could try is going into the Advanced network settings. Once you find it, there's a dialog that lets you prioritize your connections. You could also try switching from Bonjour to Beacon.
     

Share This Page