Tivo Desktop 2.8.2 - not seeing Photos and Music

Discussion in 'TiVo Home Media Features & TiVoToGo' started by dowlingg, Nov 3, 2011.

  1. dowlingg

    dowlingg New Member

    23
    1
    Jan 19, 2010
    I just recently installed 2.8.2 on my Windows 7 Ultimate (64-bit) PC because I was having slowness issues with 2.8. It transfers and views shows fine, but when I want to display the contents of either my photos or music, the "Properties" within TD starts to calculate for about 2-3 seconds before it zeroes out. When I try to view them from either of my 2 Tivo's, I get the message "an error occurred on the server. Please check the Tivo Server application on your computer."

    I even uninstalled it, ran the TivoDesktopCleaner, then reinstalled it as "administrator"... to no avail. I'm wondering if I need to go back to 2.8 and deal with the slowness and such.

    Any thoughts?
     
  2. wmcbrine

    wmcbrine Well-Known Mumbler

    11,658
    786
    Aug 2, 2003
    Try pyTivo?
     
  3. dowlingg

    dowlingg New Member

    23
    1
    Jan 19, 2010
    I have jumped through some hoops w/ Tivo support on this one. I re-removed the software and reinstalled it. Installed Bonjour Print Server for Windows. Powercycled my cable modem, wireless router, my Windows 7 PC, and one of the Tivo boxes. I even updated the firmware to my wireless router. All provided the same lack of results.

    The *only* thing that worked was when I republished music & photos into a different directory -- specifically anything *other* than the main "My Documents", "My Music", or "My Pictures" directories. It seems that Tivo Desktop greater than 2.8 (e.g. 2.8.1, 2.8.2) and Windows 7 have issues publishing music & photos in their default locations. Maybe it is a permissions thing? Thoughts?
     
  4. CuriousMark

    CuriousMark Forum Denizen

    2,620
    3
    Jan 13, 2005
    SoCal
    It sounds to me like it cannot handle libraries. Try navigating to the directory via the direct path instead of through the library and see if that makes any difference.
     
  5. dowlingg

    dowlingg New Member

    23
    1
    Jan 19, 2010
    I'm not sure. When I try to view the properties of certain directories under "My Pictures" (for example), sometimes it provides the correct number of pictures & directory size... whereas others it starts to calculate and then simply zeroes out. It's almost as if the software is tripping over some file during the calculation... so then it will not display the pictures or music through the Tivo.
     
  6. dowlingg

    dowlingg New Member

    23
    1
    Jan 19, 2010
    I think I figured it out, and it has to do with whatever changes Tivo made between versions 2.8 and 2.8.1 (and beyond). When the software scans files of a certain extension (e.g. .TXT, .ZIP, .MOV), it simply zeroes out and will not allow that directory tree to be seen from the Tivo's. It shouldn't matter since these files will not be seen by Tivo anyway, but why stop the software from working?
     
  7. dowlingg

    dowlingg New Member

    23
    1
    Jan 19, 2010
    Retract my last comment... although it was weird that it still worked with Desktop 2.8. My "sample music" and "sample pictures" link files (.LNK) were broken. That was it... simple as that. Those link files were not going to any particular target because I had copied them over when I went from my old XP computer to my new Windows 7 computer last March.

    Case closed.
     

Share This Page