TiVo Desktop 2.0 "EAccess Violation" error

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Toddler, Feb 12, 2005.

  1. Toddler

    Toddler New Member

    53
    0
    Dec 28, 2001
    Franklin, TN

    Advertisements

    Several people have reported this problem with "EAccess Violation" and the new TiVo Desktop 2.0. I posted my solution over at forums.tivo.com and figured I'd contribute it here also.

    There seems to be something funky going on between Norton and the new TiVo Desktop 2.0.

    Many of the people experiencing the problem reported using Norton AntiVirus 2005. I've got NAV 9 Corporate Edition. I have a clean Windows XP SP2 machine that literally runs nothing but TiVo Server. It was running the 1.3 version just fine. As soon as I upgraded to 2.0, I started getting the "EAccess Violation" box at startup, and no TiVo Server.

    I won't bore you guys with the troubleshooting steps that led me to this conclusion, but, at least on my system, Norton was definitely the culprit.

    Now for the workaround...configure NAV to exclude the "C:\Program Files\TiVo" folder (or wherever you installed it). That's it...problem solved.

    Of course, the ultimate fix lies somewhere between TiVo and Symantec. But if you've had this problem, this should get you working.

    -Todd
     
  2. dherchen

    dherchen New Member

    2
    0
    Apr 18, 2005
    Pittsburgh
    Has anyone seen this eAccess Violation with McAfee Anti-Virus? All of a sudden, two weeks ago and after working since February, my Tivo Desktop won't launch properly. A task shows up in Task Manager but the UI never comes up. If I quit Windows (XP SP2) I get the violation. The DVR can't see the laptop even though server, beacon and transfer show as running. I don't know the exact day it quit because I don't use it everyday. The only other thing I installed around that time was a new Netgear 802.11G pc-card but McAfee updates constantly. I also had to chuck McAfee Spamkiller around the same time because it was interferring with all kinds of things.
     
  3. sixseven

    sixseven New Member

    98
    0
    Jan 6, 2005
    Toddler,

    Thanks for the post! Upon every reboot, I had to end-task the tivoserver.exe (which was taking all system resources) and stop and restart the tivobeacon process, and finally restart the Tivo Server from the software. Hopefully this will help! :)
     
  4. sixseven

    sixseven New Member

    98
    0
    Jan 6, 2005
    I'm curious, what sort of a security risk does this create?
     
  5. comgenius1

    comgenius1 New Member

    90
    0
    Feb 15, 2004

    Advertisements

    I get that EAccess error, but its when the computer shuts down, not when it boots up. I'm runing WinXP home, SP1 and norton antivirus. The error will prevent the computer from shutting down until someone gets rid of the message.
     
  6. May 5, 2005 #6 of 14
    ccbell

    ccbell New Member

    1
    0
    Jan 12, 2005
    Thanks Toddler for your solution. This problem has been driving me crazy for weeks and everything I tried didn't work. I used your solution, and so far, so good. This news should get around!!!!!!

    Clarke :) :) :)
     
  7. geekseeker

    geekseeker New Member

    2
    0
    May 24, 2005
    Toddler or ccbell ... could you describe in a bit more detail what Norton AV screen you used to make the exclusion for TiVo? Was it the Norton Antivirus Option Screen? If so, which option? The "System AutoProtection Exclusion List?" Thanks
     
  8. JPA2825

    JPA2825 Member

    430
    0
    May 15, 2000
    Ft. Thomas,...
    Ditto. I'd like a step-by-step as well if anyone can provide same.
     
  9. davidsf

    davidsf New Member

    5
    0
    May 27, 2005
    California
    Re: the step-by-step, Geekseeker had it right. Just boot up Norton Anti-Virus, click on the "options" button, then click on "Auto-Protect", then click on "Exclusions", then click on the "open folder" icon (which is equivalent to "browse"), then zero-in to the Tivo To Go Folder -- mine was at: C:\Program Files\Tivo\Desktop\
     
  10. davidsf

    davidsf New Member

    5
    0
    May 27, 2005
    California
    My friend has been having the same "Eaccess Violation" problem. He uses AOL which I believe has McAffee Virus Protection. Don't want to phone him with this solution since he's not very good with computers, but I hope McAffee has a similar "exclusion" feature so when I get over to his house next time I can have McAffee exclude scanning the folder: C:\Program Files\Tivo\Desktop\
     
  11. dbeck316

    dbeck316 New Member

    10
    0
    Feb 20, 2006
    Hi.

    I'm having the EAccess problem as well. I have NAV 04. How do I configure it to avoid the Tivo folder. I called Norton and they said I have an unsupported version and refused to talk to me at all. I guess thats what I get for being a good customer. (Thats my problem tho.)

    Can you give me instructions to configure NAV to avoid the Tivo folder please.

    Thanks,

    Doug
     
  12. mrjam2jab

    mrjam2jab Still Learning

    524
    0
    Jul 23, 2004
    Levittown, PA
    I get it with McAfee.....i check to see if i can make that work around...work...
     
  13. dbeck316

    dbeck316 New Member

    10
    0
    Feb 20, 2006
    I was having the EAccess Violation. I switched from Norton to PC-Cillin and so far it is not a problem. I'll repost if the problem happens again.

    D
     
  14. dryheatwriter

    dryheatwriter New Member

    1
    0
    Jun 19, 2006
    Just to let everyone know, the problem still exists in NAV 2006.

    I get the EAccess Violation with shut down and with resume from standby (logging in after screen saver).

    The solution in 2006 is the same. Open NAV Options, click Auto-Protect, then click Exclusions and click New. Add the Tivo folder and you're done.

    Has anyone seen if this gets hit on a manual scan? If so, you'd need to add the same exclusion for Manual, I suppose.
     

Share This Page

spam firewall

Advertisements