Tivo Customer Support - Mike #552538 - HORRIBLE!

Discussion in 'TiVo Series3 HDTV DVRs' started by AbMagFab, Aug 2, 2007.

  1. Aug 2, 2007 #1 of 19
    AbMagFab

    AbMagFab What happened, TiVo?

    3,638
    0
    Feb 5, 2001

    Advertisements

    So I've got 7 Tivo's now, and had 8 others with DirecTV. I get Tivo. I know how the activation process works. I know that there are glitches once in a while, everything from Universal Swivel Search not being enabled, to transfers not being enabled, etc. Even when everything looks right on the manage account page.

    So I activated my TivoHD last Thursday. A week later, in the System Information screen, it still says "Name this Tivo on tivo.com". So I call customer support to get it fixed.

    - Mike, #552538, says to me "Well, you don't need that since it doesn't do MRV or TTG".
    - My response "Well, it might in the future, and I'd like it in there. Please lets try to get this fixed".
    - Mike - "Well, there's nothing I can do from here."
    - Me - "There must be, since it's not working on one of 7 Tivo's."
    - Mike - "Sorry, I can't do anything about names here, maybe you should just wait, sometime it takes a while"
    - Me - "A while, like a day or two, yes. Not a week."

    This just degraded, with Mike #552538, telling me that he didn't say what he said, with him cutting me off, and finally me pulling the "I'm a customer with 7 Tivo's, listen to me!". Then he hung up.

    I've never had such a horrible customer service experience with Tivo. It was worse than DirecTV!

    To the point - anyone know here what to tell the useless Tivo Customer Service folks to get my Tivo properly named?

    Thanks!
     
  2. Aug 2, 2007 #2 of 19
    Chimpware

    Chimpware New Member

    334
    0
    Jan 30, 2002
    Should just be able to go to your account on Tivo site, and under Manage My Account there is a button on the top right under Related Links that says Name Your DVRs, from that screen you can name your Tivos.

    I feel your pain, Tivo CS gets no love here.
     
  3. Aug 2, 2007 #3 of 19
    ZeoTiVo

    ZeoTiVo I can't explain

    25,527
    2
    Jan 2, 2004
    umm - you can say - I named my TiVo on the web site but it has not taken on the DVR yet :) Did you enable downloads to the TiVo?

    I do not think Mike has a long career in Customer Service ahead of him :rolleyes:
     
  4. Aug 2, 2007 #4 of 19
    AbMagFab

    AbMagFab What happened, TiVo?

    3,638
    0
    Feb 5, 2001
    I know that - I've got 7 Tivo's. It's named on the site, but it's not pushing to the Tivo. I've got TivoCasts working, remote scheduling, everything. Except the name in the status screen.
     
  5. Aug 2, 2007 #5 of 19
    ZeoTiVo

    ZeoTiVo I can't explain

    25,527
    2
    Jan 2, 2004

    Advertisements

    in that case = rename it and if that takes then rename it back. I have used that before when everything else was working right
     
  6. Aug 2, 2007 #6 of 19
    rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    Check this thread: http://www.tivocommunity.com/tivo-vb/showthread.php?p=5379059&&#post5379059

    It seems its not only you. Perhaps you are running the latest update as well?
     
  7. Aug 2, 2007 #7 of 19
    aus1ander

    aus1ander New Member

    516
    0
    Sep 17, 2004
    Yeah I think this is a result of the update. My TiVo HD lost its name and for some reason, its not pushing from the website. Under TiVo Desktop, it shows up as DVR-XXXX instead of its proper name.
     
  8. Aug 2, 2007 #8 of 19
    AbMagFab

    AbMagFab What happened, TiVo?

    3,638
    0
    Feb 5, 2001
    Mine too. And the Tivo CSR was a total moron, telling me I didn't need it since MRV and TTG aren't enabled. Great answer.

    Started a list of Moron Tivo CSR's: Mike #552538
     
  9. Aug 2, 2007 #9 of 19
    moldymac

    moldymac New Member

    24
    0
    Mar 26, 2006
    I have the same thing, this is especially annoying because I use amazon unbox. Worked great until the update went in
     
  10. AbMagFab

    AbMagFab What happened, TiVo?

    3,638
    0
    Feb 5, 2001
    If this is related to the new update, then even more shame on Mike the horrible Tivo CSR. He should at least have this in his brain-dead script.
     
  11. alansplace

    alansplace ------ Alan ------

    804
    0
    Apr 30, 2006
    Southern...
    same problem here with my new 652. i've waited 48 hours and it still says:

    DVR Name: <Name this DVR on tivo.com>

    on the 652's 'System Information' page.

    unlike you, i've had all good service techs when i've called, though they can't seem to fix the problem. i do have a case number for it.
    --
    Alan :D
     
  12. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    It sounds more like an issue with their backend/billing system and the new software. I'm sure once TiVo fixes it on their end, all the boxes will magically revert to the correct DVR name.
     
  13. alansplace

    alansplace ------ Alan ------

    804
    0
    Apr 30, 2006
    Southern...
    makes sense!
    --
    Alan :D
     
  14. alansplace

    alansplace ------ Alan ------

    804
    0
    Apr 30, 2006
    Southern...
    i went to the web site and changed the names of all three of my activated TiVos. the 540 and the 649 have since changed, buit the 652 (TiVoHD) still says:

    DVR Name: <Name this DVR on tivo.com>

    i guess waiting doesn't work!
    --
    Alan :D
     
  15. bizzy

    bizzy New Member

    707
    0
    Jan 20, 2004
    San...
    My old-fashioned S3 says this now too (name this on tivo.com) even though it has been set up and named for ages; and has worked previously with Unbox.

    I'll ask tivo support if I have a chance; I am on hold to ask them why my S3 crashes when I try to watch Cable :(
     
  16. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    Looks like there is either a problem with the b revision not picking up the name or something new - multiple changes of the DVR name and forced updates still yield no name on the THD box.
     
  17. brossow

    brossow TiVo DiVo-tee

    152
    0
    Jan 25, 2004
    Mankato, MN
    Same problem here with both of my S3's. (Just thought I'd chime in.)
     
  18. bkdtv

    bkdtv New Member

    7,902
    2
    Jan 9, 2003
    DC Metro Area
    The support representative was right that they have no control over this.

    It will be fixed by the time Tivo enables MRV and TTG this fall, as announced by TivoPony last week.
     
  19. nhaigh

    nhaigh Member

    984
    0
    Jul 16, 2001
    Lawrencevill...
    I just had a look having read this thread and my S3 says the exact same thing. It was fine up until recently and something other than me has caused this to change.
     

Share This Page

spam firewall

Advertisements