TiVo can't activate my Roamio Pro.

Discussion in 'TiVo Help Center' started by JJJB, Apr 1, 2015.

  1. JJJB

    JJJB Member

    67
    0
    Nov 8, 2003
    Chicago

    Advertisements

    So after getting a an email from Amazon telling me I wouldn't be able to download to my old HD20 anymore and them giving me the $100.00 off a new Roamio incentive. I bit the bullet and purchased a new Roamio Plus. Now even though I'm a video engineer for a living I know changing out one TiVo for another in theory should be relatively simple even with the cable card fiasco I was sure would ensue. Well never in my wildest dreams did I ever think that 2 days after me installing it that TiVo still can't activate it.
    Several phone calls(4-6), 4 technicians etc.... and the story I'm getting is "since your TiVo "updated" it's software on install our computer software back here at the back office can't activate it. The last guy told me today it might be 3-5 days!! They all said I wasn't the only one and they're working on it etc..... So here I am on the second night with a TiVo that will only record when I press the record button on what I'm watching. Of course I have no HBO because the M Card isn't paired either! Is anyone else going through or been through something similar? I've been with Tivo over 15 yrs but this is ridiculous!
     
    Last edited: Apr 2, 2015
  2. TomJHansen

    TomJHansen Member

    186
    0
    Nov 6, 2000
    Mesa, AZ, USA
    Have had Tivo since series 1...and this is my third Roamio. At least it's just for a bedroom - but I agree, it's frustrating. It had to update three times before it would even let me go to live TV. I have to tell you that if it was my first Roamio, I'd be upset like you.

    However....

    It's not my first Roamio (it's my third) and I can tell you that it's such a huge upgrade over the HD20 - so much faster in general. Be patient and know that they are working through us beta testers. I mean, who would have thought people would have actually bought a Tivo from anyone but Tivo, right?:)
     
  3. TomJHansen

    TomJHansen Member

    186
    0
    Nov 6, 2000
    Mesa, AZ, USA
    I was able to successfully process the "Activate my Tivo" from the website just now - it didn't work last night or this morning. So I would give it a try on their website.
     
  4. JJJB

    JJJB Member

    67
    0
    Nov 8, 2003
    Chicago
    My TiVo is activated on their website as I did it by phone 2 days ago they just haven't been able to send THAT signal to my Roamio. I just tried to force connect and it didn't work. I'll reboot it in a bit and I'll call in the morning. Thanks for letting me know that though.
     
  5. JJJB

    JJJB Member

    67
    0
    Nov 8, 2003
    Chicago

    Advertisements

    They did a great job finally getting it activated on Friday. Now the Comcast guy just spent 2 hrs trying to pair the cable card in person because I obviously got the wrong person over the phone and he couldn't do it. He even brought 2 with him? Now he drove back to get some more. The original one worked fine on my Series 3. So I'm back waiting. Now it's finally fixed and paired after the 4th tech support call the tech himself called in.
     
    Last edited: Apr 6, 2015
  6. Chris Gerhard

    Chris Gerhard Well-Known Member

    6,239
    60
    Apr 27, 2002
    AR
    Glad they got it fixed. There have been other stories about difficulties getting a TiVo activated but once activitated, I think everything is always fine.
     

Share This Page

spam firewall

Advertisements