Tivo box does not find HME service

Discussion in 'Developers Corner' started by zapatero, Jan 12, 2006.

  1. zapatero

    zapatero New Member

    3
    0
    Jan 12, 2006
    I have a netwokred tivo running within a home firewalled network (192.168.0.x) and it can never find an HME server running on another machine in the house.... I have verified that there is no network connectivity or routing issues (I can ping the tivo box from the machine running the HME server fine).

    I'm just running the Bananas sample application set.

    Also the Tivo box discovers other HME servers, and I can point it to public HME servers fine.

    However when I point the box directly to my machine running HME (192.168.0.50) the box comes back saying no services were running on that machine.

    Any help out there for this? How do I get the Tivo box to see my local HME service? I can run the simulator just fine against it.

    Here's how I start the servers:

    [zapatero@lonepine samples]$ export HME_HOME=../../HM_sdk_1.4
    [zapatero@lonepine samples]$ ./runsample.sh
    HME SDK 1.4 (TiVo, Inc.)
    LOG: added factory
    MDNS: h X X p : / / 192. 168. 0. 50 : 7288 / bananas /

    (I broke up that last URL log message to get it past the board's anti-url filter)
    - Zapatero
     
  2. josemonkey

    josemonkey New Member

    2
    0
    Jan 15, 2006
    I'm having a similar problem.

    I've installed Galleon 2.0.1 on my linux box. The linux box can see my TiVo. (i.e., can view the now playing list, etc.) However, I can't see the apps from TiVo.

    I tried running the simulator on another PC on the network, and I could see the Galleon apps running on the linux box fine.

    When I run the HME Quick Start on my WinXP box, TiVo can run the apps fine.

    Also, when I run Galleon on my WinXP box on the same network, TiVo *CAN* see the apps -- but they fail to run. (Seems to time out on the "Please Wait..." screen.)

    I am not running firewall software on the linux box. I am running firewall software on WinXP, but I believe I have opened all of the ports appopriately.

    My primary goal is to get this working on the linux box, btw; I'm only using the WinXP box for testing.
     
  3. josemonkey

    josemonkey New Member

    2
    0
    Jan 15, 2006
    FYI: I just discovered that a new version of galleon was released a few hours after I installed it.

    I installed 2.1.0, but same problem on linux.
     

Share This Page