This forum has gotten extremely slow in the last couple of months

Discussion in 'Forum Operations Center' started by timckelley, Dec 21, 2005.

  1. timckelley

    timckelley run of the mill TCFer

    31,665
    1,237
    Oct 15, 2002
    Brushy...

    Advertisements

    Has anybody else noticed this? All other websites are fine, but tivocommunity has gotten creepingly slow. (And I've tried on different computers and gotten the same result.)

    Evenings are usually okay, but during business hours, I often have to click 4 or 5 times to get a response, because of I only click once, it'll time out after awhile. But before a couple of months ago, TCF was fine.

    Is it possible that this site gets a lot more traffic than it used to, and hence the slowdown?
     
  2. David Bott

    David Bott Administrator Staff Member Administrator

    2,853
    246
    Jan 1, 1999
    More traffic? Sure has. Now has an Alexa rank below 6000. :)

    Site will always be more busy during the day for people surf more from work. Most of the stress on the site comes from just one forum actually. For all the one word, one line replies that are made that just adds to the overhead. From just the post being made itself to the searches that then also need to look through them. Oh well, all in good fun.

    I guess it is time again to archive off some of the old posts. But I may update the software to the new version first instead and see how that may go. Sorry for the slowdowns.
     
  3. timckelley

    timckelley run of the mill TCFer

    31,665
    1,237
    Oct 15, 2002
    Brushy...
    Well, I must say before a couple of months ago (and I've been here for years), it wasn't this slow. I infer from your comments that tivocommunity must have had a recently newfound popularity explosion. Or maybe the forum regulars are just posting more than they used to.
     
  4. dswallow

    dswallow Save the ModeratŠ¾r TCF Club

    54,520
    3,539
    Dec 3, 2000
    Long...
    David, I really don't think it's a slowdown. But over the last several months there have been time where there's moments of complete unresponsiveness... usually lasting 30 or 40 seconds or so. It's like the whole database is locked out from anybody using it even for reading; there've been times it happened that I quickly tried accessing from a different computer and it too didn't respond (different session). When it starts responding again, everything's as fast and responsive as usual.

    If it were a slowness due to an ever-growing load I'd expect to see delays spread out with things just taking a few seconds longer, et. al.
     
  5. YCantAngieRead

    YCantAngieRead Not Entirely Current

    39,836
    44
    Nov 5, 2003

    Advertisements

    Speaking of slow, something with Alexa is hanging when I try to reload Happy Hour. No big thing, just a weird little item to note. (Haven't had the issue with other areas of the forum, that is.)
     
  6. RegBarc

    RegBarc Well-Known Member

    16,426
    111
    Feb 18, 2003
    I've noticed it being a tad slower for me (although I have yet to experience any timeouts at all). But loads have been slower, and I kind of wrote that off to higher traffic and more and more posts.

    There's another version of the forum software out there? Or is it just some tweaks to the code in an update package? (Mind you guys, I am by far no expert in this BB stuff ;))
     
  7. David Bott

    David Bott Administrator Staff Member Administrator

    2,853
    246
    Jan 1, 1999
    Doug...

    Yes, that happens due tothe MySQL database locking tables udrin large search queries. Once the tables are locked, all the other requests are put into the queue until the locks are released and the other requests can be cleared. As the database grows larger, this can happen more and more based on what is being searched. That is what I am seeing on my end. I do not see the site being slower unless I see a lot of searches happening.

    Example...When I loaded this thread... Page generated in 0.24058 seconds with 16 queries

    But when we have a table lock issue...it can be long amounts of time. 20 to seconds or more based on what is happening. More people to the site, the more searches that happen.


    Tim...Yes, we have increased on traffic based on the holiday traffic and people researching TiVo. :) Starts about mid September or so.

    http://www.amazon.com/exec/obidos/t...lance&vi=traffic&url=http://tivocommunity.com


    James...Yes, new software ver 3.5. :)
     
  8. RegBarc

    RegBarc Well-Known Member

    16,426
    111
    Feb 18, 2003
    ::jumps up and down like it's Christmas early::

    I was a little scared when we went to the new software before, but once I got to using it, I like it a ton more. Can't wait to see this one in action!
     
  9. timckelley

    timckelley run of the mill TCFer

    31,665
    1,237
    Oct 15, 2002
    Brushy...
    I must say that after months of incredible slowness, this site lately has resumed its earlier quickness it used to have. It's much easier to use this site now.
     
  10. David Bott

    David Bott Administrator Staff Member Administrator

    2,853
    246
    Jan 1, 1999
    Hummm...All I did at this point is close some really large threads. ;)
     

Share This Page

spam firewall

Advertisements