The New Tivo Android App

Discussion in 'TiVo Premiere DVRs' started by rboutin2, Jan 6, 2012.

  1. DonaldBurns65144

    DonaldBurns65144 Member

    126
    1
    Jan 10, 2011
    USA
    Tivo app is now in the Amazon Fire marketplace.

    For those people having problems with the app not seeing their Tivo(s), see if you've gone to Tivo.com and turned on remote connections. Plus after installing the app you've got to enter the media access code(s) into the app before you can control your Tivo(s).
     
  2. rcobourn

    rcobourn Registered Snoozer

    1,019
    137
    Nov 10, 2004
    Phoenix, AZ
    My experience has been that even doing these things, the app sees the TiVos the first time it is run, and never again. I happened to do a complete reset on my phone, reinstalled the app, and was able to see the TiVos again for a bit, but now they are gone.
     
  3. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    My only complaint is it takes forever from startup time, to actually being connected to a TiVo. Please implement a default TiVo option. Also, I'm surprised they didn't allow the whole remote to fit on the Fire screen. Surely this could be possible.
     
  4. kturcotte

    kturcotte Active Member

    1,160
    0
    Dec 8, 2002
    Portland, ME
    For anybody having the same problem as me, with it not seeing the Premiere(s), try going into your router settings and turn off Wireless Isolation. Not sure why this was enabled, but as soon as I disabled it, the app found my Premiere.
     
  5. wdwms

    wdwms Member

    187
    7
    Jan 10, 2003
    Won't install to a Motorola Atrix 2, which is one of the newest phones out there (2-3 months old).. :(
     
  6. crxssi

    crxssi Veteran TiVo User

    2,795
    2
    Apr 5, 2010
    It is not the "Amazon Fire marketplace". It is the "Amazon Appstore for Android". The Amazon Appstore will run on all Android devices.

    But yes, the TiVo app is now on Amazon, and UNLIKE GOOGLE- it appears when I search for it on my Xoom. This means they might have placed corrected filters on Amazon? I went back into Google's Android Marketplace and the TiVo app still does not appear under a search on my Xoom.

    I had side-loaded the TiVo app already on my Xoom. It reports it is version 1.5.1.35(1a). But on Amazon, it is listed as version 1.5.35.1. Strange...
     
  7. crxssi

    crxssi Veteran TiVo User

    2,795
    2
    Apr 5, 2010
    That is essentially what I said in a previous posting. A setting such as that will create a separate, NAT'ed network just for that wireless device. So it will not be possible for each wireless device to see each other, or at least not see other wired devices.
     
  8. ghuido

    ghuido New Member

    311
    0
    May 8, 2007
    I installed it succesfully on the Galaxy Nexus ICS. The app opened up and showed the 4 Tivo's on my network.

    When I try to access one of the TIVO's it says it cannot connect.

    Anyone had this issue?
     
  9. DeWitt

    DeWitt Member

    424
    0
    Jun 30, 2004
    Saratoga...
    I am running it on my Galaxy Nexus without issues.
     
  10. Rob Helmerichs

    Rob Helmerichs I am Groot! TCF Club

    53,696
    10,552
    Oct 17, 2000
    Minneapolis
    OK, this is filling me with rage and hatred (well, really mild annoyance, but we live in an age of hyperbole and I'm making an effort to fit in better). I open the app, and I get a feature comparison between the S3 and the Premiere, with a Continue button. I hit Continue, and get a Connect to your Series3/TiVoHD screen with a login dialog. I put in my email and TiVo.com password, it says "Connecting to "DVR 7DB5" on the local network for a moment, then says "Could not sign in to TiVo.com. Either the email or password you entered was invalid." But it's the same email and password that I use (successfully) to sign in on the actual web site, including from the phone's browser.

    Can anybody help quell the mild annoyance rage and hatred that is filling my heart?
     
  11. crxssi

    crxssi Veteran TiVo User

    2,795
    2
    Apr 5, 2010
    You should not need your tivo.com account information to connect to a local Premiere. Just your MAK.
     
  12. Rob Helmerichs

    Rob Helmerichs I am Groot! TCF Club

    53,696
    10,552
    Oct 17, 2000
    Minneapolis
    It's not a Premiere, it's a Series 3. And the app asks for the TiVo.com info, and without it I can't get any further. (Of course, WITH it I can't get any further either, which is the problem...)
     
  13. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    That is only for Premiere's. I'm not sure why but a login is required for S3 Tivos.
     
  14. wmcbrine

    wmcbrine Well-Known Mumbler

    11,700
    812
    Aug 2, 2003
    It kept telling me the MAK was wrong. It wasn't. :p I couldn't get past that. (Maybe if I rebooted the TiVo?)
     
  15. nhaigh

    nhaigh Member

    984
    0
    Jul 16, 2001
    Lawrencevill...
    The problem I have is it sometimes sees TiVo's and sometimes it doesn't. Sometimes it sees two or three of the four. It's totally inconsistent and very frustrating.
     
  16. rcobourn

    rcobourn Registered Snoozer

    1,019
    137
    Nov 10, 2004
    Phoenix, AZ
    Did you verify that the network remote feature is enabled for your S3? Something like Settings / Remote, Cablecard, and Devices / Network Remote Control?

    If you haven't already, reboot your TiVo and your router.
     
  17. yunlin12

    yunlin12 Tivonation Citizen

    1,223
    0
    Mar 14, 2003
    San Jose, CA
    Interesting!

    I have a Galaxy Tab (7"), a Galaxy Nexus, and a Nexus 1. Only the Galaxy Tab can see the 2 Tivo Premiere's from the Tivo app, the Galaxy Nexus and the Nexus can not find the Tivos. Using the Bonjour Browser app on the 3 devices, I also confirmed that in _tivo-videos._tcp. under local. domain, I can only see the two Tivo's from the Galaxy Tab, but not from the Galaxy Nexus or the Nexus 1. All 3 android devices are connected to the same wifi network, really strange :confused:
     
  18. crxssi

    crxssi Veteran TiVo User

    2,795
    2
    Apr 5, 2010
    1) It still does not appear in a search in Play Store on my Xoom at all. Where are you seeing the word "tablet" from TiVo?

    2) I side loaded the previous versions of the .apk on my Xoom tablet and it has always worked fine except the remote control is incorrectly drawn.

    3) If I manually load the .apk there is now a NEW warning, just added in this update, that says "The version of the TiVo apps for Android has been designed for phone with less than 1024x600 screen resolution. Exit or Continue Anyway?" What real tablet has a resolution that low? And that doesn't jive with what you just said in your posting. FYI- the Xoom has a resolution of 1280x800. On my phone, I read the description in Play Store and you are right that it says "1280x800" but then why is it warning for > 1024x600?

    4) I see no new features. What new features do you think it has?

    5) It does seem to connect a bit more quickly than before.
     
  19. yunlin12

    yunlin12 Tivonation Citizen

    1,223
    0
    Mar 14, 2003
    San Jose, CA
    After my Galaxy Nexus upgraded to 4.0.3 in ~March, it was able to see and connect to both of my Tivo Premieres. So I guess something in the Bonjour handling got fixed.
     
  20. crxssi

    crxssi Veteran TiVo User

    2,795
    2
    Apr 5, 2010
    Arantius has placed a new version of DVR Commander for TiVo on the Play Store: https://play.google.com/store/apps/details?id=com.arantius.tivocommander

    You are in for a treat! He has added TONS of new features. For phone use, this independently developed and free app just blows away the official TiVo app. It has nearly all the same features but with added capability, is faster, and has no "scanning" crap when it is started. For tablet use compared to the official TiVo app, it is MUCH MUCH faster, has nearly all the same features, some added capability, and no scanning on startup, but doesn't use all the real estate as well.

    If you have not tried it, you really should. Thanks, Arantius!!
     

Share This Page