The End is Nigh for HME

Discussion in 'Developers Corner' started by davidblackledge, Dec 9, 2015.

  1. Dec 9, 2015 #1 of 24
    davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    As of today, my Roamio and Mini have the update so they have Quick Mode... and external apps I already added now result in a C501 error.

    I also had an email this morning from a user whose parents are sorely missing WordSmythe on their Roamio.

    Restart didn't fix it.

    The Bolt can't add apps without an error since its release. It looks like bringing Bolt features to the Roamio and Mini has broken them, too. I presume they'll do this to the Premiere, too (currently my premiere still works fine with apps). Then I'm sunk.

    I'll be complaining to TiVo, and I recommend everybody else complain, too.
    The "Add an App" feature is present but has been broken and needs to be fixed.

    They will either have to fix the feature they present to us, or remove it to admit their intent.

    Just to make things worse, I have no way of even removing the apps so I can use TiVo's content in "Apps & Games" or "Music & Photos." When I get the error it sends me directly back to TiVo Central.
     
  2. Dec 9, 2015 #2 of 24
    wmcbrine

    wmcbrine Well-Known Mumbler

    11,624
    774
    Aug 2, 2003
    Can you elaborate on this part? It sounds like you're saying the other entries in these menus don't work, either? What about pressing "Clear" on the affected apps?
     
  3. Dec 9, 2015 #3 of 24
    davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    I take my Roamio or Mini to "Music & Photos" or "Apps & Games"
    It displays the built-in apps, then I watch the spinny thing...
    Rather than getting a list of apps that I could click "clear" on or even the "Add an app" entry, I get "There was an Unexpected Error (C501)" in front of everything.
    When I click "OK" it takes me back to the top menu entry as if I'd pressed the "TiVo" button.

    Incidentally, I can still activate one of the TiVo built-in apps quickly, or I can pause on the page, move to another TiVo Central menu item, and the spinny thing shows up anyhow and eventually the C501 error.

    And worth noting, my user isn't reporting the C501... they said they've even tried re-adding my IP address and can't get my apps anymore, but I know they're up, and work fine on my Premiere.

    Oh...part of my reasoning was I checked my logs this morning and saw no "84x" numbers since yesterday, but I saw other models... but I just checked again and I have had 3 "84x" impressions since then. I don't know what to make of it at this point. Or maybe they just didn't get the update yet.
     
  4. wmcbrine

    wmcbrine Well-Known Mumbler

    11,624
    774
    Aug 2, 2003
    I see now that my Roamio's doing it too. :(

    Well, there goes my remediation strategy. To get around the 503 errors with "Add an App" on the Bolt, I was planning to make an "HME relay" thingie that would take an address, and send out zeroconf announcements for the apps it found to the LAN (since that still worked). But that won't help with this new bug (no local apps, either).

    I have a hard time believing this is intentional, because why not just remove HME cleanly if that's what they wanted to do? But if not, they certainly are being careless. I don't know why they'd even be working in that area of the code (but then, I haven't actually seen their code).
     
    Last edited: Dec 10, 2015
  5. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    Good, I'm not crazy at least. Any idea what SW version numbers are for Roamio and Mini on this update? I can double-check my logs to see if any managed to slip through and connect.
    Recent Roamio: 20.5.2b.RC1-USA-6 and 20.4.7a-USA-6
    and a day or so older an instance each of: 20.4.7a-USA-6-848-INIT and 20.4.7a-USA-6-848
    and recent A92: 20.4.7a-01-6-A92
    and for fun, recent A90: 20.5.2a-01-2

    Is it possible you're just stuck because you have some remaining IP address connections you can't get rid of? if you could get rid of them, maybe local apps would work?

    Yeah, I agree, but I also have a hard time believing they'll spend any time on fixing it. I think they'll give owners some instructions to clear their added IP addresses, and walk away.

    Still, I insist they need to at least explicitly remove the "Add an App" button and stop claiming that feature exists if they're going to lave it broken.
     
  6. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    and the last time I saw an A93 ( 20.4.7a-01-6 ) was 12/3, although a week gap on those has happened before.
     
  7. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    One last set of data points:
    I usually get 15-30 TiVoConnect requests from Roamios each day, I got 2 yesterday.
    I get 5-10 active Roamio users a day, I had 0.

    Numbers for Minis are within normal range, but normal range is 0-5.
     
  8. HerronScott

    HerronScott Well-Known Member

    7,314
    1,045
    Jan 1, 2002
    Staunton, VA
    Did we get an e-mail address for Ira Bahr since he indicated that TiVo should support the development community. Or at least see if you can follow-up with Margret.

    "I believe the industry has proven that when you can develop a healthy and vibrant developer community, both parties profit and the end user benefits. TiVo will need to grow its size and influence before community development can really take off, but at a minimum we should support our long-term supporters like PyTivo and KMTTG."

    Scott
     
  9. wmcbrine

    wmcbrine Well-Known Mumbler

    11,624
    774
    Aug 2, 2003
    Yeah, it's a strong possibility. Local apps are still working on the Bolt (where of course I was never able to Add an App). Both the Roamio and Bolt say they're running the same software version now -- 20.5.6.RC14 -- although it looks different on each, in terms of menu layout and colors.
     
  10. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    They're still meeting that minimum with this setback, unfortunately.

    I mean...I think of myself as a long-term supporter, but there might be a reason they didn't mention HME.

    Years of hobby work is about to go down the tubes...then I have to join the throngs of mobile app developers. I prefer being part of a niche.

    Maybe I could get into Opera TV Store stuff, but that looks pretty "throngs"-y, too.
     
  11. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    aaaaand we're done. This morning my Premiere had the update (logos and HD shortcut) which started me getting C501 errors there, too.

    Yesterday, EnterWebz.tv rolled over to 1000 subscribed DVRs. 367 Roamios, 313 Premieres, and presumably 135 Minis can't or soon won't be able to use it. I suspect most of the 107 Pace models will be in this same boat, too.

    That likely leaves me 61 Series3 and perhaps 16 "other" users.

    I'll probably leave it running for the foreseeable future, but there is no point in updating anything when I can't even test it myself (technically I have a Series 3, but it's not hooked up right now). As long as I can afford it and maybe use it for other projects, I guess it's safe.

    I wonder if anybody complained to TiVo yet? I didn't get a chance to yet... life and all.

    If everybody that reads this complains, they might actually listen, even if it's just to remove the feature.
     
  12. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    Daily unique impressions by model starting October 1st.
    [​IMG]
    Series 3 on the bottom, then Premiere, Roamio, (Bolt=0), Mini, Pace, and other (usually 0, too) on the top
     
  13. HerronScott

    HerronScott Well-Known Member

    7,314
    1,045
    Jan 1, 2002
    Staunton, VA
    You should send this information and your chart to Margret in an e-mail.

    Scott
     
  14. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    Good thought. Done.

    However, I sent her a note April 3rd (when they removed the YouTube HME app) to see if I should just stop developing in HME. I never heard back, so I don't expect anything more this time than the email getting deleted.
     
  15. HerronScott

    HerronScott Well-Known Member

    7,314
    1,045
    Jan 1, 2002
    Staunton, VA
    Hopefully you'll get a response this time. The one time that I sent her a mail regarding an issue on a Saturday, I did get a reply from her.

    Scott
     
  16. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    oh good, I did get a reply... "Thanks, I'll pass this along."
    Good enough for now.
     
  17. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,285
    5,776
    Apr 17, 2000
    Nevada
    If they're going to remove it then they just need to remove it. As it is now it's just broken. Looks like it should work, but doesn't. And it causes units that previously had 3rd party HME apps loaded to get an error just accessing the menu, which prevents them from using some of the official apps. Whatever their ultimate goal they need to fix these bugs.
     
  18. reneg

    reneg Well-Known Member

    1,109
    207
    Jun 19, 2002
    I believe it's broken and not intentionally being broken. I don't know whether it will be fixed or not. I think you should continue to let Webz run and may get an early indication if it's fixed if you see an increase in connects.
     
  19. HerronScott

    HerronScott Well-Known Member

    7,314
    1,045
    Jan 1, 2002
    Staunton, VA
    Did you ever hear back or did your errors go away?

    Scott
     
  20. davidblackledge

    davidblackledge Registered lÜser

    559
    35
    Sep 9, 2008
    NM
    Nothing more, no.

    You'll know when the errors go away about the same time as I know by looking at the graph above. It updates every day. If the Premiere and especially Roamio (and dare I say Bolt?) numbers start going up, they fixed it.

    I'm sure it will require an update, though.
     

Share This Page