TCP Port 37?

Discussion in 'TiVo Roamio DVRs' started by davetroup, Feb 22, 2017.

  1. longslim_52

    longslim_52 New Member

    Oct 31, 2014
    I'm having the seem issue, Tivo SR had me reboot twice no joy. I have had the box three years with no issue before like this. I wonder is it hardware based, because I get internet and phone bundle and they work fine. Plus I can watch youtube or Netflix but can't connect to TIVO central.
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    Dec 7, 2012
    Ashland, PA...
    Your service connection failure is not related to the port 37 failure.

    See -> Connection Failing 12/23/17
  3. scandia101

    scandia101 Just the facts ma'am

    Oct 20, 2007
    MN, greater...
    The TCP port 37 not open error is a big giant non issue that affects absolutely nothing.
    TVGIRLEAST likes this.
  4. kdmorse

    kdmorse Well-Known Member

    Jan 29, 2001
    Germantown, MD
    Actually, it's not 100% unrelated, although it's not the cause of any problems.

    Tivo services get fronted through two servers let us call them H1, and H2. But first, a server, SLS, sends you to one or the other.

    Between Friday and Tuesday, H2 was kinda sick. If you got directed to H2, you could not make a daily call. If you got directed to H1, you could. If you were being sent to H2, failing, but tricked it into connecting to H1, you could come back to life.

    Port 37 was in no way involved in the above outage.

    But..... Port 37 failures *also* are dependent on which server you are balanced to. H1 is fine, port 37 is open and answers. H2, nope, port 37 isn't open.

    The same people who have had persistent Port 37 failures overt the last few months (because they're balanced to H2), would be the same people that couldn't call in for four days.

    So, there is a relationship. It just caused the illusion that port 37 was involved, because the errors happened together to some people, or not at all for others.
    sakaike, tim1724 and ClearToLand like this.
  5. JoeKustra

    JoeKustra in the other Alabama TCF Club

    Dec 7, 2012
    Ashland, PA...
    Ok, I stand corrected. I had that error on a Premiere, two Roamio and three Mini boxes from April until November 1. During that time my TiVo boxes had nothing that other users didn't have. With the latest service issue, I also had a few failures near the end. A second or third connection would succeed. Your explanation was great insight to the problem. It also made sense on the "make two connections" CS script. I have trapped all web sites on my router in the past but never saw those you documented. I've scrolled through the System Logs and all that shows up a lot is BILLBOARD errors. Maybe because they're all caps? I guess since things are running again we can go back to complaining about guide quality. Thanks for your help.

    Now, how about a reference manual for those logs? :D
  6. sfhub

    sfhub Well-Known Member

    Jan 6, 2007
    Is it that Port 37 isn't open or that port 37 is open but after a connection is established nobody is responding? I've found in the past the TiVo deals with the first type of problem more gracefully than the second type of problem. For the second type of problem TiVo often gives confusing messages that lead you on a wild goose chase, like thinking your firewall is blocking something.
  7. William Gafford

    William Gafford New Member

    Feb 2, 2018
    I'm having the issue now - the mini was working OK for a few weeks, not getting the error on my DVR and mini that port 37 must be open. I tried port forwarding to 37 with no success in eliminating the message.
  8. JoeKustra

    JoeKustra in the other Alabama TCF Club

    Dec 7, 2012
    Ashland, PA...
    Are you having any other problems? Post 24 gives a good explanation of the error.
  9. Dan Vogt

    Dan Vogt New Member

    Feb 4, 2018
    I had this error. "Open port 37 or 123" is BS. Your router has the wrong time and date. Log into your router and make sure the time and date is accurate. It won't be. Use the "Get GMT" button and it will set it correctly. Once set correctly, reboot the router and make sure you get the right time and date back post reboot. Then, reset your TiVO. That's it. I struggled with this until I read TCP port 123 was time related. Bingo. Your TiVO should now be able to update successfully.
  10. JEJ

    JEJ New Member

    Jan 23, 2005
    Santa Clara, CA
    I just now found this thread because my Bolt is displaying that it cannot connect to the TiVo Service. When I run the diagnostic check, that completes with out error.

    I checked my firewall after seeing the TCP/37 message on the Bolt. The firewall is allowing these connections as it always has, but the session is being terminated by a TCP/RST sent back from the server.

    @kdmorse - I like your explanation. It makes sense.

    The firewall logs show that all TCP/37 connections are being terminated by the server immediately.
    These connections are to (which I am resolving to

    Other connections to are working, but there are also incomplete TCP handshakes for TCP ports 80, 8080 and 5337

    I have a Premium XL2 and XL4 that do not have these issues. I've rebooted the Bolt and I have checked the clock on my firewall, which always has been fine.

    The problem, for me, is unique to the Bolt
  11. JoeKustra

    JoeKustra in the other Alabama TCF Club

    Dec 7, 2012
    Ashland, PA...
    That is truly unique. Have you tried a wireless connection? Just guessing since you seem to have done everything right. Ports 80, 8080 and 537 are really needed.
  12. just4tivo

    just4tivo Active Member

    Dec 9, 2015
    While we weren't watching this TCP port error seems to have been resolved and the TCP port test now results SUCCEEDED... at least on my two Roamio OTA boxes.
  13. Dago Red

    Dago Red Active Member TCF Club

    Oct 22, 2002
    Parsippany, NJ
    I noticed the same thing a couple of days ago. They must have finally opened up the port on both servers.

Share This Page