TCD230040 issue

Discussion in 'TiVo Help Center' started by gougi1, Oct 15, 2011.

  1. gougi1

    gougi1 New Member

    Oct 12, 2011
    Piedmont Ca


    After initial setup and running it for a week, it became evident that the Tivo was no longer aquiring program data. I tried a number of troubleshooting techniques, including switching from the network adapter to the telephone.

    The unit negotiates a connection to Tivo and appears to download data, but no program data is added to its database.

    I had already dealt with Tivo support regarding software versioning as the unit was off a small revision (v.9.3-01-2-140) from my other series 2 (9.3.2b-01-2-540). I found it strange that it wouldn't update itself, but the functionality I require seemed there so, while annoying, did not seem to be of great consequence.

    After breaking down and contacting them again today, the tech reviewed the connection logs and found that the unit had done a successful data acquisition upon first connection (just after I did a factory reset). Since that first connection, the unit recognized that it requires a software upgrade. Upon each subsequent update, it attempts downloading the software but for some reason is unable to update itself, disconnects before updating the database, leaving the box essentially functionless without updated program data.

    This is where Tivo stops supporting the unit. There is no way for them to troubleshoot the software upgrade SNAFU with just looking at the connection logs. They would require having it sent to them (cost prohibitive).

    (i tried phone also, no go).
    Again, because it is trying to grab the latest software update but is unable to apply it, no additional program data is able to be loaded after the initial setup, essentially rendering it useless.

    It would seem tivo's lifetime service gives unlimited program data, not lifetime warranty unfortunately.

    Anyone have any ideas? I do not have a backup disk image to retore this lifetime unit from so I'm pretty stuck at this point
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    Apr 6, 2000
    SF Bay Area
    Did you try to reboot the tivo?
  3. scandia101

    scandia101 Just the facts ma'am

    Oct 20, 2007
    MN, greater...
  4. lillevig

    lillevig Cold in East Iowa

    Dec 6, 2010
    Marion, Iowa
    Does your other unit happen to be a model TCD540? I've been told by a reliable source here that the last three digits refer to the SW version of the model number. That being said, I have a TCD240 that also ends in 140 but my TCD649 (S2DT) ends in 649. Based on that, I suspect that you don't need a SW update, just Program Data. Maybe a "Clear and Delete Everything" is in order followed by a restart.
  5. unitron

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC


    The last three digits are model specific, except that the -140 is good for the various 140s and 240s, and apparently the 130 and 230 AT&T versions of them.

    If the software on your 230 ended with -540, it might not work well enough to even be able to get to the screen where you could see that it ended in -540. That version is just for the TCD540xxx.

    I have a TCD24008A

    It says it has 9.3.2b-01-2-140

    If you want to try it out, and if you have an 80GB or larger drive, with an LBA number of at least 160086528 (which is larger than the later 80GB drives which are only LBA 156301488), maybe the images I put on line are still there at the links given in this post.

    If they are, please download both to help keep them both alive a little longer (it's like believing in TinkerBell, sort of).

    One will work with WinMFS and the other with the MFS Live cd v1.4, both of which are available at

    Do not use or overwrite the original drive. Put it on the shelf. I may want you to make an image from it for me after we solve your problem.

    If those links are dead, let me know, and I'll start the slow process of uploading them again.

    edit to add:

    It also occurs to me that you may need to switch to the alternate boot partitions (where software updates get stored), and for some reason the TiVo isn't doing it automagically like it's supposed to, which is more of a hard drive problem than a motherboard problem.
  6. classicsat

    classicsat Astute User

    Feb 18, 2004
    Ontario Canada.
    AFAIK, you don't need 9.32b unless you have OTA, or some other odd configutation.

    If it wants to update but is not taking, it could be due to a failing HDD.
  7. lillevig

    lillevig Cold in East Iowa

    Dec 6, 2010
    Marion, Iowa
    I will PM you a link to an image I captured from the 40GB verison of the TCD240 just in case Unitron's link doesn't work for you. It is a WINMFS image.
  8. gougi1

    gougi1 New Member

    Oct 12, 2011
    Piedmont Ca
    Many thanks to the kind individuals above ( and anonymous ones too) who took the time/effort to assist me out of my predicament. I am confident that I will be back on the road within a matter of hours!
  9. robomeister

    robomeister DVD TiVo Expert

    Feb 4, 2005
    Beltsville, MD
    It looks like you have the wrong software image for your TiVo loaded on the hard drive. If it is really a TCD230 model, then you need the TCD230 software image. The TCD240 image may appear to work, but as you have seen, when it tries to update, it gets into a failure loop that it cannot recover from. I had this same problem with a Humax DRT800 hardware running the Toshiba RS-TX20 software. The hardware of both the Humax and the Toshiba is essentially the same, except for the ROM in the unit that designates the make and model. It worked fine, but when it attempted to update to a newer version of the software, it got stuck in a failure loop and never upgraded to the newer software version. I eventually had to manually install the correct software image on the drive and it worked again.

    So to fix your TiVo, you need an software image that is specific to the TCD230 TiVo model. The software will work in either the TCD130 or TCD230. The TCD230 is simply the same hardware in a different case. The internals of the case of the 130 looks like a Series 1, the way the hard drive is mounted, where the power supply is, etc. If you look in the System Information page on the TiVo, the last three digits of the software version should be 130, not 140.

    I can provide you with a software image for the TCD230. Send me a PM and we can make your TiVo run like new again. :)

  10. gougi1

    gougi1 New Member

    Oct 12, 2011
    Piedmont Ca
    Finally got up and running ( lateness due to my error-lack of a decent hard drive)
    However I just wanted to thank the community for the amazing response to my quandary-deluged by good advice ( and other goodies ) both here and via PM. Back on track & running great now!
  11. wfg97079

    wfg97079 New Member

    Aug 13, 2003
    Anyone know when I could find an image for a tcd230040?

Share This Page

spam firewall