Supersize not working S3 288 vs 317 HD Hours

Discussion in 'TiVo Help Center' started by ravingfans, Sep 28, 2011.

  1. ravingfans

    ravingfans Member

    59
    3
    Jan 11, 2009
    Hi, my S3 TiVo (original S3, not the HD, or XL, etc.) with a 1TB internal and external 1TB eSATA drive could not get program data (the ugly hideous S03 error), so I installed a new 2TB hard drive to troubleshoot. Eventually I discovered that increasing the swap space to 2000 fixes that problem. Apparently the guide data was getting too huge and the TiVo had no place to put it...

    I spent a week filling the hard drive with HD material to test the Hard Drive and discovered with TivoPlayList that there is only 288 (sometimes 289) HD hours recorded when the disk is full, not 317. This is obviously the difference from SuperSize which I turned on with WinMFS. Is there a way to tell if SuperSize is enabled or is there a sequence of when it needs to be enabled to get SuperSize working correctly? Checking the drive again with WinMFS reports "Supersize is already enabled" message.

    Thanks for any help!
     
  2. rayik

    rayik New Member

    90
    1
    Feb 4, 2006
    If you take a 2TB drive and use the common image backups, it will copy the contents of the original 250GB drive onto the 2 TB drive. That includes the partition table on the new replacement drive. The partition table will be exactly what the old drive was. If it was a 250GB drive, the partition table sets up partitions for using only 250GB of the drive.

    WinMFS expansion adds a partition to the partition table. The way the oringinal TIVO's partition table is structured, only one new partition can be added to it. The S3 will recognize a partition up to 1 TB in size. Thus using WinMFS to expand the replacement drive, one can only add a 1 TB partition. Thus, the maximum useable size of the 2TB drive is 1.25TB. (The original partitioning of 250GB plus the new partition of 1GB.)

    So Supersize with WinMFS is working. Just not in a way that was expected.

    If one uses a program to modify the partition table, you can expand existing data partitions so that the entire 2TB of the drive is useable. (Each expanded data partition can be no larger than 1 TB.) I assume that is what dvr_dude and weaKnees do so that a single 2TB drive is fully useable (entire 2TB).

    I've never really tried to search, but I do not believe anyone who has purchased such a drive has backed it up and posted it on line. Any such backup would have the custom created partition table. If that backup was restored to a new 2TB drive, the full 2 TB of that replacement drive would be useable.
     
  3. ravingfans

    ravingfans Member

    59
    3
    Jan 11, 2009
    Thanks Rayik, that is the most clear explanation I've seen on the drive limitations!

    Do you think it is possible to repartition the disk from the linux command line, backup with WinMFS, and Restore using WinMFS to achieve the same goal that a program would require? It seems the challenge would be to expand the MFS partitions.
     
  4. rayik

    rayik New Member

    90
    1
    Feb 4, 2006
    Absolutely. I just do not have a spare 2TB drive or I would already have done it.

    Note that TIVO uses Apple Partition Map for it's disk partitioning. It looks like partitions 11 and 13 are used as storage space for recordings.

    I was just googling and a freeware partitioning program Parted Magic looks interesting. (It's on a boot CD so you can use this in a system with only the drive you want to modify.) I'm tempted to pick up a 2TB drive and give it a try.
     
  5. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I'd like to see someone figure this out. Not because I want to see DVR Dude or Weaknees lose sales, but for the knowledge and the benefit that it would add to TCF.
     
  6. ravingfans

    ravingfans Member

    59
    3
    Jan 11, 2009
    Thanks for the good ideas--Since my 2TB drive is partitioned incorrectly, I'll be the guinea pig. Could you suggest a partition map and any other helpful hints I might need and I'll report back results for all to benefit from? I'm pretty solid with Unix and linux skills, but some of the finer points of TiVo's implementation and the various hacks still seem cryptic to me.
     
  7. GBL

    GBL covert opiniative

    2,000
    102
    Apr 20, 2000
    Twin Cities, MN
    Here's a partition map of a 2TB drive:
     
  8. ravingfans

    ravingfans Member

    59
    3
    Jan 11, 2009
    I’m able to build the 2TB disk, and the TiVo is able to reboot reliably, but something is causing a couple of problems:
    1. Reboots, seem to be during TiVo Service Connections
    2. Can’t record on both tuners at the same time – recording on one cancels the recording on the other tuner and the “Now Playing” list has no recollection of the program missing

    Any ideas on why? Is there something I need to do besides Kickstart 57 to spur the S3 to recognize the full space? In the System Information screen 317 hours are reported, and don’t see any other issues. 11.0k is the Software version.

    Here are the steps I took:

    1) First, use WinMFS to restore from the original drive (the original that shipped with the TiVo because WinMFS has trouble at least for me restoring/expanding from an already upgraded disk). Then restore to the 2TB single drive.
    a. Through experimentation, have to tell WinMFS to expand to the full available space, because if you tell WinMFS to limit the last (expanded) partition to 1TB, then pdisk is not able to create any new partitions beyond partition 15.

    2) Installed a new kernel, telnet, etc. using well-known methods
    3) Booted TiVo
    4) Went through Guided Setup
    5) Allowed TiVo to upgrade to 11.0k
    a. 9.2 only recognizes 292 HD Hours, 11.0k recognizes 317
    6) Connected to TiVo servers 3 or 4 times

    7) At this point I manually set up partitions 15 and 16 using pdisk:
    Please remember:
    a. don't type my c-style comments (everything between the /* and the */)
    b. Only type the Bold
    c. must immortalize me in the name of the partition ;-)

    Boot from Mfslive cd

    /* launch pdisk in interactive mode */
    pdisk –i
    /* edit the disk */
    Top level command (? For help): e
    /* next parameter is the drive you are modifying—be sure you are operating on the correct disk! */
    Name of device: /dev/sda
    /* print partition table */
    command (? For help): p
    /* be sure to jot down the partition number, number of blocks, name, etc. of the partition to modify */
    command (? For help): d 15
    /* create a new partition */
    command (? For help): C
    /* starting at placeholder of part 15 */
    First Block: 15p
    /*
    * Next enter the number of blocks, here are calculations:
    * WinMFS limits to “1024G”. What WinMFS means by that is 2,147,471,360 blocks of 512 bytes or 1099,505,336,320 bytes
    * the ebay approach used 2,147,450,880 blocks or 1,099,494,850,560 bytes
    * I’ve tried with
    * p15: 2,147,471,360 blocks and p16: 1,267,322,879 as well as
    * p15: 2,147,450,880 and p16: 1,267,343,360 (and also 1,267,343,359)
    */

    Length in blocks: 2147471360
    /* name of partition */
    Name of partition: “MFS Media by RavingFans 1”
    /* type of partition */
    Type of partition: MFS
    /* here pdisk complains that Linux might have trouble with more than 15 partitions */
    Pdisk: Map contains more than 15 blocks – Linux may have trouble

    /* create a new partition */
    command (? For help): C
    /* starting at placeholder of part 16 */
    First Block: 16p

    /* for this next parameter, have to calculate the number of blocks for partition 16. According to one
    * thread I read, this should be one less than the total available otherwise pdisk has a conniption. I’ve
    * tried this both ways, and didn’t see a difference. Since I’m building mine with a 2GB swap, I come up
    * with 1,267,322,879 for my first pass. See discussion under p15 above for other values I used…
    */

    /* number of blocks */
    Length in blocks: 1267322879
    /* name of partition */
    Name of partition: “MFS Media by RavingFans 2”
    /* type of partition */
    Type of partition: MFS
    /* here pdisk complains that Linux might have trouble with more than 15 partitions */
    Pdisk: Map contains more than 15 blocks – Linux may have trouble
    /* write partition table changes */
    command (? For help): w
    /* have to confirm the write, don’t recall what the prompt was */
    /* also got the warning about the number of partitions exceeding 15 */
    /* in my case pdisk had a hard time re-reading the partition table when writing, but when I did the p command, it listed out correctly */

    /* quit editing /dev/sda */
    command (? For help): q
    /* quit pdisk */
    Top level command (? For help): q

    8) Boot TiVo and do Kickstart 57
    9) test
     

Share This Page