Suddenly after windows update, pytivo not recognizing my tivo bolts

Discussion in 'TiVo Help Center' started by mtepper27, Jan 28, 2020.

  1. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    The only thing that changed was the windows update. I don't have any system restore points to use. And I tried uninstalling and reinstalling PYTIVO from my computer. Nothing seems to work.

    On a separate note, when I uninstall pytivo and go to reinstall it, it automatically has all the same settings as pre-uninstall. Like media access key, program stream selected, etc. Is there any way to completely remove pytivo and all its settings so maybe a clean reinstall will make it work?

    Edit: I've also restarted both Bolts and connected to the network with each.
     
    Last edited: Jan 28, 2020
  2. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,946
    6,017
    Apr 17, 2000
    Nevada
    Some Windows updates will reset the encryption used to store the MAK. Go into the settings, change the MAK to something bogus, and hit OK. Then go back and change it to the right value. That should get it working again.

    edit: if that doesn't work it could be a firewall thing.try disabling the firewall temporarily and see if that helps. If it does you may need to poke so e holes in the firewall to get it working again.
     
  3. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    Thank you for answering so quickly. I tried both. Neither worked. I shut off my firewalls, changed the MAK and saved, then put the correct MAK and saved and restarted the program.

    The only option I can think of is a clean reinstall of Windows, but I'm hesitant to do that.
     
  4. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,946
    6,017
    Apr 17, 2000
    Nevada
    That shouldn't be necessary.

    Can you post your log? It's in the About section under the gear icon.
     
  5. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    Code:
    INFO:pyTivo:Last modified: Wed Jan  8 14:46:58 2020
    INFO:pyTivo:python: 2.7.16
    INFO:pyTivo:System: Windows-10-10.0.18362-SP0
    INFO:comtypes.client._code_cache:Imported existing <module 'comtypes.gen' from 'C:\Users\mitep\AppData\Local\Temp\_MEI168202\comtypes\gen\__init__.pyc'>
    INFO:comtypes.client._code_cache:Using writeable comtypes cache directory: 'c:\users\mitep\appdata\local\temp\comtypes_cache\pyTivo-27'
    INFO:pyTivo.beacon:Scanning for TiVos...
    WARNING:pyTivo.beacon:No TiVos found!
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Z:
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=QueryServer HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetOSName&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetLogText&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:12] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:root:5.1.1.719 - Dec 17 2014
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:15] "GET /TiVoConnect?Command=GetVersion&Container=VRD HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:19] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:19] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:19] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:23] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:23] "GET /TiVoConnect?Command=Restart&Container=Settings HTTP/1.1" 200 -
    6529172037INFO:pyTivo.beacon:Unregistering: Z:
    INFO:pyTivo:Last modified: Wed Jan  8 14:46:58 2020
    INFO:pyTivo:python: 2.7.16
    INFO:pyTivo:System: Windows-10-10.0.18362-SP0
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo:192.168.0.106 [28/Jan/2020 15:04:34] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=8496A0190517809 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.101 [28/Jan/2020 15:04:34] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=84960119037E1D4 HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:38] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:04:38] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    WARNING:pyTivo.beacon:No TiVos found!
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Z:
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:'port'
    INFO:pyTivo:192.168.0.101 [28/Jan/2020 15:05:00] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=84960119037E1D4 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.106 [28/Jan/2020 15:05:00] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=8496A0190517809 HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:05:00] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:05:00] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:22:04] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:22:04] "GET /TiVoConnect?Command=Restart&Container=Settings HTTP/1.1" 200 -
    6529172037INFO:pyTivo.beacon:Unregistering: Z:
    INFO:pyTivo:Last modified: Wed Jan  8 14:46:58 2020
    INFO:pyTivo:python: 2.7.16
    INFO:pyTivo:System: Windows-10-10.0.18362-SP0
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:22:19] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:22:19] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:22:19] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    WARNING:pyTivo.beacon:No TiVos found!
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Z:
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:192.168.0.106 [28/Jan/2020 15:23:03] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=8496A0190517809 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.101 [28/Jan/2020 15:23:03] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=84960119037E1D4 HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:25:40] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:25:40] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:25:53] "GET /TiVoConnect?Command=GetLogText&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:27:44] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:27:44] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:27:56] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:27:56] "GET /TiVoConnect?Command=Restart&Container=Settings HTTP/1.1" 200 -
    6529172037INFO:pyTivo.beacon:Unregistering: Z:
    INFO:pyTivo:Last modified: Wed Jan  8 14:46:58 2020
    INFO:pyTivo:python: 2.7.16
    INFO:pyTivo:System: Windows-10-10.0.18362-SP0
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:11] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:11] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:11] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:17] "GET /TiVoConnect?Command=GetLogText&Container=Settings
     
  6. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    Code:
    HTTP/1.1" 200 -
    WARNING:pyTivo.beacon:No TiVos found!
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Z:
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:192.168.0.101 [28/Jan/2020 15:28:54] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=84960119037E1D4 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.106 [28/Jan/2020 15:28:54] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=8496A0190517809 HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:56] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:56] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=Z:\ HTTP/1.1" 200 -
    INFO:pyTivo:'port'
    INFO:pyTivo:'port'
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:59] "GET /TiVoConnect?Command=GetDriveList&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:28:59] "GET /TiVoConnect?Command=GetFileList&Container=Settings&BasePath=Z%3A%5C HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:01] "GET /TiVoConnect?Command=GetFileList&Container=Settings&BasePath=C%3A%5C HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:04] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=C:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:08] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:08] "GET /TiVoConnect?Command=Restart&Container=Settings HTTP/1.1" 200 -
    6529172037INFO:pyTivo.beacon:Unregistering: Z:
    INFO:pyTivo:Last modified: Wed Jan  8 14:46:58 2020
    INFO:pyTivo:python: 2.7.16
    INFO:pyTivo:System: Windows-10-10.0.18362-SP0
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:23] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:23] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=C:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:23] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:26] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:26] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:27] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:28] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:29] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:29] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:29] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:30] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:31] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:31] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:31] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:31] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:31] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:32] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:37] "GET /TiVoConnect?Command=GetLogText&Container=Settings HTTP/1.1" 200 -
    WARNING:pyTivo.beacon:No TiVos found!
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Z:
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:48] "GET /TiVoConnect?Command=GetSettings&Container=Settings HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:48] "GET /TiVoConnect?Command=GetDiskUsage&Container=Settings&Path=C:\ HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:29:48] "GET /TiVoConnect?Command=GetTiVoList&Container=ToGo HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.106 [28/Jan/2020 15:30:07] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=8496A0190517809 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.101 [28/Jan/2020 15:30:07] "GET /TiVoConnect?Command=QueryContainer&Container=Z%3A&ItemCount=0&SerialNum=84960119037E1D4 HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [28/Jan/2020 15:30:19] "GET /TiVoConnect?Command=GetLogText&Container=Settings HTTP/1.1" 200 -
     
  7. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,946
    6,017
    Apr 17, 2000
    Nevada
    It's not finding the TiVos on the network. There is a setting on the network tab called zeroconf try setting it to off and see if that helps.
     
  8. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    You fixed it, Dan. Thank you very much. I troubleshooted my network connection which came back with an error, I googled how to fix the error and now it works.
     
  9. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    After yet another unwanted Windows Update, my PYTIVO is not finding the TIVOS on the network again. I have fiddled around with settings on http://localhost:9032/ and tried stuff on the TroubleShoot - pyTivo - Wiki website, but I can't manage to fix. What worked last time was going to the network connection properties and changing IPv4 and IPv6 to "Obtain IP Address automatically" and "Obtain DNS Server Address automatically." Unfortunately this time, those are already checked.

    Below is the log
     
  10. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    Attached is log
     

    Attached Files:

  11. justen_m

    justen_m Cheesehead

    10,029
    656
    Jan 14, 2004
    Boise, ID
    roll eyes
     

Share This Page