Sudden file transfer failure: kmttg and Tivo Desktop

Discussion in 'TiVo Home Media Features & TiVoToGo' started by howards, Feb 16, 2013.

  1. hershey4

    hershey4 Member

    May 31, 2006
    Red Sox Nation


    I have to add my THANKS to the curl.conf fix and even the timestamp workaround.

    I rarely use my Tivo Desktop (w/S2) to the point that I had disabled all the related services that I felt bogged down my computer needlessly. But today after about 1-2 years of non-use, I had a need to transfer a tivo file so I re-enabled everything and was quite pleased when Desktop started up smoothly and showed me my DVR recordings. But, alas timing is everything!!! The transfer attempt failed. If only I had done this a couple of weeks ago. Nice that the error message was so helpful too (NOT!)

    Fortunately, from previous experiences, I knew to head immediately to TivoCommunity. It took hardly any time to find these threads. Yea!!

    I did the time-stamp workaround reluctantly and a transfer is in progress now. As soon as it completes, I will undo that and try the curl.conf fix. I hope when (if?) TIvo fixes this in its software, the workaround doesn't cause a problem.
  2. jackie moon

    jackie moon New Member

    Mar 3, 2009
    I'm new to windows 8 and I am not able to figure out how to find this curl file. Anyone have any step by step help. Changing the date is causing me all kinds of other problems.
  3. hershey4

    hershey4 Member

    May 31, 2006
    Red Sox Nation
    Are you using Tivo Desktop? I saw on the Tivo website that it is NOT supported for Windows 8.
  4. Puppy76

    Puppy76 Well-Known Member

    Oct 6, 2004
    It works fine for Windows 8 (one of the great things about Windows is how good the backwards compatibility is for not just years, but decades).

    This is a problem with with a date Tivo's using, they need to update it and haven't yet. Simply setting the clock back on your PC "fixes" it, but hopefully they're actually working on a real fix (which should be easy).
  5. sender_name

    sender_name I remember XM 202!

    Feb 11, 2005
    Northboro Ma


    A++++ For the fix
    Came back from a 1 week cruise to find that not only had none of my shows transferred but the dvr ran out of room and recorded over them...This has not been a problem for 8 years and I go away for a week...eccch! And these are shows you can't get off torrents...
  6. alansh

    alansh Active Member

    Jan 3, 2003
    Phoenix, AZ
    Hold down the Windows key and type R. A "Run" box will pop up.

    In the box, put in

    %USERPROFILE%\AppData\Local\TiVo Desktop

    and click OK. Paste it in exactly as above, with the percent signs and USERPROFILE. File Explorer will open up and one of the files will be called curl.conf.

    Double-click on it. When it asks if you want to look online for an app to open it, instead select "more options". From the list that appears, select Notepad. Add the "cookie" line so that it looks like this:
    user-agent = TivoDownloader/0.1
    speed-time = 30
    cookie = "sid=abc"
    Save the file and restart Tivo Desktop.

    Oh, and yes, I can't believe they hardcoded the date, and that it's been there as long as TivoToGo has existed.
  7. malayphred

    malayphred Underpowered User

    Jan 29, 2007
    Las Vegas
    Oh - so NOW you show up.

    Where the hell were you when I was dying???
  8. Corran Horn

    Corran Horn Member

    Feb 12, 2002
  9. steve614

    steve614 what ru lookin at?

    May 1, 2006
    Dallas, TX
    Sucks to be an early adopter, eh? :p
  10. howards

    howards Member

    Oct 31, 2007
    I am using ancient Series 2 with lifetime service, and the latest Tivo Desktop with the curl.conf patch works great.
  11. egg5264

    egg5264 New Member

    Feb 26, 2013
    Morac: Could you please give the steps on how to change this curl setting using the download. Also, how do you backup the current curl setting? I am still new to a lot of the complicated steps. Thanks very much!
  12. jackie moon

    jackie moon New Member

    Mar 3, 2009
    Thanks for the help. Worked like a charm! Now I can have my tivo to go work while still being able to use iTunes.
  13. seattletwodogs

    seattletwodogs New Member

    Aug 21, 2008


    It worked!!!

    Thank you very much for your step by step instructions. I have absolutely no idea whatsoever what I just did and do not quite believe I am seeing the rotating transfer circle as I write this.

    I didn't know "Notepad" from a notebook until following this thread and subsequently reading further in an attempt to reduce my anxiety over destroying my laptop in the effort to accomplish what TiVo has failed to do.

    Your post gave me the confidence needed to make what for me feels like a quantum leap, though as stated above, without any comprehension of what I did. I marvel at how someone such as yourself arrives at a solution that persons at my level can implement.

    Much appreciated. Especially since my unit has a 20 hour HD limit.
  14. rad1701

    rad1701 Member

    Aug 17, 2003
    Morac - thanks a million! You need to work at TIVO (or someone should try working at TIVO - lol!). :)
  15. egg5264

    egg5264 New Member

    Feb 26, 2013
    Thanks MORAC! I had the same problem with the error, " system cannot find the file specified" and was using the procedure of changing the computer's date but other programs did not like the date change. I first tried to add the line to the curl file but I guess since I was running version 2.8.2 it did not work. I then uninstalled, ran the cleaner , and installed 2.8.3 and changed the file with copy and paste and save and it now transfers! We might remind others that the file is a hidden file and you will have to follow steps to unhide hidden files and folders in windows. Thanks again!

  16. windracer

    windracer joined the 10k club

    Jan 3, 2003
    St. Pete, FL
    In case anyone is having this problem with the ToGo app in Galleon (I know at least one person is since they filed a bug on SourceForge), I've managed to make a code fix that seems to resolve it.

    I can't rebuild the entire Galleon package to create a new version, so you can grab the updated jar file here. Rename that file to galleon.jar and drop it into Galleon's /lib directory (you might want to make a backup of the original and your conf/configure.xml file first). Restart Galleon and your ToGo downloads should work again.
  17. Mar 1, 2013 #157 of 212

    holligl Member

    Dec 28, 2004
    Ditto for me. It is truly amazing to me how someone figures this out! Why something works for a long time then quits. Why TiVo offers no solution is equally amazing. Proves the value of these forums.

    Thanks again! Files downloading again.
  18. Mar 1, 2013 #158 of 212

    tivoluvver New Member

    Mar 13, 2003
    Thank you!

    This fixed my situation. This is the first time I have run into this and I was so upset to see this problem going back for five years with enormous numbers of folk having it, wihtout any real fix, until I stumbled upon your post. I have no idea what curl.conf does but the added line fixed it like magic.

    FWIW, the only changes I made my end were to install office365 preimum home edition and to join my machine to a domain as part of a server install at home, just in case this gives anyone else any clues.
  19. Mar 1, 2013 #159 of 212

    lrhorer Active Member

    Aug 31, 2003
    Well, in this case, it was simply due to an embedded "expiration date", if you will, in the code that runs on the TiVos. The so-called Y2K bug was similar, and there are a number of embedded bombs in various codes coming up. For example, in 2036, the UTC timestamp (also known as epoch time) will overflow anywhere it is still maintained on a 32 bit platform. Even the 64 bit timestamp will overflow in another 292 billion years or so. I have freed up my calendar for that week, just in case. :D

    That it does, to be sure.

    Well, the CODE has been in place since 2005. The problem, or its symptoms if you will, did not arise until the calendar date exceeded the time stamp in the code. No user really knew about it until the symptoms appeared a couple of weeks ago, and the developers who input the time stamp into the code had probably forgotten all about it, assuming the ones directly responsible even work for TiVo any longer.

    Curl is a program that automates access to pages on web servers. Basically, it imitates the keystrokes and mouse clicks a human would enter when accessing a web page. In this case, the web page is on the TiVo. The web server built in to the TiVo hosts a secure HTML page which is how programs like TDT, kmttg, Galleon, and pyTivo access the device. Some of those programs, including TDT, use or can use Curl to access the web page.

    'Not related. It started happening once the cookies on the TiVo expired.
  20. Mar 3, 2013 #160 of 212

    ntbert New Member

    Dec 28, 2006
    Thank you for finding this fix and shareing!!

Share This Page

spam firewall