Sudden file transfer failure: kmttg and Tivo Desktop

Discussion in 'TiVo Home Media Features & TiVoToGo' started by howards, Feb 16, 2013.

  1. jlb

    jlb Go Pats!

    Dec 13, 2001
    Burlington, VT


    Well....I did what they said anyways....

    uninstalled 2.6.2, ran the cleaner, installed 2.8.3, patched, and it is working. So I guess a small +1 for support......

    And, it seems like 2.8.3 fires up much faster on my aging XP machine than 2.6.2 did.

    So I guess it all worked out in the long run....
  2. jlb

    jlb Go Pats!

    Dec 13, 2001
    Burlington, VT
    ...aaaaaaand it seems performance of web-based things on the TiVo is better now too.

    Go figure.....
  3. jlb

    jlb Go Pats!

    Dec 13, 2001
    Burlington, VT
    Last post.....sorry about the fragmented thoughts....

    Put I feel like my TiVo is sorta all new again. Being able to flip right to music or Pandora without wondering if it is going to work.....whole new world.....
  4. pnolans

    pnolans New Member

    Dec 16, 2006

    This has got to be the gol-durndest freakin computer bug I've ever seen!!!!!

    And I've only been in this business THIRTY-FIVE YEARS!!!!! Geez...

    Thanks to those who figured it out and shared their findings!!!
    I truly appreciate it .

    I have been using Tivo Desktop since 2006....

    But here's the weird thing: I started having intermittent problems that got more constant about a year ago! And.. the last successful transmissions I had were in January. So, I set the date to 1/1/13 ... and damned if it didn't start working! Edited the curl.conf as "prescribed", and again... it started working.


    Again... thanks!
  5. Jun 2, 2013 #205 of 212

    xanfan New Member

    Jun 2, 2013


    So I finally tried to do the editing to the conf file, but I have a problem. When I load it up in notepad to add the extra line of text, I discovered that the text was already there!

    Any ideas on why it's still not transferring? I can't even transfer anymore if I change the date on the computer! (I'm running 2.8.2 and I have unsuccessfully added the patch that Tivo made available...)
  6. Jun 3, 2013 #206 of 212

    Puppy76 Well-Known Member

    Oct 6, 2004
    Your computer is "seeing" the Tivos, right, and showing you your list of shows to transfer? But it's just failing when you try to transfer?

    I don't think it matters, but 2.8.3 is the newest (actually only available to download for another couple days if I'm remembering right). Maybe try uninstalling and reinstalling that, and then the patch? I'd assume the patch pretty much just adds in that line, which is why it's there. You shouldn't have to edit anything after you install the patch.

    What OS are you running? It's worked fine for me with Windows 7 and 8.
  7. Jun 6, 2013 #207 of 212

    brykasch New Member

    Jun 6, 2013
    I use kmttg and I have the same issue tried switching to java from curl and still does the same thing tried downloading a new version and it never downloads any of the tools. About at the end of my rope trying to get it to work.
  8. Jun 6, 2013 #208 of 212

    jcthorne Well-Known Member

    Jan 28, 2002
    You have the latest version of kmttg? This date issue was solved some time ago.

    Perhaps you need to start fresh and do a complete remove and reinstall of kmttg.
  9. James R. Matey

    James R. Matey New Member

    Dec 25, 2013
    I implemented the curl.conf fix recommended here when my TIVO (HD) failed to make transfers earlier in the year. Thanks for the fix. It worked fine.

    However, the same or a similar problem seems to have recurred sometime in the past month or so. Symptoms are:

    1. Tivo Desktop opens up on PC.
    2. Can browse files on Tivo and select for transfer.
    3. Transfer seems to start, but hangs immediately.
    4. Error message "The network location cannot be reached ..." is displayed on the transfer status window.

    I've tried:

    A. Reboot of everything -- PC, router, switch, TIVO had no effect.
    B. Setting PC date to 2012, had no effect; the curl.conf file has the recommended fix.
    C. Accessing the Tivo from Firefox or IE and attempting to download from there -- again fails on a hang.
    D. Different files, different size files -- no effect.
    E. Can ping the Tivo from the PC
    F. The PC has
    Win 7 sp1
    Tivo Desktop 2.8.3
    Hardwired (during testing) internet connection

    Can anyone offer suggestions for diagnostics that would help me figure out what is going wrong?

    Has anyone heard of similar problems that are not fixed by the curl.conf modification?

    PS -- I checked at the TIVO end on the diagnostics page. It acknowledges that the transfer started at 10 MB/s, but that nothing got transferred.
  10. morac

    morac Cat God TCF Club

    Mar 14, 2003
    No need to bump this old thread as the initial problem has been patched in the TiVo software on all TiVo models. The problem you are having must be unrelated.
  11. unitron

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    Are you using fixed IP addresses for everything on your network that doesn't leave the house?

    Can't hurt.
  12. techspai

    techspai New Member

    Jan 22, 2014
    I applied Morac's fix in the curl.conf file, and did a couple other changes that seem to help.
    Tried transfers from browser as proof of my tivo network setup and consistently got "too many transfer in progress" failures. Looked like my series xfers were constantly running and failing in rotation.
    I had noticed that when I setup series transfers in my desktop settings, that tivo tries to transfer something like 3 shows of the series at a time. One seems to get the most resource then fails. A third program is then added to the queue and the first in line get resources then fails etc etc.
    Once I did Morac's fix I then turned off series xfers and things may be working again. Time will tell.


    Ok, I managed to download 3 one hour shows using TiVo Desktop 2.8.3 last night. I did have a couple failures too between successful downloads. Still cannot download from the browser. I can see the programs, but when I click through one of the show .MPG-PS I get an immediate

    Server Busy
    too many transfers in progress

    All my problems with TiVo transfers started about a year ago and gradually got worse. At least got a couple to work, but probably never get back to the old unattended transfers.

    Why is this software from a device vendor so difficult? Doesn't seem like it should have this many issues.

Share This Page

spam firewall